Linux Guest - Chrome issues

Discussions about using Linux guests in VirtualBox.

Linux Guest - Chrome issues

Postby girishd » 22. Oct 2013, 12:00

Steps taken to reproduce bug
  • Launch Google Chrome in Linux guest virtual machine
  • Navigate to Gmail
  • Google Chrome freezes after a couple of seconds

This only happens when I have the "Enable 3D Acceleration" box checked.

Environment Details - Host
Windows 8.1 (64-bit)
VirtualBox 4.3.0 r89960
12GB RAM

Environment Details - Guest
Xubuntu 13.10 (64-bit)
VirtualBox Guest Additions 4.3.0 r89960
6327MB RAM

I have attached the following in the zip file
  • VirtualBox Log
  • Output of VBoxManage showvminfo
  • Output in terminal when I run google-chrome on my guest OS (Xubuntu)

The two ways I can get around this for now are
  • Disable 3D Acceleration
  • Launch google-chrome in Xubuntu with the following switch "--blacklist-accelerated-compositing"

Also, my host OS keeps crashing with the following error message "CRITICAL_STRUCTURE_CORRUPTION". But looking at the other thread on this forum, it seems like you guys have fixed this with 4.3.1 r90098. Anyway, will be great if you guys can fix this OpenGL (??) problem....I kept thinking it was something to do with my guest OS and I've installed/uninstalled 3 distros (Linux Mint, Ubuntu, Xubuntu) over the past 5 hours only to realize it had something to do with VirtualBox.

Thanks,
Girish
Attachments
VirtualBox-ChromeError.zip
(133.95 KiB) Downloaded 36 times
Last edited by girishd on 26. Oct 2013, 05:58, edited 1 time in total.
girishd
 
Posts: 1
Joined: 22. Oct 2013, 11:22

Re: Linux Guest - Chrome issues

Postby Royce » 24. Oct 2013, 06:40

You're not alone. I had the same issue with Chromium browser. Temporary workaround was to disable hardware acceleration in advanced settings of Chromium.

My experience so far is that 3d acceleration in VBox is buggy!
Royce
 
Posts: 20
Joined: 27. Jun 2013, 09:25

Re: Linux Guest - Chrome issues

Postby ChrisRus » 13. Dec 2013, 04:56

Code: Select all   Expand viewCollapse view
locate google-chrome.desktop


Add --blacklist-accelerated-compositing to the three exec lines in google-chrome-desktop.

Worked for me. See beshoy-dot-girgis-dot-us 2012/11 blog post for details (where I got this tip).
ChrisRus
 
Posts: 7
Joined: 13. Dec 2013, 04:50
Primary OS: Mac OS X other
VBox Version: OSE Debian
Guest OSses: Debian, CoreOS

Re: Linux Guest - Chrome issues

Postby socratis » 13. Dec 2013, 08:29

ChrisRus wrote:locate google-chrome.desktop
Add --blacklist-accelerated-compositing to the three exec lines in google-chrome-desktop.
Worked for me. See beshoy-dot-girgis-dot-us 2012/11 blog post for details (where I got this tip).

I can post URLs, so I'll make it easier for the rest of the community to find what you meant: http://beshoy.girgis.us/2012/11/. Just to add to this, I'm running a WinXP VM with IE6 (yes, I know, it's sick). I haven't touched IE (besides basic updates), just in case that someone is still running it and I want to be able to test some client's website. If I'm not fast enough to disable 3D hardware acceleration in IE, the VM needs a restart...

Nice catch for a 1st post!!!
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 16775
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Linux Guests

Who is online

Users browsing this forum: Baidu [Spider] and 7 guests