VM extremely slow, running on green turtle

Discussions related to using VirtualBox on Windows hosts.
Locked
Matt St-L
Posts: 2
Joined: 15. Jun 2020, 14:31

VM extremely slow, running on green turtle

Post by Matt St-L »

Good day all,

I copied this working VM from my other laptop, kept the same settings, disabled Hyper-V and Device Guard. All Virtualization options are Enable into BIOS.

When loading it keeps running on Native API, no Nesting therefore, unusable. See screenshot.

I've attached the log file in zip.

Need assistance, Thank you!
Attachments
VM Screenshot.PNG
VM Screenshot.PNG (41.04 KiB) Viewed 36588 times
VM5-2020-06-15-10-37-02.zip
(44.38 KiB) Downloaded 89 times
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: VM extremely slow, running on green turtle

Post by scottgus1 »

Your log still contains these lines:
{timestamp} HM: HMR3Init: Attempting fall back to NEM: VT-x is not available
{timestamp} NEM: WHvCapabilityCodeHypervisorPresent is TRUE, so this might work...

So something requiring Hyper-V is still running.

To turn Hyper-V off completely, do this:

1. Shut down all programs. You will have to reboot your host.

2. Look into I have a 64bit host, but can't install 64bit guests, 2nd post, points 2 & 3 and ensure that none of these things are running.

3. Find the Command Prompt icon, right click it and choose Run As Administrator.

4. Enter this command:
bcdedit /set hypervisorlaunchtype off
5. Enter this command:
shutdown -s -t 2
6. When the computer turns off, unplug it for 20 seconds. Then plug it in again and boot up Windows 10.

Your Virtualbox should be running now. If the green turtle still appears and the tell-tale lines are in the log, try all the steps again. If you don't get the standard virtualization icon, post back exactly what you did and we'll try to help some more.

For further info, see https://www.tenforums.com/tutorials/139 ... puter.html
Matt St-L
Posts: 2
Joined: 15. Jun 2020, 14:31

Re: VM extremely slow, running on green turtle

Post by Matt St-L »

Hi Scott, I did all of the above from that post before posting my issue. It still runs on that green turtle after all. :?
Any other idea?

Thanks!
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: VM extremely slow, running on green turtle

Post by scottgus1 »

Regrettably, no. Hyper-V slows down the guest, and the 64-bit tutorial has absolutely everything we know about how to shut off Hyper-V. If you still have the green turtle, then Hyper-V is still enabled, and either Microsoft has come up with something new, or there's something in the tutorial that got missed.
Navjo0910
Posts: 1
Joined: 21. Sep 2020, 10:40

Re: VM extremely slow, running on green turtle

Post by Navjo0910 »

I have the same issue, I have tried every thing to disable Hyper-V, but the green turtle is still present ...
Did you find any solution to disable it ?
Thanks
Martin
Volunteer
Posts: 2561
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: XP, Win7, Win10, Linux, OS/2

Re: VM extremely slow, running on green turtle

Post by Martin »

Follow the instructions from the second post in this thread completely. ;)
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: VM extremely slow, running on green turtle

Post by scottgus1 »

Martin wrote:Follow the instructions from the second post in this thread completely.
Hear hear!

Navjo0910, if you decide to glom onto someone else's topic, it is good to read the thread and implement the suggested solutions first. Like this one:
scottgus1 wrote:the 64-bit tutorial has absolutely everything we know about how to shut off Hyper-V.
which should handle:
Navjo0910 wrote:Did you find any solution to disable it ?
vaisov
Posts: 1
Joined: 23. Oct 2020, 14:00

Re: VM extremely slow, running on green turtle

Post by vaisov »

Here's what helped in my case (I can't paste URLs as I'm too new member, so I'll describe how to find the solution):
  1. Google for "Disable Windows Defender Credential Guard by using the HVCI and Windows Defender Credential Guard hardware readiness tool" - it should link you to microsoft website
  2. Copy contents of script

    Code: Select all

    DG_Readiness_Tool_v3.6.ps1
    (the link should be in the first link) to the file
  3. Run powershell as administrator
  4. Run the file with script content:

    Code: Select all

    PowerShell.exe -ExecutionPolicy Bypass -File .DG_Readiness_Tool_v3.6.ps1 -Disable
  5. Restart your PC
  6. Upon reboot it'll ask you if you want to disable Credential Guard - hit F3
  7. Hit F3 for the second question as well and voila, after booting there'll be no more green turtle
Make sure that you really don't need Defender Credential Guard before applying this changes!

I was running powershell a bit differently, so in my case I solved no execution issue with

Code: Select all

Set-ExecutionPolicy -Scope Process -ExecutionPolicy Bypass
[/i]
BillG
Volunteer
Posts: 5106
Joined: 19. Sep 2009, 04:44
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows 10,7 and earlier
Location: Sydney, Australia

Re: VM extremely slow, running on green turtle

Post by BillG »

Yes, Credential Guard is another of the long list of things which prevent VirtualBox from accessing the hardware virtualization capabilities of the CPU.
Bill
svobora
Posts: 1
Joined: 17. Mar 2021, 18:40

Re: VM extremely slow, running on green turtle

Post by svobora »

I would like to point out that also having "Windows Subsystem For Linux" Windows Feature turned on causes the green turtle and in my case inability to start 64bit Ubuntu system. The answer "Disable Hyper-V" in every green turtle thread was not very helpful, because how should I know which features use Hyper-V? Hyper-V feature itself was disabled the whole time.
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Linux

Re: VM extremely slow, running on green turtle

Post by scottgus1 »

svobora wrote: The answer "Disable Hyper-V" in every green turtle thread was not very helpful, because how should I know which features use Hyper-V? Hyper-V feature itself was disabled the whole time.
The linked tutorials in all those topics explain to not bother with the "Features" list, since there are so many things that try to use Hyper-V, and rather offer a method ("bcdedit" etc.) to kill Hyper-V off at the root, rather than try to waste time attempting to prune all the branches.
Locked