SATA controller crashing my OpenSolaris Virtual Machine.

Discussions about using Solaris guests in VirtualBox.

SATA controller crashing my OpenSolaris Virtual Machine.

Postby IAmBill » 10. Sep 2008, 16:53

I get a critical error when enabling the SATA controller in my Virtual Machine settings. OpenSolaris is already installed and is currently connected through the IDE controller. I'd like to switch it to the SATA controller however, just enabling the controller causes VirtualBox to crash when attempting to load the operating system. My guess is that the driver is not set up properly. I do have the Intel AHCI driver that I need (for x64) in /kernel/drv/amd64/ahci. However, I don't no how to enable to driver to load with no SATA controller connected to the system.

If anyone has had a similar issue, please consult.

Thank you.

HOST: Microsoft Windows Vista Ultimate 64-bit
GUEST: Sun Microsystems OpenSolaris 2008.05
IAmBill
 
Posts: 29
Joined: 6. Sep 2008, 21:30

Postby rlk » 21. Sep 2008, 23:57

I have the same issue; running OpenSolaris in 64-bit mode (under OpenSUSE 11.0 with kernel 2.6.25.16-0.1-default) gives me a critical error if I enable the guest SATA controller. I can run fine in 32-bit mode (with VT-x disabled) with SATA enabled, but not with both SATA and VT-x enabled.

Presumably this is either a VirtualBox or an OpenSolaris bug. Have you checked the bug databases?
rlk
 
Posts: 8
Joined: 21. Sep 2008, 23:27

Postby rlk » 22. Sep 2008, 00:25

I've filed bug 2292 for this, since I couldn't find anything that looked like a match. You may want to add a note about observing it under Windows too. I suggest including detailed hardware configuration of the host in case it's relevant.
rlk
 
Posts: 8
Joined: 21. Sep 2008, 23:27

Re: SATA controller crashing my OpenSolaris Virtual Machine.

Postby nnnnnk » 29. May 2009, 20:23

To fix problem it' enough to reinstall grub.

I have booted from live cd in console mode, and then typed as root:

zpool import
// remember cXtXdXsX from output
zpool import -f rpool
mkdir /a
zfs set mountpoint=legacy rpool/ROOT/opensolaris
mount -F zfs rpool/ROOT/opensolaris /a
cd /a/boot/grub
installgrub stage1 stage2 /dev/rdsk/cXtXdXsX
reboot

That's all, and now it works :)

Regards,
Nick.
nnnnnk
 
Posts: 2
Joined: 29. May 2009, 20:16
Primary OS: OpenSolaris 11
VBox Version: OSE other
Guest OSses: opensolaris


Return to Solaris Guests

Who is online

Users browsing this forum: No registered users and 0 guests