VirtualBox fails to start, assertion failure

Discussions related to using VirtualBox on Windows hosts.

VirtualBox fails to start, assertion failure

Postby lwesker » 3. Sep 2008, 01:52

With a fresh install of VirtualBox VirtualBox-1.6.6-Win_x86.msi (and also with v1.6.4) on an XP SP3 host, I get the following when I try to run it:

Could not create the VirtualBox home directory 'V:\\.VirtualBox'(VERR_ACCESS_DENIED).

Nothing in the documentation says the V: drive must be free or mapped to anything specific, but I dismounted it anyway and then receive the following:

Failed to create the VirtualBox COM object.
Assertion failed at 'C:\vbox\branch\w32-1.6\src\VBox\Main\VirtualBoxImpl.cpp' (288) in VirtualBox::init.

Unknown exception.
Please contact the product vendor!


I get the same errors using: vboxmanage createvm -name test

If I map V: to a writeable share, and run VirtualBox, I get the same assertion failed message, but a directory V:\.VirtualBox is created containing VirtualBox.xml, but said XML file will not load into XMLnotepad. It was corrupted by a hex 00 byte being inserted at the end of the file. The XML also references an obsolete web site.

<?xml version="1.0" encoding="UTF-8" ?>
<!-- Sun xVM VirtualBox Global Configuration -->
<VirtualBox xmlns="http://www.innotek.de/VirtualBox-settings" version="1.3-windows">
<Global>
<MachineRegistry/>
<DiskRegistry/>
<USBDeviceFilters/>
<SystemProperties/>
</Global>
</VirtualBox>


No forum pages seem to help. All other COM problems were different from this. I have no problems starting VBoxSvc.exe in a DOS window, but once started, it disappears when an above error message occurs.

It is odd that a .VirtualBox directory is trying to be accessed on a fixed drive letter, in a way that is totally undocumented. There is also some legacy innotek stuff that has not been fully cleaned up.

I am guessing this problem is due to conflicts with other stuff installed on my machine. Otherwise, a lot more people would be seeing this. Any ideas what is wrong?
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

Postby TerryE » 3. Sep 2008, 03:01

If you open a CMD box and do set | find "HOME", what do you get?

Also the XML must reference the DTD and this is still maintained at the referenced URL. It's not an obsolete reference.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Site Moderator
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

Postby lwesker » 3. Sep 2008, 17:28

Yes, HOME was set to V:. Probably legacy from when I played with CygWin. That explains the first part of the problem with looking for V:.

Unfortunately, the bigger problem of the assertion failure still exists. I even did an uninstall, cleaned up all traces of VirtualBox in the registry, made sure HOME was not set, and reinstalled. The problem still exists.
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

Postby TerryE » 3. Sep 2008, 17:36

No, you missed my shorthand. I asked "what do you get", and in my case I get
    HOMEDRIVE=D:
    HOMEPATH=\Documents and Settings\terrye
. You change these through the Environment settings in Computer->Properties. This is why your install is not working.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Site Moderator
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

Postby lwesker » 3. Sep 2008, 18:46

I get:

HOMEDRIVE=U:
HOMEPATH=\


For me, these are not defined in the Environment Settings. They are defined by the Domain Server login script. This machine is XP Pro in a Win 2003 domain environment. I don't know how to override or block execution of the login script.

In any event, the above definition is valid as U:\ is a writable network share on the domain, so unless the program prevents use of network shares for configuration data, it should have worked.

I would think the better Windows default should have been
%USERPROFILE%\.VirtualBox instead of
%HOMEDRIVE%%HOMEPATH%\.VirtualBox,
as the later variables have meaning to other applications but the USERPROFILE variable is specific and fixed and can't be wrong (in a bootable XP).

Per the documentation, I defined VBOX_USER_HOME to the path: C:\Documents and Settings\lwesker\.VirtualBox. However the program still fails to start. Next, I will uninstall/reboot/reinstall with the variable defined and comment further if that changes anything.


Checking in another direction, I looked at the OSE source code for the failure line number and found it is commented out code:

280 /* check hard disk consistency */
281 /// @todo (r=dmik) add IVirtualBox::cleanupHardDisks() instead or similar
282 // for (HardDiskList::const_iterator it = mData.mHardDisks.begin();
283 // it != mData.mHardDisks.end() && SUCCEEDED (rc);
284 // ++ it)
285 // {
286 // rc = (*it)->checkConsistency();
287 // }
288 // CheckComRCBreakRC ((rc));


Is it possible that this code is active, but broken, in the FPUE code?
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

Postby Sasquatch » 3. Sep 2008, 19:03

You can't really compare the two with the source code, as the OSE has some parts removed that the PUEL version does have (like USB support). Because of this difference, code lines are different.

Best thing to do, is look for your .virtualbox folder and remove any files from it (or remove the whole folder). That way, you will start with a clean Machine.xml file.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby lwesker » 3. Sep 2008, 19:27

I gussed as much, but it was interesting that line 288 is a call to handle errors and since the only stuff ahead of it was initialization, it appeared that maybe they were somewhat comparable.

The only thing inside .VirtualBox is the VirtualBox.xml. I have deleted that several times to no avail. The program never gets to the point of creating any machine XML files as it crashes on startup.

Setting VBOX_USER_HOME also has no impact. I am starting to think we are drifting in the wrong direction here, which started with the fact that HOME being defined overrode the HOMEPATH and HOMEDIR, even though that is not documented for Windows installs. I even tried setting HOME to the desireable path, also to no avail.

I think the original idea path is concluded and the problem is now something different, to do with the COM subsystem. Does anyone have access to v1.6.6 FPUE code that can check what is happening at line VirtualBoxImpl.cpp (288)?
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

Need guidance to isolate cause of Assertion Failure at start

Postby lwesker » 5. Sep 2008, 05:28

When I said the original idea path was concluded, I didn't mean that the issue is done. I spent the last two days trying very hard to find the problem, googleing for anything related to COM susbsystem diagnostics or repair. I think I read evey VirtualBox forum post with the COM error mentioned and nothing is related.

Updating to v2.0.0, the problem still exists, but the message is now:
Assertion failed at 'C:\vbox\32\w32-rel\src\VBox\Main\VirtualBoxImpl.cpp' (301) with result code E_FAIL (0x80004005).

I have done installs on other machines in my reach and have no problems. This problem seems to be solely unique to this one machine. Unfurtunately, this is the machine I have to get this running on. That being said, I need clues from VirtualBox developers to help me pinpoint the problem, as everything else about my machine appears to be functioning normally. Maybe there is a debug version or something that dumps a trace file you guys could send me.

I tried to run with nearly all services and startup programs disabled and still get the assertion failure on startup. Similarly I stripped all extraneous environment variables and still no change. I also did a full registry cleanup. So I can't isolate this to any particular program conflict.

Please, special versions of VirtualBox, pointers to MS tools and web pages, or something to diagnose what broken would be greatly appreciated.
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

VBox 2.0.0 fails to start on vista

Postby cstrack » 5. Sep 2008, 13:47

I installed vbox 2.0.0 on vista.

After starting vbox the message is:
Assertion failed at 'C:\vbox\32\w32-rel\src\VBox\Main\VirtualBoxImpl.cpp' (301) with result code E_FAIL (0x80004005).

Any idea what is wrong?
cstrack
 
Posts: 1
Joined: 5. Sep 2008, 13:40

Postby itxpurts » 5. Sep 2008, 15:09

I had the same problem.
All i did was went to the compatability tab of the Properties of the icon and select "Run as Administrator" and it now works...

Alf
itxpurts
 
Posts: 1
Joined: 5. Sep 2008, 15:05

Postby lwesker » 8. Sep 2008, 16:54

This topic began with an XP SP3 host install of VirtualBox and a untraceable COM problem. Install issues and potential solutions for Vista are unrelated and probably should have started a different topic.

The solution indicated had no effect on the original XP host problem.
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02

Postby lwesker » 8. Sep 2008, 20:32

I finally found Ticket #1655 which described my problem. Apparently tickets don't show up under forum or google searches, so I didn't find the ticket until I went to file one myself.

The conflict resolution reported by "andrei.tulai" (having an attached USB drive), was also verified the same as my problem. The original ticket issuer "cubsftw" did not reply if it solved his problem or not.

Simply remove the external USB drive and the program starts. Have the drive attached and the program does not start. If VirtualBox is running (even with an empty list of machines) and plug in the USB device, VirtualBox immediately crashes in vboxrt.dll. Interesting this problem does not occur on my other host computer with attached USB drives.

I am glad to see it is not corruption on my computer, although it cost me two days trying to find some type of corruption. I am disappointed that such a severe showstpper bug such as this was reported 3 months ago and not fixed, causing other customers to repeat the same headaches.

I am adding more detail to ticket #1655 with the crash message information.
lwesker
 
Posts: 7
Joined: 2. Sep 2008, 21:02


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 27 guests