F8 key EULA confirmation with Silver Keyboard

Discussions related to using VirtualBox on Mac OS X hosts.

F8 key EULA confirmation with Silver Keyboard

Postby giversen » 15. Aug 2008, 17:01

When installing Windows XP I need to F8 to accept EULA, and this MAC (new mac pro) flat silver keyboard will not seem to send F8 with any combination of shift/control/option/command key pressing.

Any ideas?

Gary
giversen
 
Posts: 6
Joined: 15. Aug 2008, 16:49

Postby h1d » 15. Aug 2008, 17:03

Sounds like same issue against 2 posts below? :roll:

http://forums.virtualbox.org/viewtopic.php?t=8660
h1d
Volunteer
 
Posts: 170
Joined: 3. Jul 2008, 02:10

Same problem - different fix?

Postby giversen » 15. Aug 2008, 17:57

I would embrace the simple thought that I didn't press the shift/control/option/command key combo. That does not seem to be the case!

In all cases pressing f8 causes the pause on my iTunes instead, and I was careful to be sure the keyboard capture was on in the virtual box. (My left command button is the keyboard/mouse capture hot key).
giversen
 
Posts: 6
Joined: 15. Aug 2008, 16:49

Postby h1d » 15. Aug 2008, 18:24

isn't this all about pressing the 'Fn' key together?
h1d
Volunteer
 
Posts: 170
Joined: 3. Jul 2008, 02:10

Fn Key

Postby giversen » 15. Aug 2008, 18:57

I have the shift-control-option(alt)-command keys on my keyboard, but no FN key (might call it the F'n key at this point :wink: ). No combination works. I saw another posting somewhere where virtual box may not pass many function keys, even if un-selecting the auto capture option.
giversen
 
Posts: 6
Joined: 15. Aug 2008, 16:49

Temporary Solution

Postby giversen » 15. Aug 2008, 19:00

My temporary solution for now was to login from another computer using logmein. Then it recognized the F8 key from the remote PC keyboard, so it is definitely a keyboard issue.
giversen
 
Posts: 6
Joined: 15. Aug 2008, 16:49

Function Keys on Mac...

Postby amagine » 15. Aug 2008, 19:14

Sounds like you have the same keyboard I have,
since you mentioned iTunes popping up...

This is where you would use the second suggestion from:

http://forums.virtualbox.org/viewtopic.php?t=8660

Open System Preferences.app (located in Utilities folder of Applications folder)

Select Keyboard & Mouse preferences

Under the Keyboard tab,

look for a check box in the center of the window which toggles:

Use all F1, F2, etc. keys as standard function keys...


There is a button at the bottom left of this window also, "Modifier Keys..."

which lets you make action changes. (good to know if a little rascal has been messing with your Mac ;) )

If the above is not your solution, we can sleuth to the next level...[/quote]
amagine
Volunteer
 
Posts: 177
Joined: 28. Jul 2008, 19:52

Success!

Postby giversen » 15. Aug 2008, 19:22

Thank you for helping me navigate to the solution - that did the trick! :D
giversen
 
Posts: 6
Joined: 15. Aug 2008, 16:49


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: No registered users and 7 guests