Shared Folder Mount

Discussions about using Linux guests in VirtualBox.

Shared Folder Mount

Postby Walot » 12. Aug 2008, 18:29

:roll: Hi, Host is Win XP Prof, Guest is openSuse 11.0, VBox is 1.6.4

nach langem Basteln I've got defined the shared folder in XP!? I'm not sure wether correct or not.

For mounting the shared folder in Suse I used a command line I found in a forum, which however was meant for UBUNTU. What happened shows the following protocol:

linux-3yfc:/home/WOSCH # sudo mount -t \vboxsf Brief-VB /mnt/Brief
mount: wrong fs type, bad option, bad superblock on Brief-VB,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so

linux-3yfc:/home/WOSCH #

dmesg | tail shows the following:

linux-3yfc:/home/WOSCH # dmesg | tail
SFW2-INext-DROP-DEFLT-INV IN=eth0 OUT= MAC=08:00:27:e6:9e:38:52:54:00:12:35:02:08:00 SRC=62.245.157.209 DST=10.0.2.15 LEN=40 TOS=0x00 PREC=0x00 TTL=255 ID=4934 PROTO=TCP SPT=80 DPT=11479 WINDOW=0 RES=0x00 ACK RST URGP=0
SFW2-INext-DROP-DEFLT-INV IN=eth0 OUT= MAC=08:00:27:e6:9e:38:52:54:00:12:35:02:08:00 SRC=62.245.157.209 DST=10.0.2.15 LEN=40 TOS=0x00 PREC=0x00 TTL=255 ID=4976 PROTO=TCP SPT=80 DPT=11481 WINDOW=0 RES=0x00 ACK RST URGP=0
SFW2-INext-DROP-DEFLT-INV IN=eth0 OUT= MAC=08:00:27:e6:9e:38:52:54:00:12:35:02:08:00 SRC=62.245.157.209 DST=10.0.2.15 LEN=40 TOS=0x00 PREC=0x00 TTL=255 ID=4977 PROTO=TCP SPT=80 DPT=11481 WINDOW=0 RES=0x00 ACK RST URGP=0
vboxvfs: sf_glob_alloc: vboxCallMapFolder failed rc=-102
sf_read_super_aux err=-71
vboxvfs: sf_read_super_aux: no mount info specified
sf_read_super_aux err=-22
SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=10.0.2.15 DST=224.0.0.251 LEN=64 TOS=0x00 PREC=0x00 TTL=255 ID=0 DF PROTO=UDP SPT=5353 DPT=5353 LEN=44
vboxvfs: sf_read_super_aux: no mount info specified
sf_read_super_aux err=-22
linux-3yfc:/home/WOSCH #
-------
Any idea what I have to change?
Thanks for help
Walot
 
Posts: 8
Joined: 12. Aug 2008, 14:41

Postby Sasquatch » 13. Aug 2008, 15:06

Try the mount command without the \ after -t ;). Run
Code: Select all   Expand viewCollapse view
sudo mount -t vboxsf sharefolder /mnt/point

This is described nicely in the manual.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Shared Folder Mount

Postby Walot » 14. Aug 2008, 18:48

:arrow: Hi Sasquatch, thanks for the answer but this I tried rightaway after the first one failed. I did it again today and you can see, the result is the same. I wundered wether the phrase ".run" in your example had been of any relevance and so I tried this as well. Again with no success:
-------
WOSCH@linux-3yfc:~> sudo mount -t vboxsf Brief-VB /mnt/Brief
mount: wrong fs type, bad option, bad superblock on Brief-VB,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so

WOSCH@linux-3yfc:~> sudo mount -t vboxsf Brief-VB /mnt/Brief.run
mount: Einhängepunkt /mnt/Brief.run existiert nicht
WOSCH@linux-3yfc:~>
-------
Any further hint?
Walot
 
Posts: 8
Joined: 12. Aug 2008, 14:41

Postby TerryE » 14. Aug 2008, 19:56

The codepage might be a clue. Is this a charset issue. Do you have utf8 loaded? if not you may need to specify a different iocharset or convertcp parameter with a -o option.
Read the Forum Posting Guide
Google your Q site:VirtualBox.org or search for the answer before posting.
TerryE
Volunteer
 
Posts: 3572
Joined: 28. May 2008, 08:40
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu 10.04 & 11.10, both Svr&Wstn, Debian, CentOS

How to use the shared folder

Postby Walot » 14. Aug 2008, 20:57

Hi TerryE, either my English is to bad or my knowledge of Linux! I dont understand anything what you mean!!

If you can, explain it in German or more detailed please
Walot
 
Posts: 8
Joined: 12. Aug 2008, 14:41

Postby Sasquatch » 14. Aug 2008, 22:27

It means that the character encoding used is not the same as the character encoding on the shared folder. If you for example use ISO-8891-1 on the Host, but mount it using UTF-8 on the Guest, you will get an error, or problems opening/saving files.

One thing I would do, is create a simple named shared folder, like "test", no upper case characters or other special characters. See if that works first.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

How to use the shared folder

Postby Walot » 17. Aug 2008, 18:05

:? Hallo Sasquatch, thanks for the explanation. I tried that as you can see, but the simple "brief" didnt help either. I renamed/recreated both host-folder and mount point:

linux-3yfc:/home # sudo mount -t vboxsf brief /mnt/files
mount: wrong fs type, bad option, bad superblock on brief,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen – versuchen
Sie dmesg | tail oder so

linux-3yfc:/home #

fs type means file system?? In my case it is FAT32
bad option: I have no idea what option could be wrong or what other option could be used.
What is the "superblock" on my host-partition/folder?
Walot
 
Posts: 8
Joined: 12. Aug 2008, 14:41

How to use the shared folder

Postby Walot » 17. Aug 2008, 18:55

annex:

:?: About the character encoding: How can I compare or display the encoding types? :?:
Walot
 
Posts: 8
Joined: 12. Aug 2008, 14:41

Postby Sasquatch » 17. Aug 2008, 20:49

The character encoding is one of the errors that's possible. If you read the error more carefully, you see that you have the following options as the problem:
  • Wrong filesystem chosen;
  • Wrong option chosen (though you didn't supply one, this is not it);
  • Bad superblock on the share (meaning cluster size in Windows terms);
  • Missing codepage or helper program;
  • A different error than mentioned above;

Now, are you sure it's a Shared Folder you set and not a network share? And does the mount point actually exists? You do have a folder /mnt/files? The location where you mount drives and shares have to exists, it cannot be created while mounting.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Re: Shared Folder Mount

Postby Chrimson » 13. Oct 2010, 14:14

Hi,

in case

sudo mount -t vboxsf source /mnt

does not work and gives you

mount: wrong fs type, bad option, bad superblock on ...,
missing codepage or helper program, or other error
(for several filesystems (e.g. nfs, cifs) you might
need a /sbin/mount.<type> helper program)

Try:

sudo /usr/sbin/mount.vboxsf source /mnt

It worked for me in openSuse(guest) on MacOSX(host).

Greetz\c
Chrimson
 
Posts: 1
Joined: 13. Oct 2010, 14:06
Primary OS: Other
VBox Version: OSE other
Guest OSses: Linux/Win


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 12 guests