Windows xp in virtualbox on ubuntu =100% cpu

Discussions related to using VirtualBox on Linux hosts.

Windows xp in virtualbox on ubuntu =100% cpu

Postby greekman12 » 27. Jun 2008, 06:56

Hi,

I've set up windows xp in a vm on Ubuntu 8.04. The install works, but as soon a s windows boots the CPU utilization goes to 100% and stays there. I've tried disabling usb, cd-rom options....any ideas what I can do to prevent this?

Thanks.
greekman12
 
Posts: 7
Joined: 25. Jun 2008, 00:10

Postby AlGaN » 27. Jun 2008, 11:06

same with me. I installed VB 1.6.2 recently and started a Windows XP image created with 1.5.6, as soon as Windows starts, CPU load reaches 100% forever.

Some users said this is due to crappy ACPI of windows, but I had activated ACPI support in 1.5.6 without any problems... :(

I'd be looking forward to a fix/workaround for this major issue...

Thanks,
AlGaN
AlGaN
 
Posts: 22
Joined: 18. Jun 2008, 11:11
Location: Germany
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Windows XP SP3

Windows xp in virtualbox on ubuntu =100% cpu --- SOLVED

Postby greekman12 » 27. Jun 2008, 22:36

I've found a solution for my laptop.

I re-created the VM and disabled acpi, then re-installed windows. Now the cpu utilization is way down. Granted, I have one core active in the vm, but it's much more responsive.





[/quote]
greekman12
 
Posts: 7
Joined: 25. Jun 2008, 00:10

Postby kyboren » 30. Jun 2008, 04:35

AlGaN wrote:same with me. I installed VB 1.6.2 recently and started a Windows XP image created with 1.5.6, as soon as Windows starts, CPU load reaches 100% forever.

Some users said this is due to crappy ACPI of windows, but I had activated ACPI support in 1.5.6 without any problems... :(

I'd be looking forward to a fix/workaround for this major issue...

Thanks,
AlGaN

The problem is not activating support in the VM manager -- you need to swap out the Windows kernel for one that doesn't use ACPI.

Your CPU will, by default, prompt Windows to load the ACPI-enabled SMP kernel. So when you switch to having Windows virtualized, this kernel remains and uses some ACPI registers that have severe virtualzation penalties (it talks to the BIOS). The solution is to force Windows to stop doing that. You can do this by going to Device Manager (right click on My Computer -> Hardware -> Device Manager), expanding 'Comptuer', right-clicking 'ACPI Multiprocessor PC', select 'Update Driver...', choose manual installation, from a list, and select 'Standard PC'.

Then you're set :)
kyboren
 
Posts: 6
Joined: 25. Jun 2008, 04:08


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 24 guests