[Solved] seamless mode is grayed out & not available

Discussions related to using VirtualBox on Windows hosts.

[Solved] seamless mode is grayed out & not available

Postby mkamoski » 11. Sep 2015, 20:56

Dear VirtualBox Pros --

Please help.

For me, Seamless Mode is grayed out and not available.

I have tried many fixes suggested on the internet, and nothing seems to work.

The Host can run in 1980x1080 so that is what I want the guest to do.

Right now I can either run the VM in Full Screen Mode (in which case the screen is only running 1582x789 as its highest resolution) or I can run in Scaled Mode (which stretches the 1582x789 and everything is distorted).

Here are the details so far....

I am running Windows 10 on the Host, the physical machine itself.

I am running Windows 8.1 in the Guest, the VM itself.

I am running "VirtualBox 5.0.2r102096".

On the VM I have the following file...

c:\VBoxGuestAdditions_5.0.2.iso

On the VM, I have chosen > Devices, > Insert Guest Additions CD Image, and I have run the install, and it reports the install was successful, and yes I rebooted.

Now, when the VM boots, Windows File Explorer mounts the ISO correctly (it seems) and in File Explorer it says...
CD Drive (D:) VirtualBox Guest Additions

But in the VM's "Devices" menu it always says...
Insert Guest Additions CD Image
...and so it looks like the VM does not recognize the ISO as mounted.

I read about a fix via setting the Windows AutoPlay options, so I have set all AutoPlay options in the VM to always try to play automatically...
...but that has not helped.

I read about a fix via adding a custom resolution via the command line, so I tried adding custom resolution by using the cmd window...
VBoxManage.exe setextradata "MyVm1" CustomVideoMode1 "1920x1080x32"
...but that has not helped.

I made a guess and I tried setting VM with Maximum Guest Screen Size to "Hint" and then putting in Width=1920 and Height=1080....
...but that has not helped.

I read about the video memory needing to be greater than 8mb or something so in the Host I checked...
> Settings, > Display, > Screen, > Video Memory
...and the slider was set to max, 128mb....
...but that has not helped.

I read about turning off Nested Paging, so I went here...
> System, > Settings, > Acceleration, > Enable Nested Paging = Unchecked
...but that has not helped.

So now I am stuck and out of ideas and things to try, and BTW I am pretty much a newbie to VirtualBox.

Please send along any guesses, hints, suggestions, etc.

Does anyone know how to get this Seamless Mode thing working?

Please advise.

Thanks.

-- Mark Kamoski
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: seamless mode is grayed out & not available

Postby mpack » 11. Sep 2015, 22:56

Post a VM log file: with the VM fully shut down, right click it, save "VBox.log" (ONLY) to a zip, and attach the zip here.
mpack
Site Moderator
 
Posts: 30713
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: seamless mode is grayed out & not available

Postby mkamoski » 14. Sep 2015, 15:50

mpack wrote:Post a VM log file: with the VM fully shut down, right click it, save "VBox.log" (ONLY) to a zip, and attach the zip here.


mpack (and all) --

Ok, here is the log attached as...

MKAMOSKI-VM-01-2015-09-14-09-41-17.zip

...and if you (or anyone) can help then that would be greatly appreciated.

Thanks.

-- Mark Kamoski
Attachments
MKAMOSKI-VM-01-2015-09-14-09-41-17.zip
(23.08 KiB) Downloaded 45 times
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: seamless mode is grayed out & not available

Postby mpack » 14. Sep 2015, 17:06

I see this in the log :-

VBox.log wrote:00:00:54.294584 VMMDev: Guest Log: VBoxMP::DriverEntry: VBox WDDM Driver for Windows 8 version 5.0.2r102096, 64 bit; Built Aug 13 2015 17:29:40
00:00:54.294749 VMMDev: Guest Log: VBoxMP::DriverEntry: OsVersion( 6, 3, 9600 )
00:00:54.296517 VMMDev: Guest Log: VBoxMP::VBoxMpCrCtlConConnectHgcm: WARNING! :vboxCrCtlConConnect failed, rc (-3302)
00:00:54.296550 VMMDev: Guest Additions capability report: (0x0 -> 0x0) seamless: no, hostWindowMapping: no, graphics: no
00:00:54.296824 VMMDev: Guest Log: VBoxMP::VBoxMpCrCtlConInit: VBoxMpCrCtlConConnectHgcm failed with rc(0), 3D not supported!
00:00:54.296894 VMMDev: Guest Log: VBoxMP::DriverEntry: 3D is NOT supported by the host, falling back to display-only mode..
00:00:54.308734 GUI: UISession::sltAdditionsChange: GA state change event came, notifying listeners.


Now, this could mean that your host graphics drivers really don't support OpenGL (required for 3D acceleration in a VirtualBox VM), or it could mean that your host graphics DLLs are unsigned. Either way, you should check for graphics driver updates. You can also turn off 3D acceleration in the VM settings.

I don't know that this is your cause, but it seems reasonable to me that if this problem causes it to fall back to a more basic operation, then that may not include support for transparent guest desktops, A.K.A. seamless mode.
mpack
Site Moderator
 
Posts: 30713
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: seamless mode is grayed out & not available

Postby mkamoski » 14. Sep 2015, 18:19

mpack --

Ok, so In VirtualBox, in the host, with my VM powered off, when right-click my VM and choose "Settings", I have...

> System, >Acceleration, > Hardware Virtualization, > Enable VT-x/AMD-V = Checked

...and also...

> Display, > Screen, > Acceleration, > Enable 3D Acceleration = Checked

...so...

...I did try checking "Enable 3D Acceleration" and then staring the VM but the VM then started with a blank screen, so that did not work...

...so it is looking like maybe my host's video capabilities do not support seamless-mode for the VM?
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: seamless mode is grayed out & not available

Postby mpack » 15. Sep 2015, 10:30

Seamless mode doesn't require a specific capability from the hosts graphics drivers other than a transparent blit.

As I said, check for host graphics driver updates. Early driver package releases often have glitches such as bugs in OpenGL, or missing certification.
mpack
Site Moderator
 
Posts: 30713
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: seamless mode is grayed out & not available

Postby mkamoski » 15. Sep 2015, 18:32

mpack wrote:Seemless mode doesn't require a specific capability from the hosts graphics drivers other than a transparent blit.

As I said, check for host graphics driver updates. Early driver package releases often have glitches such as bugs in OpenGL, or missing certification.




Pretty sure it is NOT the host's video drivers, it is a very modern NVIDIA graphics card, and a modern laptop, and Open GL is not so modern and widely supported, so it would be weird if it were not supported in NVIDIA, plus as to "unsigned" or "missing certification", I see no evidence of that, and have scoured Device Manager and other locations looking for such, but all drivers seem pristine and up-to-date, as far as I can tell.

But...

Just to be sure, I updated all drivers on my host machine, updating to latest-and-greatest from the manufacturer, fully patched, rebooted, etc.

Still seamless mode is grayed out on the VM.

Also, tried some more experiments, as follows...

With VM off, in VirtualBox manager on the host, I selected the VM and then choose > Settings, > Display, > Acceleration, and I tested each of the following combinations...


Test1Params: > Enable 3d Acceleration = NotChecked, > Enable 2d Video Acceleration = NotChecked

Test1Result: > SeamlessMode=NotWorking (grayed out), FullScreenMode=Working, ScaledMode=Working


Test2Params: > Enable 3d Acceleration = Checked, > Enable 2d Video Acceleration = NotChecked

Test2Result: > SeamlessMode=NotWorking (grayed out), FullScreenMode=NotWorking (screen blank), ScaledMode=NotWorking (screen blank)


Test3Params: > Enable 3d Acceleration = Checked, > Enable 2d Video Acceleration = Checked

Test3Result: > SeamlessMode=NotWorking (grayed out), FullScreenMode=NotWorking (screen blank), ScaledMode=NotWorking (screen blank)


Test4Params: > Enable 3d Acceleration = NotChecked, > Enable 2d Video Acceleration = Checked

Test4Result: > SeamlessMode=NotWorking (grayed out), FullScreenMode=Working, ScaledMode=Working


So, basically, Seamless Mode is still not working.

If anyone has any fix or workaround or suggestion to get Seamless Mode working, then please let me know, and all help is appreciated.

Thanks.

-- Mark Kamoski
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: seamless mode is grayed out & not available

Postby mkamoski » 22. Sep 2015, 15:31

All --

FYI, it seems that I have found the issue that was causing VirtualBox Guest Additions to not work on Windows 8.1 for me, which was causing Seamless Mode to be unavailable and was causing clipboard sharing to not work, and etc.

While investigating something else, I happened to launch the Windows 8.1 Task Manager, and I was browsing the Startup tab there, and I noticed this...

VirtualBox Guest Additions Tray Application with Status = Disabled

...well, I had not seen that item until now, so I definitely did not set it to Disabled manually, so maybe Windows was being "safe" and installed it but did not enable it, or something, but...

...the happy news is that I simply Enabled that Tray Application and rebooted the VM and now everything works just fine...

Thanks for all your help.

-- Mark Kamoski
Last edited by mkamoski on 22. Sep 2015, 20:37, edited 2 times in total.
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: seamless mode is grayed out & not available

Postby mpack » 22. Sep 2015, 15:40

mkamoski wrote:...the happy news is that I simply Enabled that Tray Application and rebooted the VM and now everything works just fine.

Can you explicitly confirm that seamless mode now works, since that was the subject of this topic?
mpack
Site Moderator
 
Posts: 30713
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: seamless mode is grayed out & not available

Postby mkamoski » 22. Sep 2015, 19:26

Yes, I confirm that Seamless Mode now works for me.
mkamoski
 
Posts: 18
Joined: 11. Sep 2015, 20:22
Location: ZULU-0500
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 8.1 + ETC

Re: [Solved] seamless mode is grayed out & not available

Postby ggdogg » 13. Aug 2016, 07:40

FYI, it seems that I have found the issue that was causing VirtualBox Guest Additions to not work on Windows 8.1 for me, which was causing Seamless Mode to be unavailable and was causing clipboard sharing to not work, and etc.

While investigating something else, I happened to launch the Windows 8.1 Task Manager, and I was browsing the Startup tab there, and I noticed this...

VirtualBox Guest Additions Tray Application with Status = Disabled


I have been struggling for 6 hours with this. Host is Win 7, Guest is Win xp. I have run Guest Additions setup, it completes setup and I restart. After reboot the Guest Additions icon is not in the taskbar tray, and taskbar is configured to SHOW Disabled applications. I have followed all the attempts that mkamoski has made.

I am desperate at this point to solve this problem and ungray-out SEAMLESS MODE and AUTO-RESIZE Guest Display.

I am new to VBox and not especially savy with windows so I have to research nearly every attempt and all jargon.

Your help is appreciated
ggdogg
 
Posts: 9
Joined: 13. Aug 2016, 07:30

Re: [Solved] seamless mode is grayed out & not available

Postby ggdogg » 13. Aug 2016, 08:30

After reboot the Guest Additions icon is not in the taskbar tray, and taskbar is configured to SHOW Disabled applications.


Is there any other way to verify that Guest Additions is set up but perhaps not enabled?
ggdogg
 
Posts: 9
Joined: 13. Aug 2016, 07:30

Re: [Solved] seamless mode is grayed out & not available

Postby mpack » 13. Aug 2016, 09:32

Look in "Installed Apps" for the VirtualBox Guest Additions to see if they're installed. Most often they simply aren't (some people think mounting the CD == running the installer, despite autorun being deprecated since Vista). If they're installed then look in the task list to see if they're running.
mpack
Site Moderator
 
Posts: 30713
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: [Solved] seamless mode is grayed out & not available

Postby ggdogg » 13. Aug 2016, 21:40

@mpac, As an inexperienced user, I don't know where "Installed Apps" is in WinXP, but it is not in the list of apps in "add or remove applications" and it is not found in task manager.
ggdogg
 
Posts: 9
Joined: 13. Aug 2016, 07:30

Re: [Solved] seamless mode is grayed out & not available

Postby ggdogg » 13. Aug 2016, 21:42

Do you know how or why it is not installed and how to remedy it? I can't find an answer and I've spent many hours on this.
ggdogg
 
Posts: 9
Joined: 13. Aug 2016, 07:30

Next

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Google [Bot] and 50 guests