ipod touch / iphone (virtualbox v1.5.4 winXP client)

Discussions about using Windows guests in VirtualBox.

ipod touch / iphone (virtualbox v1.5.4 winXP client)

Postby ijmiller » 29. Dec 2007, 19:12

I've verified that v1.5.4 fixed an issue which caused v1.5.2 to abort when mounting an ipod touch (Ticket #827). iTunes now seems to be giving me issues when trying to connect to the ipod touch:

"iTunes could not connect to the iPhone "" because an unknown error occurred (0xE8000001)"

After doing some research it seems that this problem occurs for people using usb 1.1, or trying to connect through passive usb 2.0 hub (when not using visualization). I am currently running Ubuntu 7.10 (gusty gibbon) and have usb 2.0 ports. If anyone experiences this issue and finds a work around, please list the fix. Thanks!
ijmiller
 
Posts: 3
Joined: 29. Dec 2007, 18:59

Same with me

Postby AndreasBank@gmx.de » 29. Dec 2007, 20:41

I encountered the exactly same problem!

Any ideas?
AndreasBank@gmx.de
 
Posts: 4
Joined: 29. Dec 2007, 20:33

Postby phillc » 29. Dec 2007, 21:05

I have not much constructive to add here, except "me too!"

I have upgraded to VirtualBox 1.5.4. It no longer crashes but does produce the error described above.

I am using an iPhone, not an iPod Touch. My phone has firmware 1.1.2 and has not been unlocked/jailbroken.

I am running a Windows XP SP2 guest on my Ubuntu Gutsy 7.10 machine.
phillc
 
Posts: 2
Joined: 29. Dec 2007, 21:01

Postby sandervl » 30. Dec 2007, 11:12

Known problem. We haven't had time yet to investigate. Since I own an iPhone, I'll look at it eventually. :)
sandervl
Volunteer
 
Posts: 1064
Joined: 10. May 2007, 10:27
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Windows, Linux, Solaris

Postby stefan.becker » 30. Dec 2007, 11:51

If you have USB-Problems, then give the same hardware to sandervl as christmas present :)

@innotek: great job! great product! happy new year!
stefan.becker
Volunteer
 
Posts: 7046
Joined: 7. Jun 2007, 21:53

Postby Smerlok » 15. Jan 2008, 16:56

Same problem:
"iTunes could not connect to the iPhone "" because an unknown error occurred (0xE8000001)"

Windows XP SP2 guest on Ubuntu Gutsy 7.10 on VirtualBox 1.5.4
and an Ipod Touch fw 1.1.2 jailbroken.
Any news?
Smerlok
 
Posts: 3
Joined: 15. Jan 2008, 16:52

Postby morgewan » 16. Jan 2008, 01:49

Sigh, I was hoping this would work. Bad Apple!!! :-)

Same issue here as well:
Windowx XP SP2 guest on Kubuntu Gusty 7.10 under VirtualBox 1.5.4
jailbroken iPhone with firmware 1.1.1
morgewan
 
Posts: 2
Joined: 16. Jan 2008, 01:44

Bueller? Bueller? Bueller? (iPhone woes)

Postby morgewan » 23. Jan 2008, 02:19

Bouncing this up... Does anyone else care about this working? I am more than willing to donate hardware, time, or funds to get this worked on...

Does anyone know the history behind this issue, or it's current status. It seems like something that should just work out of the box.

I really don't want to go back to having XP on a separate partition....

Thanks!
David Morgan
morgewan
 
Posts: 2
Joined: 16. Jan 2008, 01:44

vmware has the same problem

Postby ijmiller » 25. Jan 2008, 05:17

As of today (Jan 24th 2008) it seems as though vmware has the same issue:
http://communities.vmware.com/thread/91 ... &start=120

I wouldn't be surprised if the two groups are waiting on a kernel patch before they can release their fixes. Else, the problem is a bit bigger than it originally seemed...
ijmiller
 
Posts: 3
Joined: 29. Dec 2007, 18:59

Postby Smerlok » 21. Feb 2008, 11:07

Any news with the 1.5.6 release???
Smerlok
 
Posts: 3
Joined: 15. Jan 2008, 16:52

re: 1.5.6

Postby ijmiller » 21. Feb 2008, 18:21

I haven't had a chance to test it yet. There is nothing in the change logs which would lead me to believe that its been fixed.
ijmiller
 
Posts: 3
Joined: 29. Dec 2007, 18:59

Postby dchill42 » 23. Feb 2008, 05:20

I've experienced this same problem with my iPod video and a WinXP client using 1.5.4 on Ubuntu 7.10. I've been waiting patiently, hoping sandervl would work it out soon. It's been a couple of months, now, and there doesn't seem to be anything new. I see 1.5.6 has been released, but the notes don't mention iPod or USB or anything related.

*twiddles thumbs and waits some more*
dchill42
 
Posts: 3
Joined: 23. Feb 2008, 05:10

Postby onero » 24. Feb 2008, 12:07

Nope, I just tried with Virtualbox 1.5.6, no luck :( This is probably the last reason I'm even booting into Windows, so I really hope this gets fixed soon :D
onero
 
Posts: 5
Joined: 29. May 2007, 13:04

Postby dchill42 » 24. Feb 2008, 17:53

Yeah, that's about it. I use iTunes, occasionally Flash, and I test web development in IE 6 and 7 (have to support the poor fools who don't know any better).

In VirtualBox, my iPod is generally recognized - I get the disconnect hardware icon and all, but it hoses iTunes. I've tried plugging in before launching iTunes, as well as once the program is running - it doesn't seem to make any difference.

I guess if DRM goes away completely, Apple might stop trying to prevent the open source community from replicating their software, but that doesn't seem to be happening any faster than getting my iPod to work in VirtualBox.

This one defect aside, I absolutely love VirtualBox and will gladly use it until the cows come home. I just hope they can fix this issue somewhere in the forseeable future.
dchill42
 
Posts: 3
Joined: 23. Feb 2008, 05:10

Same thing

Postby Jsewill » 22. Mar 2008, 10:29

I am experiencing the same issue with my IPOD touch:

iTunes could not connect to the iPhone~because and unknown error occurred (0xE8000001).
Jsewill
 
Posts: 2
Joined: 22. Mar 2008, 10:25

Next

Return to Windows Guests

Who is online

Users browsing this forum: Bing [Bot] and 18 guests