PPTP connection does not work...

Discussions about using Windows guests in VirtualBox.

PPTP connection does not work...

Postby DocB » 16. Nov 2007, 19:53

I've set up a XP/SP2 guest with all latest patches on a SuSE 10.3 Server.

From the XP host I try to connect to a VPN using the build-in PPTP. It connects to the server, verifies user and PW, and then hangs...until it comes back with an error 619. I've checked user and PW for correctness.
Using a dedicated VPN client (Nortel Contivity) to connect to a different VPN, it works fine. Just this freaking PPTP thing is not working.

Any idea what the problem could be? From native XP it works out of the same network.

Thx!
DocB
 
Posts: 64
Joined: 16. Nov 2007, 19:48

Postby sion2k » 19. Nov 2007, 14:30

I've been having a similar issue, and have a suggestion and would like to propose a question at the same time.

I have gutsy gibbon(ubuntu 7.10) running fully updated w/ virtualbox running WinXP SP2 as a guestOS. Before I installed the virtualbox Guest Additions I created two VPN connections to diff. networks I work with on a regular basis. Everything worked as it should very seamless. The firewall was manually turned off, and both connections had shortcuts on the desktop.

Now I installed the Additions to get the integrated mouse/keyboard action going, and on reboot there was only one VPN connection. Apparently the second connection had been deleted, and only one remained both in Net Connections and on the desktop. When I try and connect to the remaining VPN it connects and times out on Verification. Maybe im missing something in the setup, but it seams as if the Additions are presumably changing something in the Net setup as well. Another interesting point is that if I try and uninstall the Additions the system crashes on some sort of Kernel like panic that Microsoft vaguely attempts to describe, but in any case I guess the only alternative is to re-install the guestOS.

DocB:
I'd say try and reinstall your XP and see if the VPN works out of the box, and see if you have the same results as I do. Maybe we can get something going. Let me know. I'm going to reinstall and check to see what the actual differences are.

As far as researching the problem I did do a search on the forum and didn't come up with much, but maybe I missed something in the manual. If I find anything interesting I'll post it on here.

--Sion
sion2k
 
Posts: 1
Joined: 19. Nov 2007, 14:19

Postby DocB » 20. Nov 2007, 17:32

Sion,
a good point. I've setup a new vbox with XP/SP2, without innotek-extentions, but that did not solve the problem. Same result as before.

The counterpart for the VPN mentioned it might be a firewall problem, but I dont feel so. As long as innotek has not introduced a 'glitch' for normal PPTP-connections, i dont think that an additional NAT-translation will change much....but in fact I dont know exactly
DocB
 
Posts: 64
Joined: 16. Nov 2007, 19:48

Postby Ryushin » 15. Jan 2008, 21:50

The issue is Virtualbox does not know how to NAT GRE packets which PPTP uses. It looks like it only NAT's TCP packets from what I can tell. I haven't tried any UDP yet so I don't know about that. When VMWare first came out they didn't NAT GRE either. It wasn't until version 3 did they add that functionality. I don't know when/if Virtualbox is going to add support for that.
Ryushin
 
Posts: 1
Joined: 15. Jan 2008, 21:24


Return to Windows Guests

Who is online

Users browsing this forum: slicendice and 13 guests