Constant CPU utilization of 20-40%

Discussions about using Linux guests in VirtualBox.

Constant CPU utilization of 20-40%

Postby wwestra » 10. Nov 2007, 16:56

I am runing Virtualbox 1.5.2 on a Linux host, Ubuntu 7.10 32 bits
2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux


The cpu utilization on the host is always at least 20-30% when the guest is running.

The guest itself is idle 0-1 % utilization.
Guest addons installed
Guest OS Suse Linux Enterprise 10 SP1

Anybody else having the same problem ?
Or even better a solution ?

Regards,

Wijnand.
wwestra
 
Posts: 2
Joined: 10. Nov 2007, 16:44

Postby the4thchild » 11. Nov 2007, 00:23

I've seen this as well with a Windows XP SP2 guest on Fedora 7/8 host. People have mentioned using the nohz=off boot option for what appear to be similar problems, although I have yet to get it working for me:

http://forums.virtualbox.org/viewtopic.php?t=1189
the4thchild
 
Posts: 27
Joined: 10. Sep 2007, 05:30
Location: San Francisco, CA
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: MS Windows Vista, MacOS Snow Leopard, Ubuntu 9.10

Postby wwestra » 11. Nov 2007, 20:07

I have seen the posts with references to the nohz=off option.
Tried it, didn't fix the problem.

The posts with the nohz=off option seems to fix issues with virtualbox 1.40.

I am running virtualbox 1.52.

Maybe, just maybe vb 1.5.2 is not ready for the tickless kernel.
I hope they fix this bug soon, 20-30% utilization is no fun at all.
wwestra
 
Posts: 2
Joined: 10. Nov 2007, 16:44

Same Problem here

Postby semidark » 28. Nov 2007, 16:08

Same Problem here

Vbox 1.5.2 (1.5.0 had even 50% - 60% Host CPU Usage)

Host: windows XP SP2
Guest: Linux SuSE 9.3

Guest CPU load is almost 0% but VirtualBox.exe uses 20-40% of the Host CPU.

nohz=off did not do the trick.

Is there a Solution?

Greetz SemidarK
semidark
 
Posts: 1
Joined: 28. Nov 2007, 15:54

Postby jcat » 7. Feb 2008, 15:03

Seems like you have to recompile your guests kernel tu use a Timer Frequency of 100Hz, nothing more than that.

I had it set to 1000Hz, but re-compiled to 100Hz. Host CPU before was around 40% with the guest idle, and afterwards it is about 5% on idle.



Cheers,
jcat
jcat
 
Posts: 6
Joined: 6. Feb 2008, 19:23

Postby the4thchild » 8. Feb 2008, 02:22

Is there a solution for WinXP guests? I don't know of a way to adjust the timer frequency in Windows.
the4thchild
 
Posts: 27
Joined: 10. Sep 2007, 05:30
Location: San Francisco, CA
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: MS Windows Vista, MacOS Snow Leopard, Ubuntu 9.10

Postby jcat » 8. Feb 2008, 17:03

Only Microsoft can recompile the NT kernel.

If you get this high host cpu usage with a windows guest that that seems idle, then that must be due to another issue.


Cheers,
jcat
jcat
 
Posts: 6
Joined: 6. Feb 2008, 19:23

Win2003 Guest, Ubuntu Gutsy Host

Postby bundabrg » 22. Feb 2008, 04:11

I can confirm that I also get the result.

I run V7.10 Gutsy X86_64 on the host, on an AMD that supports hardware virtualization. My guest in this case is a Windows 2003 server.

I have tried the following: -

    Enabling and Disabling Hardware Virtualization
    Using the GUI virtualbox and VBoxVRDP


In all cases, the cpu load in the guest is 1-2%, whereas the host has a continuous 25-30%

Before I ran this under VirtualBox, I was running this exact same image with KVM (qemu) on the same machine and it ran with less than 1% CPU when the guest was idle. All I did was convert the qcow2 image to Raw, then convert it to VDI, then boot it.

Guest Additions have been installed with no difference.

Clipboard is disabled.

Something is not right.

Brilliant product apart from this however! Props to the developers.

If it helps (the developers that is!) I can make available both the virtual machine and the host (VRDP for the guest, NX for the host) for test purposes.

Brendan Grieve
bundabrg
 
Posts: 47
Joined: 22. Feb 2008, 04:01

Postby bundabrg » 23. Feb 2008, 09:57

I have posted a bug (as far as I can see there is no duplicate as the others are for linux guests or windows hosts.).

http://www.virtualbox.org/ticket/1233
bundabrg
 
Posts: 47
Joined: 22. Feb 2008, 04:01

Postby litemotiv » 4. Mar 2008, 12:11

any news on this?

i'm experiencing the same problem with a windows xp guest, constant 10-20% host cpu usage(virtualbox 1.5.6).

very annoying, i didn't have this before ~1.5/1.5.2
litemotiv
 
Posts: 4
Joined: 29. Jun 2007, 16:29

Postby the_ghost » 30. Mar 2008, 16:30

very similiar thing happening to me with virtualbox.exe, just the usage is not constant it goes to 20% then it drops after a while and goes up again while the guest load is 0 (load average: 0.00, 0.00, 0.00)

Virtualbox 1.5.6
Host: win2k3, 4GB RAM, amd x2 4200+
guest: Linux version 2.6.18-6-486 (Debian 2.6.18.dfsg.1-18etch1) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 Sun Feb 10 22:06:33 UTC 2008
the_ghost
 
Posts: 1
Joined: 26. Mar 2008, 21:26

Postby the4thchild » 2. Apr 2008, 10:04

I had this problem before, but it seems to have disappeared over the past several weeks. I wonder if perhaps the upgrade to kernel 2.6.24 made the difference? I don't recall the upgrade to VB 1.5.6 alone making the improvement. But now with the combo of kernel 2.6.24 plus VB 1.5.6 with WinXP guest on Fedora 8 host, I see ~5% idle CPU usage rather than the 30-40% I saw previously. Anyone know what might have done the trick?
the4thchild
 
Posts: 27
Joined: 10. Sep 2007, 05:30
Location: San Francisco, CA
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: MS Windows Vista, MacOS Snow Leopard, Ubuntu 9.10

try to look at this

Postby helledi » 3. Apr 2008, 14:36

helledi
 
Posts: 10
Joined: 2. Apr 2008, 10:57


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 32 guests