Arch Linux (ide-lagacy comment)

Discussions about using Linux guests in VirtualBox.

Arch Linux (ide-lagacy comment)

Postby psi » 24. Oct 2007, 12:20

I see on the http://www.virtualbox.org/wiki/Guest_OSes page it is mentioned that Arch Linux works fine but,
"Installation has to be booted with the ide-legacy option." Perhaps Arch does not work at all if one doesn't use
this option when using a previous version of VirtualBox (I'm using 1.5.2), or it works but gives an error as set out below.

When I do not use ide-legacy, the entire installation proceeds without any problems, however, after the first reboot
it seems the kernel wants to mount root on hda and not sda as it should when using PATA.

I then booted into my freshly installed system using the Arch Core CD :

arch root=/dev/sda3

and it worked prefectly. A subsequent reboot failed again, looking for root on hda3. So long story short; I booted
back into system using the Arch Core CD and rebuilt the kernel image with :

# mkinitcpio -p kernel26

That seems to have fixed it and it's now using PATA and looking for root on sda. One can of course just
change the sda references in grub to hda or as innitially said, boot with ide-lagacy, but I didn't want to
do either :). The vanilla Arch Installation disk does build the kernel with PATA, but it doesn't seem to work
the first time in VirtualBox. Of course, YMMV on all of this ;)
psi
 
Posts: 2
Joined: 24. Oct 2007, 12:07

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 8 guests