Ubuntu Gutsy - USB not working

Discussions related to using VirtualBox on Linux hosts.

Ubuntu Gutsy - USB not working

Postby sensimilla » 19. Oct 2007, 10:17

After upgrading from Feisty to Gutsy whenever I access the settings or start a machine I get the following error:

Could not load the Host USB Proxy Service (VERR_FILE_NOT_FOUND). The service might be not installed on the host computer.

Result Code:
0x80004005
Component:
Host
Interface:
IHost {81729c26-1aec-46f5-b7c0-cc7364738fdb}
Callee:
IMachine {31f7169f-14da-4c55-8cb6-a3665186e35e}

I have tried 1.50 and 1.52 same result.
I have edited the /etc/udev/rules.d/40-permissions.rules to change group ownership of usb devices as reccomended here:
http://www.virtualbox.org/wiki/USB_on_Ubuntu_7.04
All was working well under Feisty.

Anybody got any ideas how to fix this ?
sensimilla
 
Posts: 5
Joined: 19. Sep 2007, 10:04

Postby rcdeacon » 19. Oct 2007, 12:22

I have the exact same problem. Hopefully there is a solution out there somewhere.
rcdeacon
 
Posts: 8
Joined: 18. Oct 2007, 18:33
Location: Murfreesboro, N.C.

Postby sandervl » 19. Oct 2007, 14:31

Ubuntu removes usbfs in Gutsy. We rely on that for USB, so currently there's no easy solution. Perhaps you can compile it back into the kernel.

OpenSuse once tried the same thing until they realized it was a very bad idea. (it also breaks VMWare)
sandervl
Volunteer
 
Posts: 1064
Joined: 10. May 2007, 10:27
Primary OS: MS Windows Vista
VBox Version: PUEL
Guest OSses: Windows, Linux, Solaris

Postby sensimilla » 19. Oct 2007, 15:36

Ok, think I may have found the answer here:

http://www.virtualbox.org/ticket/747

I'll reproduce it here.

You need to edit an init script:
Code: Select all   Expand viewCollapse view
sudo gedit /etc/init.d/mountdevsubfs.sh

Then look for the following:
Code: Select all   Expand viewCollapse view
    #
    # Magic to make /proc/bus/usb work
    #
    #mkdir -p /dev/bus/usb/.usbfs
    #domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
    #ln -s .usbfs/devices /dev/bus/usb/devices
    #mount --rbind /dev/bus/usb /proc/bus/usb

Remove the #'s from the last four lines so it looks like this :
Code: Select all   Expand viewCollapse view
    #
    # Magic to make /proc/bus/usb work
    #
    mkdir -p /dev/bus/usb/.usbfs
    domount usbfs "" /dev/bus/usb/.usbfs -obusmode=0700,devmode=0600,listmode=0644
    ln -s .usbfs/devices /dev/bus/usb/devices
    mount --rbind /dev/bus/usb /proc/bus/usb

Reboot

This seems to have fixed the issue for me.
sensimilla
 
Posts: 5
Joined: 19. Sep 2007, 10:04

Postby incunabulum » 19. Oct 2007, 17:16

Works for me, too! Thanks for the tip!

btw - a /etc/init.d/mountdevsubfs.sh start works for me :-)

cu, mz
incunabulum
 
Posts: 3
Joined: 30. Aug 2007, 14:09

Postby rcdeacon » 19. Oct 2007, 22:01

This fix SORT OF worked for me. Now I can see usb under "settings" but when I start xp all of the usb devices are grayed out. Not sure what that problem is but we are making headway. Any ideas?
rcdeacon
 
Posts: 8
Joined: 18. Oct 2007, 18:33
Location: Murfreesboro, N.C.

Postby grahams1 » 20. Oct 2007, 23:49

thanks, this worked for me also.

tip for getting xp to see the usb devices. The 1st time I enable a usb device
Device > USB Device, my XP guest saw the device but them failed to install. I disable the device in VB and then re-enabled and Xp them saw it correctly.
grahams1
 
Posts: 5
Joined: 9. Oct 2007, 21:07

Postby matthew_eli » 21. Oct 2007, 22:01

rcdeacon wrote:This fix SORT OF worked for me. Now I can see usb under "settings" but when I start xp all of the usb devices are grayed out. Not sure what that problem is but we are making headway. Any ideas?


same problem:

Code: Select all   Expand viewCollapse view
Not permitted to open the USB device, check usbfs options.


Codice&nbspd'uscita:
0x80004005
Componente:
Console
Interfaccia:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}
matthew_eli
 
Posts: 5
Joined: 21. Oct 2007, 18:29

Postby sensimilla » 22. Oct 2007, 07:10

I think you have to follow the procedure described here for 7.04 to change the usb filesystem permissions.

http://virtualbox.org/wiki/USB_on_Ubuntu_7.04

I'll quote it here for convenience

--

Contributed by Ibrahim Ben Faruhn, 2007/06/14

After I had a taken a look into the insides of Ubuntu 7.04, I managed to get VirtualBox's USB-Support working there in such a way that the user only needs to be a member of a group called usbusers. This howto describes how I did it.

Basically, you just have to tell Ubuntu that a group called usbusers should have read and write access to all usb devices.

1. Create a group called usbusers

2. Add yourself to this group

3. Edit the file /etc/udev/rules.d/40-permissions.rules (for this, you must have administrative privileges)

3.1 Search for the following lines
Code: Select all   Expand viewCollapse view
# USB devices (usbfs replacement)
SUBSYSTEM=="usb_device",                    MODE="0664"


3.2 Change them to the following
Code: Select all   Expand viewCollapse view
# USB devices (usbfs replacement)
SUBSYSTEM=="usb_device", GROUP="usbusers", MODE="0664"


4. Restart your PC

5. You should now have write access to all usb devices.
sensimilla
 
Posts: 5
Joined: 19. Sep 2007, 10:04

Postby matthew_eli » 22. Oct 2007, 08:13

I fix the problem with the USB:

first i use the code of the first post of this thread;

then i use the code of this site:

http://danieleparlante.wordpress.com/2007/07/30/risolvere-i-problemi-tra-virtualbox-e-lusb/

and now the USBs works perfectly!

I hope this will help.

Bye
matthew_eli
 
Posts: 5
Joined: 21. Oct 2007, 18:29

Postby rcdeacon » 22. Oct 2007, 11:36

Sorry, but I was having difficulty trying to sort out the fix posted by matthew_eli. I AM NOT bilingual. Can someone point me to the fix in English?
rcdeacon
 
Posts: 8
Joined: 18. Oct 2007, 18:33
Location: Murfreesboro, N.C.

Postby rcdeacon » 22. Oct 2007, 12:02

OK, just for the record I finally got usb working! The trick for me was to make a new group called "usbusers" as someone posted. Thanks for steering me in the right direction.
rcdeacon
 
Posts: 8
Joined: 18. Oct 2007, 18:33
Location: Murfreesboro, N.C.

Postby jhouse59 » 28. Oct 2007, 02:58

sensimilla wrote:




1. Create a group called usbusers

2. Add yourself to this group

3. Edit the file /etc/udev/rules.d/40-permissions.rules (for this, you must have administrative privileges)

3.1 Search for the following lines
Code: Select all   Expand viewCollapse view
# USB devices (usbfs replacement)
SUBSYSTEM=="usb_device",                    MODE="0664"


3.2 Change them to the following
Code: Select all   Expand viewCollapse view
# USB devices (usbfs replacement)
SUBSYSTEM=="usb_device", GROUP="usbusers", MODE="0664"


4. Restart your PC

5. You should now have write access to all usb devices.

Instead of creating a group called usbusers. I just used my user name. That worked for me. I'm using Mint 3.1 Celena.
jhouse59
 
Posts: 55
Joined: 10. Sep 2007, 07:01

Postby RichTJ99 » 3. Nov 2007, 21:06

Thanks, this was helpful to me as well.
RichTJ99
 
Posts: 13
Joined: 3. Nov 2007, 06:13

easiet fix on 7.10 Gutsy

Postby 52rockwell » 4. Nov 2007, 04:09

This is a really easy fix
http://ubuntuforums.org/showthread.php? ... ualbox+usb
------------------------------------------
Courtesy of STEVE1961 on ubuntuforums.org

or just add this line to /etc/fstab

none /proc/bus/usb usbfs devgid=1002,devmode=664 0 0

the devgid number is the vboxusers group id (check to see if yours is different)

Once you've saved and closed fstab just do a sudo mount -a and you should be good to go.
__________________
52rockwell
 
Posts: 1
Joined: 4. Nov 2007, 03:54

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 5 guests