"Loading please wait" on Ubuntu VirtualBox on Wind

Discussions related to using VirtualBox on Windows hosts.

"Loading please wait" on Ubuntu VirtualBox on Wind

Postby abcuser » 10. May 2007, 20:50

Hi,
1. On Windows XP SP2 I installed VirtualBox 1.3.8 product.
2. I created virtual machine (linux 2.6) and setup virtual disks and CD mounted.
3. Inserted Ubuntu 7.04 Desktop into CD drive and start booting.
4. Ubuntu first window start up. But first option"Start or install Ubuntu" doen't work it hangs after few seconds displaying "Loading please wait..."
5. I have rebooted virtual machine and from start up menu selected "Start Linux in save graphic mode". Ubuntu was up and running. I successfully installed Ubuntu.
6. After installation Ubuntu requires to reboot. Now the same problem appears: "Loading please wait..." - it looks like Ubuntu would like to run in normal graphic mode - but as I understand it should run in "save graphic mode" - how to overcome this problem and how to just start successfully installed Ubuntu.

Any idea?
Thanks,
Abcuser
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby abcuser » 10. May 2007, 21:46

I have successfully start up Ubuntu from recovery console. Ubuntu was up and running - I started Firefox and went to internet.

But I don't know which key I have pressed on recovery console. I just pressed random keys :(

So I have rebooted, but just don't know what key I have pressed - it looked like as changing fonts (from bold to non bold) - it looks like changing terminal settings or something like that. Can someone help me out what key I have pressed? I know I am very very very close to solution...
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby abcuser » 10. May 2007, 22:17

Ok, I have been trying out 100 things, but I think I have a solution:
1. start virtual machine
2. pressing ESC at "GRUB loading please wait"
3. select "recovery mode"
4. pressing <F6> multiple times (maybe only one is enough)
5. command prompt is displayed. I executed command:
dpkg-reconfigure xserver-xorg
6. xserver console pops-up: I just went through the wizard and select only!!!! default.
7. After finishing program returns back to command prompt. I executed command: reboot
8. Ubuntu reboots - don't touch anything - it reboots fine.

It looks like there is something not good with graphic card or monitor settings. Don't know...
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby Belberto » 11. May 2007, 01:29

Hi,
I had the same issue installing and booting ubuntu 7.04.
I run XP SP2 on my desktop PC : opteron 165 (dual core), 2GB ram.

My solution is to assign affinity of the VM running Ubuntu to cpu1 or cpu0 with the task manager.

1/ run the ubuntu vm
2/ then pause the ubuntu vm at start up (innotek on screen)
3/ run the task manager of the host (ctrl+alt+suppr)
4/ find the process "VirtualBox.exe", there are 2 process (if running a single vm), then set affinity of the "VirtualBox.exe" using the most memory to cpu0 or cpu1 (right click the proces, choose "set affinity" and uncheck a box), close task manager
5/ resume the ubuntu vm et voilà

It worked fine for me. Now I can run ubuntu 7.04 and kubuntu 7.04.
Belberto
 
Posts: 3
Joined: 11. May 2007, 01:05

Postby abcuser » 11. May 2007, 10:24

Belberto wrote:Hi,
I had the same issue installing and booting ubuntu 7.04.
I run XP SP2 on my desktop PC : opteron 165 (dual core), 2GB ram.

It is possible that "dual core" technology is causing a problem. I use IBM ThinkPad T60 (Intel Centrino Duo T2300; CPU: 1.66 GHz; RAM: 1.5 GB).

Now my Ubuntu 7.04 boots up OK, but I will think about your suggestion next time I run into the same problem. Thanks for posting you note.
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby Belberto » 11. May 2007, 11:48

Your welcome,
I just want to say that it solved my keyboard issue (BBBBeeeellllbbbbbeeeeerrtttttttoooooooo), and sometimes I lost the mouse, since I assign affinity the VM is very stable.
Belberto
 
Posts: 3
Joined: 11. May 2007, 01:05

Postby abcuser » 11. May 2007, 16:36

Belberto,
the "loading please wait" problem reappeared again. I have used your method and it worked well. Thanks!
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby Pohutukawa » 14. May 2007, 00:24

This is all very interesting!

In my experience with a competing VM product, I had absolutely no problems installing any of the *Buntus (versions 604, 610, or 704) as guests on my current PC, which has a Core2 Duo CPU, 2 GIG RAM. I've run the host as XP and then Vista.

It seems like I'm getting a whole other set of problems installing Ubuntu 704 on Virtual Box 1.3.8.
Pohutukawa
 
Posts: 5
Joined: 13. May 2007, 01:14

Postby hobelbrecht » 15. May 2007, 10:28

Hi,
I had the same problems,
but i found a workaround. I start the linux-kernel with the option clock=pit. (kernel option in grubs or in the commandline ) Now it works fine for me.

regards
Werner Hobelbrecht
hobelbrecht
 
Posts: 1
Joined: 15. May 2007, 10:20
Location: Germany

Postby abcuser » 15. May 2007, 14:13

Pohutukawa wrote:This is all very interesting!

In my experience with a competing VM product, I had absolutely no problems installing any of the *Buntus...

Hi, it is also interesting using VMware workstation. I have installed it on my job PC - everything works fine. But installing it on my laptop VMware corrupted my network settings on Windows. So general rule: "each product has its one set of bugs". ;)
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby abcuser » 15. May 2007, 14:17

hobelbrecht wrote:Hi,
I had the same problems,
but i found a workaround. I start the linux-kernel with the option clock=pit. (kernel option in grubs or in the commandline ) Now it works fine for me.

regards
Werner Hobelbrecht

Hi,
can you please post more details. I am not a Linux geek, so I would appreciate if more details is posted.
Thanks,
Abcuser
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby Belberto » 15. May 2007, 14:32

Hi,
thank you Werner Hobelbrecht, it works fine!
Belberto
 
Posts: 3
Joined: 11. May 2007, 01:05

Postby abcuser » 11. Jul 2007, 15:29

Hi,
today I installed Virtual Box 1.4.0 and install Ubuntu 7.10 and the problem has disappeared. It looks like this bug was fixed.
Regards,
Abcuser
abcuser
Volunteer
 
Posts: 558
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Re: "Loading please wait" on Ubuntu VirtualBox on Wind

Postby gurubob » 16. Feb 2011, 05:03

Hi all,

I moved a Virtual Hard Disk from one VBox machine to another and when booting I had the same problem. The newer version of VirtualBox had attached the hard disk file to a virtual SATA controller, whereas on the old VirtualBox it was attached to an IDE controller. I opened up the two versions of VirtualBox side by side and compared the settings to make sure they were identical and everything then worked fine.

Hope it helps someone.

Cheers,

- Bob -
gurubob
 
Posts: 2
Joined: 16. Feb 2011, 04:59
Primary OS: Ubuntu other
VBox Version: OSE Debian
Guest OSses: Linux


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 58 guests