Deadkeys in Windows XP Guest

Discussions related to using VirtualBox on Linux hosts.

Deadkeys in Windows XP Guest

Postby plenque » 5. Sep 2007, 15:18

Hi all,

I just wanted to know if someone else has experienced problems with deadkeys under the just released VBox 1.5. Seems I cannot write vocals with their graphical accent in spanish anymore (ej: áéíóú). Following the usual way I just get the normal vocal.

Also, and this is very weird, if I press ALT+F4 on the Guest, it gets captured by the host (offering to close the guest) but after cancelling the action with the VBox dialog provided I loose the keyboard control on the guest. The only workaround after that is restarting the Guest.

Thanks!
plenque
 
Posts: 8
Joined: 21. Aug 2007, 03:27

Postby michael » 5. Sep 2007, 15:48

Just a few questions. Did you use VirtualBox 1.4.0 and if so, is this behaviour new in 1.5.0? If it is, could you try out all keys on the keyboard in the guest to see if they produce what they expect them to produce?

If you have only just started using VirtualBox, try changing your keyboard configuration inside the guest.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Postby plenque » 5. Sep 2007, 16:27

Thanks for your response.

I've upgraded from a previously working virtual machine with VirtualBox 1.4.

I've just tried the rest of the keys and they seem to be working fine. My keyboard configuration under the guest is: English (United States) / United States-International.

Regards,
Mauro.
plenque
 
Posts: 8
Joined: 21. Aug 2007, 03:27

Postby michael » 5. Sep 2007, 16:40

And which keyboard configuration are you using in the host?
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Postby michael » 5. Sep 2007, 16:40

Which host system is that by the way?
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Postby plenque » 5. Sep 2007, 16:51

Ubuntu Feisty.
Generic 105-key (Intl) PC / U.S. English International (with dead keys).

Thanks again.
plenque
 
Posts: 8
Joined: 21. Aug 2007, 03:27

Postby michael » 6. Sep 2007, 17:12

plenque: see my private message.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Postby michael » 6. Sep 2007, 18:44

VirtualBox 1.5.2 will contain a fix for this. Anyone else with keyboard issues in Linux hosts is welcome to add them onto the end of this thread or ticket 599 in the issue tracker.
michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Postby aemau » 19. Sep 2007, 16:05

The key combination Alt Click is also not passed from Linux Host to WinXP guest.

Allan
aemau
 
Posts: 46
Joined: 22. Aug 2007, 23:10

Postby michael » 28. Sep 2007, 09:20

michael
Oracle Corporation
 
Posts: 336
Joined: 10. May 2007, 09:46

Simple solution!

Postby nabamer » 1. Oct 2007, 23:24

In the KDE guest Linux operating system where is VirtualBox installed do:

Control Center -> Desktop -> Windows Behavior -> Accions... --> Replace ALT key to META.


In Spanish:
Centro de Control -> Escritorio -> Comportamiento de la ventana
-> Acciones de ventana -> Tecla modificadora: (cambiar de ALT a META)


Enjoy!!
nabamer
 

Postby fstafforini » 18. Apr 2008, 16:55

I had a similar problem with dead keys not working, using us-intl keyboard. It turns out that these don' t work with intl nor alt-intl variants, but do work fine with altgr-intl (ie, I changed my X keyboard layout, in my case using KDE)

Maybe you should try all variants in the locale you need and see if there is one that works.
fstafforini
 
Posts: 3
Joined: 18. Apr 2008, 16:46

Postby fstafforini » 18. Apr 2008, 19:15

What I wrote is wrong... It seems that for dead keys to work within the host, they must be disabled within the host.

It turned out that in the altgr-intl variant dead keys were not working within the host, so that's why they worked in the guest. They also work in the guest if I use a no dead-keys layout, such as us (default); they don't work when the host is using a layout with dead keys.
fstafforini
 
Posts: 3
Joined: 18. Apr 2008, 16:46

Postby Sasquatch » 18. Apr 2008, 19:29

That is strange. I use 1.5.6 on Ubuntu 7.10 and have no problems with either host nor guest keyboard. I have US (intl) on both systems, Linux with dead keys, so if I type '"' (double quote) followed by 'e', it will result in 'ë' on both Linux and Windows. I do have the problem that the Winkey isn't passed to the guest correctly, it passes the Alt key. It used to work, so something on my system made it that way. Have to reinstall it anyway so it will be fixed when I'm done with it, I hope.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby gewe » 28. May 2008, 20:10

I just noticed the problem for the first time. I recently upgraded my Ubuntu host to 8.04 (kernel 2.6.24-17-generic), and VirtualBox to 1.6.0. In the guest I installed the guest additions 1.6.0.

If the keyboard capture is on (green arrow in status bar) the dead keys don't work. Not by themselves (e.g. to type a quote), and not combined with a letter (e.g. to type an ë).
If the keyboard capture is of (black arrow in status bar), and the guest windows has the focus, the dead keys do work (in a Windows guest that is, in an Ubuntu guest they still don't work).

Keyboard layout is US International (with dead keys).

Edit 05-08-2008:
VirtualBox versions 1.6.2 and 1.6.4 have the same problem. When are all these keyboard issues finally going to be fixed? :x This will drive me back to VMware server, once 2.0 is final (and I can use USB 2.0 in the guests).
gewe
 
Posts: 32
Joined: 8. Jan 2008, 20:36


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: phantom21 and 24 guests