Mouse instantly clicking

Discussions about using Windows guests in VirtualBox.

Mouse instantly clicking

Postby jan. » 4. Sep 2007, 21:18

On my Ubuntu-Host (7.04) the Mousepointer in a WindowsXP-Guest (with SP 2) is instantly clicking, both left and right (that is not me clicking ;)). This is happening since I installed the Windows Guest Additions

Turning off Mouse integration won't fix the problem. Any workarounds?
jan.
 
Posts: 2
Joined: 4. Sep 2007, 21:11

Postby ralph » 2. Oct 2007, 22:21

Hi,
I have the same problem with the touchpad on my Acer 7720G notebook.
I figured that the mouse driver which was installed by the guest additions caused the problem, so I uninstalled the guest additions. This didn't solve the problem.
Then I just removed the vboxmouse.sys (or something similar - I can't remember the exact name) file from the windows\system32\drivers folder (copied it to the recycle bin). Now the mouse pointer has stopped clicking all by itself, but I can't use the touchpad at all anymore (Fn + F7 isn't working either by the way, if you were wondering).
The device manager displays an error with the "Synaptcs PS/2 Port Touchpad" and says that the driver can't be loaded because it's corrupt or missing. I tried to reinstall the drivers, I even downloaded the latest from the Acer website, but my touchpad still refuses to work.
I already spent hours on this one, and it's beginning to get really frustrating, escpecially since I have no system restore points or other backups...
Thanks in advance,
Ralph
ralph
 
Posts: 1
Joined: 2. Oct 2007, 22:03

Postby naju » 9. Oct 2007, 23:20

Same problem here. XP guest, mouse integration and guest additions were both working fine in the virtual machine, until I installed setpoint (logitech mouse software -- I *think* that's the cause) when running the winxp installation natively. Next time I booted the winxp partition in the VM, the mouse went all crazy, clicking constantly with both buttons every time the pointer is moved. Tried removing guest additions, setpoint, deinstalling the mouse driver completely, no luck. I'm using a logitech MX518 btw. Are you using a similar mouse Jan ?
naju
 
Posts: 7
Joined: 9. Oct 2007, 23:14

Same thing here

Postby djl » 14. Oct 2007, 01:02

I had the same problem. I'm running Kubuntu Feisty and installed Windows XP, which was working fine until I installed the Logitech mouse drivers. (MX400) I just deleted XP and will start over again later tonight.

Dana
djl
 
Posts: 1
Joined: 14. Oct 2007, 00:26
Location: Fond du Lac, WI

Mouse instantly clicking

Postby fred_f » 4. Feb 2008, 13:37

Has anyone found a solution for this problem yet?

I have copied my XP SP2-Boot partition (according to the following post http://forums.virtualbox.org/viewtopic. ... 1568cf3102
).
System is running an somewhat old Logitech-Mouse, Driver 9.79.0.0 dated 11/07/03

Everything worked great execept for the mouse-nuissance, which renders the whole thing unusable.
Tried to uninstall the driver - did not work.

Virtualbox 1.5.2, Opensuse 10.3. Kernel 2.6.22.16-0.1-default

Any help is greatly appreciated.
fred_f
 
Posts: 1
Joined: 4. Feb 2008, 13:27

Postby seastar » 6. Feb 2008, 22:47

Hi everyone. I think I found a solution, but I´m not sure if it matches the problem. Here´s my setup:

- Host: Win Vista 64
- Guest: Win XP SP2

I had the problem that after installing Guest additions, the mouse started rightclicking non-stop within Virtual Box. Problem seemed to be the Logitech SetPoint Software I used on both host and guest system (before installing Guest additions, I could for instance control audio settings in the host while being within guest (I use a MediaPlay Mouse with tons of keys)). I tried several things like killing the SetPoint process etc. but nothing worked. Then I finally found this thread and thought about ralph´s post.
Then, quite simply, I uninstalled SetPoint within the guest system (took a while) and rebooted after being prompted. Voilá - it worked.

Hope this rather simple approach might help some of you!

Cheers
seastar
 
Posts: 1
Joined: 6. Feb 2008, 22:38

Re: Mouse instantly clicking

Postby AlesZib » 13. May 2009, 13:35

I am working on a Ubuntu 9.04 host and WIn XP guest. I had the same problem, however, removing Logitech SetPoint Software did not work. Aslo, removing vboxmouse.sys caused the mouse to stop working completely. The solution was to remove guest additions, however I do not like it very much (I miss the features).

If anybody has better solution I would be most grateful.
AlesZib
 
Posts: 1
Joined: 13. May 2009, 13:29
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Winows XP

Re: Mouse instantly clicking

Postby sfink » 23. Sep 2010, 01:01

This plagued me for ages, but I finally found a solution. See http://www.virtualbox.org/ticket/501 for workarounds.
sfink
 
Posts: 1
Joined: 23. Sep 2010, 01:00
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 17 guests