VB always aborting.

Discussions related to using VirtualBox on Linux hosts.

disabled hyperthreading helps with crashes ...

Postby freimann » 5. Oct 2007, 13:47

after 24 hours on my Slack 12.0 box with Pentium-4 and HT disabled I am still running without any crash - having two VM - Win-XP and Win-2000 running all the time - doing heavy graphics editing in Adobe Photoshop & website editing in Dreamweaver (512 Mb VM) and with W2K running MS Exchange 2003 ...
freimann
 
Posts: 14
Joined: 8. Sep 2007, 09:44

Postby sitor » 5. Oct 2007, 15:06

Freimann,

What do you mean with HT disabled? What is HT?

Ciao,

Sitor
sitor
 
Posts: 20
Joined: 28. Sep 2007, 13:20

HT

Postby freimann » 5. Oct 2007, 15:12

HT means hyperthreading - I have disable HT support for my P4 CPU in BIOS and now (at least so far :-)) I have no crashes for more than 24 hours of heavily using my two VM's in Slackware 12.0 ... I haven't noticed any significant performance degradation after switching the HT off ...
freimann
 
Posts: 14
Joined: 8. Sep 2007, 09:44

Postby sitor » 5. Oct 2007, 15:34

I'll give that a try, but I'm rather pessimistic, as Virtualbox runs great very stable on Windows, just not on Linux. Unless of course the newer linux kernels use that hyperthreading possibilities differently or something. Thanks for informing us in any case. Gives hope...
sitor
 
Posts: 20
Joined: 28. Sep 2007, 13:20

Postby vista killer » 5. Oct 2007, 18:12

First abort yesterday in ubuntu gutsy :P
vista killer
 
Posts: 9
Joined: 11. Sep 2007, 14:00

Postby sitor » 6. Oct 2007, 13:12

Hmm, looks like this is leading somewhere. Don't have something with HT or Hyperthreading in the name of any feature of the BIOS, but I do have dual processor support and speedstep. Turning of those two, I had an uptime of 14 hours before I stopped the VM myself (OK, I didn't do much with, it was just idle, but that was also the case sometimes when it aborted all the time).

Now, I'm going to test which of the two features is the one that causes the aborts: dual processor support or speedstep.
sitor
 
Posts: 20
Joined: 28. Sep 2007, 13:20

48 hours uptime

Postby freimann » 6. Oct 2007, 14:10

after disabling hyperthreading in BIOS there was NO MORE CRASHES for almost 48 hours now ..

sitor - i think hyperthreading and dual processor support are very similar things - HT just makes my P4 act as two independent CPU's ...

i had these problems with HT before - my slack box would crash with some USB bluetooth dongle but turning HT off would help then ...
freimann
 
Posts: 14
Joined: 8. Sep 2007, 09:44

Postby sitor » 7. Oct 2007, 09:54

OK, it definitely seems to be the dual processor support. When I leave that on and disable speedstep, still aborts, when I disable dual processor support and enable speedstep, I could keep it running for 18 hours in a row before ending it myself.

Good! I found a temporary solution, even if that slows down my machine a bit.

Thanks again for the tip freimann!

Ciao,

Sitor
sitor
 
Posts: 20
Joined: 28. Sep 2007, 13:20

Postby vatbier » 8. Oct 2007, 00:03

Are these aborts happening only on Intel Pentiums or also on Amd Athlon 64 X2 Dual Core Processor (which I have)?
vatbier
 
Posts: 11
Joined: 9. Sep 2007, 22:24

aborts

Postby dmontywilliams » 8. Oct 2007, 00:55

Have not experienced the problem on this system:
intel core 2 duo 6600
Mandriva 2007.1 kernel 2.6.17.15 host
Windows XP guest
VirtualBox 1.5.0 proprietary

But then, I do not leave Windows on all that long.
dmontywilliams
 
Posts: 3
Joined: 30. Jun 2007, 07:40

crashes and kernel versions ...

Postby freimann » 8. Oct 2007, 09:41

this has already been discussed - kernels up to 2.6.18 work fine ... higher versions will make VM crash - disabling HT would help but with a performance penalty - tested on P4 and Core2 6600 Quad core ... the crashes can happen anytime - regardless of how long you run the VM ... i am not able to pinpoint a single action that would be the cause - it would crash even when running alone in another virtual desktop without ANY user action - btw i am using KDE 3.5.7 - have not tested with other WM
freimann
 
Posts: 14
Joined: 8. Sep 2007, 09:44

Processor Types

Postby holvenstot » 9. Oct 2007, 01:29

Vatbier -

I run an AMD64 X2 4600+ and see the dreaded "guest abort" problem on a regular basis so it is not just limited to Intel products.

I can not comment on the multi-core / single-core aspect as my CPU and chipset does not allow me to disable the second core

Chris
holvenstot
 
Posts: 12
Joined: 15. Sep 2007, 04:58

Window Manager

Postby holvenstot » 9. Oct 2007, 01:34

Freimann -

Between the two of us I think that we have the Window Manager thing covered.

Normally I run Gnome as a desktop with Beryl as my window manager but I have also run with Gnome using the standard Metacity window manager and even "fallen back" to a plain Motif Window Manager system.

None of these changes seem to effect the abort issue.

Chris
holvenstot
 
Posts: 12
Joined: 15. Sep 2007, 04:58

how to disable hyperthreading ..

Postby freimann » 9. Oct 2007, 09:15

to holvenstot - you can easily disable hyperthreading without any change to your BIOS - simply append the following parameter to your kernel command line : "ht=off" (in your lilo.conf or grub menu.lst)
freimann
 
Posts: 14
Joined: 8. Sep 2007, 09:44

Thanks Friemann

Postby holvenstot » 9. Oct 2007, 15:45

Thank you for the information - Hyper-Threading is an Intel technology which was used to improve the multi-tasking performance of their Pentium 4 processors. Of course these were single-core processors.

I have a number of Lenovo ThinkPads for work which all have Intel Duo Core processors - in the case of these machines there is a BIOS setting to drop back to being a "single core" system - which I have used several times in an effort to flush out serialization issues with platform I support.

This is why I went looking for the same type of BIOS option on the AMD processor used in my personal system. But this option does not seem to exist.

I am not sure what effect the Hyper-Treading switch you suggested would have on an AMD processor, but you got me to thinking and I will build a kernel this afternoon with CONFIG_SMP turned off - this should force me to run on a single core.

Chris
holvenstot
 
Posts: 12
Joined: 15. Sep 2007, 04:58

PreviousNext

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Majestic-12 [Bot] and 10 guests