VirtualBox 2.1.2 kills USB printing

Discussions related to using VirtualBox on Linux hosts.

VirtualBox 2.1.2 kills USB printing

Postby birefringence » 24. Jan 2009, 13:20

After installing VirtualBox 2.1.2 on my OpenSUSE 11.1 I cannot print anymore. I filed a bug report here: http://www.virtualbox.org/ticket/3143

Until this issue is resolved, I would be glad if anyone could point me to a temporary workaround. Can I somehow prevent VirtualBox from fiddling with the USB permissions? I do not need USB access in VirtualBox, but I do need to print!
birefringence
 
Posts: 5
Joined: 24. Jan 2009, 13:14

Postby Sasquatch » 24. Jan 2009, 16:41

Disable USB. It's possible that a VM grabbed your printer.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby birefringence » 24. Jan 2009, 19:58

Sasquatch wrote:Disable USB. It's possible that a VM grabbed your printer.

Where do I do that? Please note, that printing immediately stops working after the version 2.1.2 RPM package is installed and the corresponding USB device is recreated (due to reconnecting the printer or rebooting the system).

I'm also quite sure that it is purely a permission problem. If I reset them by hand everything works fine until the next reboot.
birefringence
 
Posts: 5
Joined: 24. Jan 2009, 13:14

Postby Sasquatch » 24. Jan 2009, 20:24

You can disable USB in the VM settings. But from your post now, it seems that your issues are since the install of the new version, not specifically if you run a VM, correct?
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby birefringence » 24. Jan 2009, 23:26

Yes indeed. The problem appears after installing the RPM package. And in fact, it disappears after deleting the package again. But it seems that I cannot both succesfully print and have the package installed.
birefringence
 
Posts: 5
Joined: 24. Jan 2009, 13:14

Postby Sasquatch » 25. Jan 2009, 01:05

Extract the package only, then see what files are replaced/modified to track down the issue. Once you've found it, you can open a bug report in the Bugtracker. You need to sign up for a new account there, your Forum account won't work.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby birefringence » 25. Jan 2009, 13:24

Ok, I took a closer look at the installation. It creates a file /etc/udev/rules.d/60-vboxdrv.rules
Deleting it solves the problem. I have already created a bug report (see my first post).

(I guess this thread can be closed)
birefringence
 
Posts: 5
Joined: 24. Jan 2009, 13:14

Postby Eck » 25. Jan 2009, 19:27

Well, I'm not sure if closing the topic is appropriate. I also just had the problem. Since I have my user in the lpadmin and lp groups I was able to print, however the hplip toolbox reported a device communications error and the extra features like Supplies, align cartridges, etc did not even appear.

I moved the /etc/udev/rules.d/60-vboxdrv.rules to my home folder and rebooted. Then hplip toolbox was able to access my printer again.

But how does this effect virtualbox operation? Should we, rather than removing that vboxdrv rules file, simply delete the usb lines and leave that KERNEL line? I mean, this file has always been installed by the virtualbox installer and so I figure that it does something that VirtualBox needs.

My install is on Debian Lenny using the .run installer. I haven't any guests installed at the moment since I've been using VMWare lately due to the various problems with VirtualBox since 2.1 was released. That's why I don't know whether deleting this file will effect normal operation of VirtualBox guests regarding vboxdrv, the USB, etc.

I had been waiting to start installing some Linux guests (I've got XP and 98SE on VMWare guests) on VirtualBox until the bugs in VirtualBox 2.1 were dealt with. Now it seems we have a new bug. But perhaps default UDEV rules on a Debian installation and the standard vboxdrv setup are enough without this vboxdrv.rules file?
Eck
 
Posts: 31
Joined: 5. Jan 2008, 19:10

Postby birefringence » 25. Jan 2009, 23:35

Deleting the usb lines starting with SUBSYSTEM (and leaving the KERNEL line) is enough. A probable side effect will be, that it is then no longer possible to access USB devices from within a VM, unless other measures are taken to ensure read/write access to the devices for the user executing the VM. Apart from this, VirtualBox should work normally.
birefringence
 
Posts: 5
Joined: 24. Jan 2009, 13:14

Postby retabell » 26. Jan 2009, 03:13

the same here on Debian-ETCH

You can disable USB in the VM settings.


it doesn' matter

change in 60-vboxdrv.rules the two lines with subsytem MODE="664" change to "666"

this should solve it
retabell
 
Posts: 3
Joined: 26. Jan 2009, 02:49

Postby Eck » 26. Jan 2009, 17:01

Going with no /etc/udev/rules.d/60-vboxdrv.rules file, I installed an OpenSUSE 11.1 guest and USB works fine in the guest.

On my host's /etc/fstab I still have the line:

none /proc/bus/usb usbfs auto,busgid=1001,busmode=0775,devgid=1001,devmode=0664 0 0

That's what made USB work within guests in VirtualBox on my Debian Lenny host before and it still appears to work regardless of whatever the USB changes were in VirtualBox 2.1.2.

Perhaps due to that bug report this vboxdrv.rules issue will be looked into and adjusted to play more nicely with host USB devices such as those using hplip.

For now, deleting that file hasn't appeared to effect VirtualBox guests and re-enables my hplip toolbox in the host to function properly. Printing was working anyway, even when hp-toolbox was reporting device communication errors and its services weren't available. KDE was using the printer fine from the hp:// device uri.
Eck
 
Posts: 31
Joined: 5. Jan 2008, 19:10

Postby retabell » 21. Feb 2009, 13:59

same with VirtualBox 2.1.4 on Debian-Etch
with usb-printer when printing via hplip

changing in 10-vboxdrv.rules the two lines with subsytem MODE="664" change to "666"
fixed it for me.
retabell
 
Posts: 3
Joined: 26. Jan 2009, 02:49

Postby Sasquatch » 21. Feb 2009, 16:15

retabell wrote:same with VirtualBox 2.1.4 on Debian-Etch
with usb-printer when printing via hplip

changing in 10-vboxdrv.rules the two lines with subsytem MODE="664" change to "666"
fixed it for me.

If you needed that, you are not in the proper groups to access the USB system. Are you in the vboxusers group? When I execute id from a terminal, I get this output. Compare it with yours.
Code: Select all   Expand viewCollapse view
uid=1000(sasquatch) gid=1000(sasquatch) groups=4(adm),24(cdrom),29(audio),30(dip),44(video),46(plugdev),102(netdev),105(scanner),108(fuse),115(lpadmin),118(admin),121(gdm),122(sambashare),124(pulse),125(pulse-access),126(pulse-rt),127(vboxusers),130(floppy),1000(sasquatch)

I have no problems with USB. I do use Ubuntu, so there might be something different there too, compared to your OpenSuSE.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby retabell » 21. Feb 2009, 16:43

Are you in the vboxusers group?


yes, here is th id output

Code: Select all   Expand viewCollapse view
uid=1000(holger) gid=1000(holger) Gruppen=20(dialout),21(fax),22(voice),24(cdrom),25(floppy),
26(tape),27(sudo),29(audio),30(dip),44(video),46(plugdev),
60(games),100(users),106(usb),113(scanner),115(camera),
116(umlnet),117(fuse),118(powerdev),123(netdev),
1000(holger),1003(vboxusers)


i am using Debian-Etch (Kanotix) (not OpenSuse)
with Ubuntu-Kernel 2.6.28-8-generic
retabell
 
Posts: 3
Joined: 26. Jan 2009, 02:49


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: andyp73, shkval and 5 guests