Ubuntu 8.10 on Vista : AZERTY to QUERTY (VirtualBox 2.1.0)

Discussions about using Linux guests in VirtualBox.

Ubuntu 8.10 on Vista : AZERTY to QUERTY (VirtualBox 2.1.0)

Postby Jacky672 » 17. Dec 2008, 20:48

Hello,

First, thanks for your great job! :)

I have a little problem (maybe a bug ?). I just install VirtualBox 2.1.0 on my Vista SP1 host. Then I install the new guest addition on my Ubuntu 8.10 guest. Now my keybord is in QUERTY mode in my guest. I need to use AZERTY mode (French keybord).

Regards,

:wink:
Jacky672
 
Posts: 45
Joined: 30. May 2007, 23:59
Location: France
Primary OS: Debian Lenny
VBox Version: OSE Debian
Guest OSses: Linux

Postby Jacky672 » 17. Dec 2008, 20:57

Sorry I just resolv the problem. I added a new keyboard setting.

Image


Strange...

Sorry :wink:
Jacky672
 
Posts: 45
Joined: 30. May 2007, 23:59
Location: France
Primary OS: Debian Lenny
VBox Version: OSE Debian
Guest OSses: Linux

Postby julien_york » 18. Dec 2008, 11:25

I have the same problem, and i've already tried your setting. It wored BUT do you have the @ carater? When i try to type a "@" i've got a "à".

This appends when you install linux guest additions (i've re-installed my ubuntu guest and it appeards after rebooting when additions are installed)

So , i've a qwerty keyboard on the logon screen. I've tried to change the language but i does'nt work.

Is there a bug in the linux guest additions package?
julien_york
 
Posts: 3
Joined: 7. Oct 2008, 13:56

Postby Marty* » 18. Dec 2008, 12:04

Same problem here with the German QWERTZ keyboard layout. All Gnome language and keyboard settings are correct but I get an QWERTY layout without umlauts etc.
This problem has appeared after updating to 2.1.0. On all previous versions, the keyboard worked correctly.
Marty*
 
Posts: 2
Joined: 18. Dec 2008, 11:56

Postby tarp » 18. Dec 2008, 16:42

I can confirm the problem. After upgrading to 2.1 my Kubuntu 8.10 was not able to change back to german keyboard layout.

I found the following in /var/log/Xorg.0.log but have not found a solution yet.

(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
(**) Option "xkb_model" "pc105"
(**) AT Translated Set 2 keyboard: xkb_model: "pc105"
(**) Option "xkb_layout" "de"
(**) AT Translated Set 2 keyboard: xkb_layout: "de"
(**) Option "xkb_variant" "nodeadkeys"
(**) AT Translated Set 2 keyboard: xkb_variant: "nodeadkeys"
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap


I am using an empty xorg.conf, which was working fine a day before with virtualbox 2.06.
tarp
 
Posts: 3
Joined: 18. Dec 2008, 16:37

Postby ticapix » 18. Dec 2008, 20:56

Same errors here with debian testing under gnome and debian unstable/sid under kde.

Code: Select all   Expand viewCollapse view
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap


I made a complete reinstall and the problem definitively appears only after the install of the VBoxLinuxAdditions-x86.run under VirtualBox 2.1.

I don't know how to fix it yet.


--
pierre
ticapix
 
Posts: 2
Joined: 18. Dec 2008, 20:46

Postby fixedwheel » 19. Dec 2008, 00:51

ticapix wrote:Same errors here with debian testing under gnome and debian unstable/sid under kde.
Code: Select all   Expand viewCollapse view
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap

same here with ubuntu 8.10

2.0.6 GA working ok with 2.1.0 host ... no GA after ubuntu kernel update (keymap ok), installed new GA => no more german keymap and same xorg error as quoted above


where can i download 2.0.6 GA iso without reinstalling the whole 2.0.6?
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Postby ticapix » 19. Dec 2008, 10:42

Well I fixed it by deleting manually the installed files by VBoxLinuxAdditions-x86.run --list

made a reboot and install the virtualbox-ose-guest-modules-2.6-686 package from aptitude. I get my keymap back after that. but this is clearly a dirty hack.
ticapix
 
Posts: 2
Joined: 18. Dec 2008, 20:46

Postby jmtdstoc » 19. Dec 2008, 13:04

I also have this keyboard problem when 2.1.0 Additions are installed on a Linux Guest.
I have tried Fedora 10 and Ubuntu 8.10. Both keyboard layouts loose their correct definitions when I need to use the Alt GR key. All the other keys work fine... it's just the Alt Gr key that gets misconfigured.

But this is just a problem with Linux. On a Windows XP Professional guest the Alt Gr key works as it should.

A fast solution would be great! I can't use my Ubuntu 8.10 guest because of this... in order to write the "€" (euro) sign I need to type Alt Gr + E.
jmtdstoc
 

Postby abcuser » 19. Dec 2008, 13:26

ticapix wrote:made a reboot and install the virtualbox-ose-guest-modules-2.6-686 package from aptitude.

Hi,
can you please provide instruction how did you do this.

I tried the following:
1. I added deb source from virtualbox.org described on:
http://www.virtualbox.org/wiki/Linux_Downloads

2. Then I have updated repository:
sudo apt-get update

3. Then I have tried to install package:
sudo apt-get install virtualbox-ose-guest-modules-2.6-686
and got error:
E: Couldn't find package virtualbox-ose-guest-modules-2.6-686

Please provide any info how to overcome this problem.
Regards
abcuser
Volunteer
 
Posts: 566
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby fixedwheel » 19. Dec 2008, 13:56

abcuser wrote:1. I added deb source from virtualbox.org

no, its done in the guest and there you dont need the virtualbox.org deb source: ose deb packages dont come from virtualbox.org repository
the virtualbox-ose-guest-modules-... should come from the normal ubuntu repository - look for the ones matching your exact kernel version number in synaptic
fixedwheel
Volunteer
 
Posts: 1699
Joined: 13. Sep 2008, 02:18

Postby xasx » 19. Dec 2008, 14:12

tarp wrote:
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) AT Translated Set 2 keyboard: xkb_rules: "evdev"
...
(EE) Error compiling keymap (server-0)
(EE) XKB: Couldn't compile keymap
(WW) Couldn't load XKB keymap, falling back to pre-XKB keymap


Exactly the same problem here under Gentoo and Ubuntu 8.10 after upgrade to GA 2.1.

You may (or may not) override/work around the problem by using a keyboard layout switcher/setting manager provided with your desktop manager (e.g. Gnome, Xfce)
xasx
 
Posts: 49
Joined: 17. Jul 2007, 17:11
Location: Karlsruhe
Primary OS: MS Windows other
VBox Version: PUEL
Guest OSses: Windows XP/Server 2008R2/7/8/2012, Gentoo, Ubuntu, OpenSUSE, Oracle Linux, Fedora, Arch

Postby abcuser » 19. Dec 2008, 18:16

fixedwheel wrote:no, its done in the guest and there you dont need the virtualbox.org deb source: ose deb packages dont come from virtualbox.org repository
the virtualbox-ose-guest-modules-... should come from the normal ubuntu repository - look for the ones matching your exact kernel version number in synaptic

Hi,
I couldn't find virtualbox-ose-guest-module... in Ubuntu repository, so I thought it was on virtualbox.org repro... I removed virtualbox.org repo from source file.

I have searched synaptic using word virtualbox, but didn't get any virtualbox-ose-guest-module... result. See below picture:
Image

Which package should I install to overcome this keyboard bug?
Regards
abcuser
Volunteer
 
Posts: 566
Joined: 10. May 2007, 20:03
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu, Windows XP

Postby julien_york » 19. Dec 2008, 18:47

I have finaly re-installed the 2.0.6 version of virtual box, i had the good idea to backup my XML files of my guests (2.1.0 version needs to reformat these files), so i copy back the backed up files to their originals names and everything work fine now (I've re-installed Guest additions of the 2.0.6 version too). I'll wait to install the 2.1.0 version , maybe virtual box developpers team will provide a fix...
julien_york
 
Posts: 3
Joined: 7. Oct 2008, 13:56

Postby xasx » 19. Dec 2008, 19:27

You also might use the old GA iso file from
http://download.virtualbox.org/virtualb ... _2.0.6.iso

so you need not to install a different version of VirtualBox on your host.
xasx
 
Posts: 49
Joined: 17. Jul 2007, 17:11
Location: Karlsruhe
Primary OS: MS Windows other
VBox Version: PUEL
Guest OSses: Windows XP/Server 2008R2/7/8/2012, Gentoo, Ubuntu, OpenSUSE, Oracle Linux, Fedora, Arch

Next

Return to Linux Guests

Who is online

Users browsing this forum: Google [Bot] and 7 guests