Seamless mode problems after recent Linux kernel update

Discussions about using Linux guests in VirtualBox.

Seamless mode problems after recent Linux kernel update

Postby dogword » 28. Nov 2008, 18:40

Hello,

after my regular Ubuntu 8.10 update today I observed that VirtualBox doesn't perform seamless mode and automatic mouse capture anymore after the Linux kernel has been updated.

All I can do is switch to fullscreen mode, in which I do not get an entire full screen but a 1152x864 field surrounded by black borders.
Is this due to the kernel update or am I the only one facing this problem?

No changes have been made to the settings. So far VB ran Ubuntu smoothly in my WinXP Pro host environment.

Peter
dogword
 
Posts: 9
Joined: 2. Nov 2008, 20:47

Postby stephanecharette » 28. Nov 2008, 20:09

After the guest linux kernel has been updated, the guest additions have to be recompiled.

There are several ways to do this.

The easiest way to do this (for me anyway) is to re-install the guest additions.

Stéphane
stephanecharette
Volunteer
 
Posts: 262
Joined: 10. Nov 2007, 22:03
Location: Kelowna, British Columbia, Canada
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu-64bit, Windows

Postby dogword » 28. Nov 2008, 23:19

Ah, yes... Reinstalling the guest additions did the trick.
Could have thought of that myself, of course... :oops:

Thanks for the swift reaction!

Peter
dogword
 
Posts: 9
Joined: 2. Nov 2008, 20:47

Postby bob23450 » 3. Dec 2008, 14:55

dogword wrote:Ah, yes... Reinstalling the guest additions did the trick.
Could have thought of that myself, of course... :oops:

Thanks for the swift reaction!

Peter


I did it too, but after doing it the shared folders feature did not work any more. Would you be so kind to check if it happened to U 2?
Many thanks.
bob23450
 
Posts: 11
Joined: 9. Jul 2008, 15:52
Primary OS: Debian Wheezy
VBox Version: PUEL
Guest OSses: Windows XP Windows 7 Debian

Postby dogword » 3. Dec 2008, 20:26

Sorry,

I do not have shared folders installed...

Peter
dogword
 
Posts: 9
Joined: 2. Nov 2008, 20:47

Postby bob23450 » 4. Dec 2008, 10:02

dogword wrote:Sorry,

I do not have shared folders installed...

Peter


Never mind, thanks again.

Anyone else reading this thread can check it?
bob23450
 
Posts: 11
Joined: 9. Jul 2008, 15:52
Primary OS: Debian Wheezy
VBox Version: PUEL
Guest OSses: Windows XP Windows 7 Debian

Postby Sasquatch » 4. Dec 2008, 19:57

On my compile machine, which runs 8.10 with only a CLI, and up to date, I have no problems accessing shared folders. Maybe another install of the GA fixes it.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby bob23450 » 5. Dec 2008, 10:16

Sasquatch wrote:On my compile machine, which runs 8.10 with only a CLI, and up to date, I have no problems accessing shared folders. Maybe another install of the GA fixes it.

Well, I found I'm able to restore the shared folders functionality only after uninstalling DKMS and reinstalling GA once again. I suspect a GA installer bug on the DKMS related code.

Thank you all.
Bye
bob23450
 
Posts: 11
Joined: 9. Jul 2008, 15:52
Primary OS: Debian Wheezy
VBox Version: PUEL
Guest OSses: Windows XP Windows 7 Debian

Postby Sasquatch » 8. Dec 2008, 18:46

bob23450 wrote:
Sasquatch wrote:On my compile machine, which runs 8.10 with only a CLI, and up to date, I have no problems accessing shared folders. Maybe another install of the GA fixes it.

Well, I found I'm able to restore the shared folders functionality only after uninstalling DKMS and reinstalling GA once again. I suspect a GA installer bug on the DKMS related code.

Thank you all.
Bye

That might be the problem indeed. IIRC, I don't have DKMS on my compiler.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 13 guests