Page 1 of 1

Ubuntu lost internet connection

Posted: 2. Apr 2024, 03:32
by Planefreak
Hello everyone, I'm running Ubuntu 22 in Virtualbox 7 on Debian 12. I setup the VM about a month ago and I've run into an issue where I lose internet connectivity.

I cannot connect to any webpage currently, but last week I had no issues at all. I'm able to ping other devices on my network, and I am able to ping my VM from other devices. Usual response times are 1-10ms.

The host is Debian 12 and wired into router.

Virtualbox network for the VM is configured to use "Bridged Adapter" and "eno1" as the device. I only have "eno1" and "docker0" available.

This produces the network on the guest VM:
IP: xxx.xxx.xxx.193
default route: xxx.xxx.xxx.1
DNS: 8.8.8.8 xxx.xxx.xxx.1

Can someone help me figure out why this happening? Thank you

Re: Ubuntu lost internet connection

Posted: 23. Apr 2024, 00:56
by Planefreak
For anyone wondering...

I spent about 10 hours trying to get this machine working (and another 8 hours on the previous machine that had the same issue) and just deleted the whole machine and moved on. I can setup the machine in about an hour, so spending 10 times that amount is insane and doing twice is even more insane.

I setup a windows 11 machine to replace the ubuntu machine and haven't had the same issue.

Maybe it's Ubuntu, maybe it's virtualbox, maybe it's Debian, but either way, of all the posts I made about this subject no one had anything worthwhile to offer, so if you have found yourself here looking for an answer, you won't find one. Just delete the vm, select a new OS and move on.