Stuck on windows 10 logo

Discussions about using Windows guests in VirtualBox.
Post Reply
Posts: 1
Joined: 16. Mar 2024, 06:06

Stuck on windows 10 logo

Post by Rosie_26 »

I am trying to run the windows 10 pro on an M2 MacBook Air however I get stuck at the Windows 10 logo when I start it. I am using version 7.0. And I have tried everything I can find someone please help.
Posts: 2
Joined: 15. Apr 2024, 00:02

Re: Stuck on windows 10 logo

Post by Fedeamo8 »


I have the same issue on a M1 mac computer, with VirtualBox 7.0

Any help?

Thank you
Posts: 949
Joined: 14. Sep 2019, 16:51
Primary OS: Mac OS X other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: WIN11,10, 7, Linux (various)
Location: United Kingdom

Re: Stuck on windows 10 logo

Post by multiOS »

See: viewtopic.php?t=107344

Until VirtualBox users begin to report successes rather than failures, or an official announcement is made that there has been significant progress in the capability of the BETA Developer Preview (7.0.97), the comments in the above thread represent the latest information available.

I haven't tried a recent version of the Beta Version for a couple of months, but a working Windows XP (32-bit) is, so far, the best outcome I have been able to achieve, i.e for me Windows 7 32-bit and all 64-bit Windows versions have consistently failed.

From reports I have seen elsewhere for Virtualisation apps available for 'M' Series Macs, only UTM (and possibly some others making use of QEMU to emulate x86 CPUs) have been said to have achieved some success with installing more recent x86 versions of Windows, although the performance of those more recent Windows versions, such 10/11, has been said to be "unacceptably slow", i.e. of no real use! Believe the hype about Apple's 'M' processors being more powerful than Intel/AMD if you wish, but that still doesn't mean they are (or will ever be) capable of supporting the emulation of Intel/AMD x64 processors and the required Instruction Sets needed to run x86 versions of Windows 10/11 efficiently.

In short, for acceptable performance, newer Windows x86 variants currently need a computer with a genuine (hardware) Intel/AMD CPU. However, Windows 11 for ARM is a working option with some virtualisation apps, but not yet possible with VirtualBox; and the availability of ARM version of Linux distributions is also slowly expanding.
Post Reply