Page 1 of 1

1908 error after upgrading Ubuntu

Posted: 20. Feb 2024, 16:20
by HockeyBum27
OS: Ubuntu 22.04
Kernel (uname -r): 5.15.0-94-generic
Secure Boot: No
VBox: 6.1.50_Ubuntu r161033

After upgrading Ubuntu to 22.04, I am no longer able to start my VM (a Windows 10 64-bit guest). I get the "Kernel driver not installed (rc-1908)" error, instructing me to reinstall virtualbox-dkms package and then run

Code: Select all

modprobe vboxdrv
as root.
I ran

Code: Select all

sudo apt-get install virtualbox-dkms
and was informed that it is already the newest version (6.1.50-dfsg-1~ubuntu1.22.04.1). I also get a note that 1 not fully installed or removed. Nevertheless, I proceed, and get the following:

Code: Select all

Setting up virtualbox-dkms (6.1.50-dfsg-1~ubuntu1.22.04.1) ...
Removing old virtualbox-6.1.50 DKMS files...
Deleting module virtualbox-6.1.50 completely from the DKMS tree.
Loading new virtualbox-6.1.50 DKMS files...
Building for 5.15.0-94-generic
Building initial module for 5.15.0-94-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/virtualbox-dkms.0.crash'
Error! Bad return status for module build on kernel: 5.15.0-94-generic (x86_64)
Consult /var/lib/dkms/virtualbox/6.1.50/build/make.log for more information.
dpkg: error processing package virtualbox-dkms (--configure):
 installed virtualbox-dkms package post-installation script subprocess returned error exit status 10
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
I then run

Code: Select all

sudo modprobe vboxdrv
and get the message

Code: Select all

modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/5.15.0-94-generic
I found that when I try to edit the settings of my Win10-64 VM, they are all read-only. I see the message 'invalid settings detected', it indicates that I'm not using the VboxSvga driver. In my settings it's VboxVga, but editing is disabled.

I also tried the following steps:
* Uninstall 6.1 (which was initially installed from Virtualbox repo, not the Ubuntu software center) via

Code: Select all

sudo apt-get remove virtualbox-6.1
* Install VirtualBox from the Ubuntu Software Center (same issues)
* Uninstall Virtualbox from the Ubuntu Software Center; got the following error:
Unable to remove VirtualBox:
Error while installing package: installed virtualbox-dkms package post installation script subprocess returned error exit status 10

I tried installing Virtualbox 7.0 from I got the following:

Code: Select all failed: Look at /var/log/vbox-setup.log to find out what went wrong.
There were problems setting up VirtualBox.  To re-start the set-up process, run
  /sbin/vboxconfig as root
I did that, and got the following:

Code: Select all

Error building the module:
make V=1 CONFIG_MODULE_SIG= CONFIG_MODULE_SIG_ALL= -C /lib/modules/5.15.0-94-generic/build M=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 -j12 modules
make[1]: warning: -j12 forced in submake: resetting jobserver mode.

  ERROR: Kernel configuration is invalid.
         include/generated/autoconf.h or include/config/auto.conf are missing.
         Run 'make oldconfig && make prepare' on kernel src to fix it.

make[1]: *** [Makefile:758: include/config/auto.conf] Error 1
make: *** [/tmp/vbox.0/Makefile-footer.gmk:133: vboxdrv] Error 2
I should point out that while it's not important to me which version of VirtualBox I use, it is important that I'm able to use the VM I have.
I'm open to suggestions, and thanks in advance for your time on this.

Re: 1908 error after upgrading Ubuntu

Posted: 20. Feb 2024, 23:21
by HockeyBum27
I was able to resolve by re-installing the linux kernel):

Code: Select all

sudo apt install --reinstall linux-headers-$(uname -r)
as shown here

I'd tried unininsatlling and re-installing these several times, but it apparently required the --reinstall option to work.