CLSID_VirtualBox error while running VB built from source

Discussions related to using the OSE version of VirtualBox.
Post Reply
Posts: 1
Joined: 4. Apr 2023, 21:21

CLSID_VirtualBox error while running VB built from source

Post by Composed0229 »


I have had problems with building VB from source and now trying to execute the built version. The error i get while trying to execute VirtualBox.exe is
"Completely failed to instantiate CLSID_VirtualBox:

Component: VirtualBoxClientWrap
Interface: IVirtualBoxClient {d2937a8e-cb8d-4382-90ba-b7da78a74573}".

I have used the following script to handle some of its dependencies and then build it. But i dont believe the problem is here: github dot com/VirtualBoBs/build-virtualbox-in-windows. (Could not post link but hope you got it)

But the thing is that it cant seem to find headers from WDK (a header i recall as of now is ntifs.h) and when inspecting the compile command printed after executing kmk it seems that it does not have a "-IC" flag for WDK path, only for SDK. So my hacky solution was to copy over the header files from WDK to SDK. After doing this it compiles fine. No errors from comregister.cmd or loadall.cmd either.
I have also started the com+ service as i have read somewhere.

I have also tried manually building it from source by following the build instruction on virtualbox website.

What am i doing wrong? Am i missing something?
If you need more information just say what and i will try to provide.

My environment:
Windows 11
Test mode is active and memory integrity in windows security settings are off.

Can compile virtualbox versions 6.1.16 and 6.1.30 but end up with same error as described above.
Cannot compile 7.0.4, get an error an variable not being declared before used in qt. (Sorry dont remember the name)

Thanks in advance for your replies.
Post Reply