Keyboard regularly starts working too fast in guest

This is for discussing general topics about how to use VirtualBox.

Keyboard regularly starts working too fast in guest

Postby CaptainFlint » 10. Oct 2008, 11:58

I have VB 2.0.2, host OS is WinXP SP3, guest is SUSE Enterprise Linux Server 10 SP2; additions installed. Tried with VT-x turned on and off — no difference.

I have customized the keyboard speed in the guest OS so that it fits me well. However, roughly once a minute the keyboard in the guest OS starts to work too fast, as if the settings suddenly changed to extremely short intervals. This lasts for about 7-10 seconds and then all returns back to normal. And in a minute all this repeats again and again.

I noticed that during such "fast" intervals VB eats much host CPU, though guest OS remains almost idle. Here is the screenshot of the host OS Process Explorer:

Image

You can see these periodical bursts of activity of VB. The I/O activity (blue) are also from VB. File Monitor shows that during this period VB updates the virtual machine VDI file, but this process is not very active (here is the filtered log for one of such periods; yes, just 41 records).


The question is what to do with this? It's completely impossible to work with keyboard in the guest OS during such periods, and they repeat too often, so I can't just ignore them. :( Of course, I tried rebooting guest OS, host OS, and reinstalling VB guest additions, all this did not help.
CaptainFlint
 
Posts: 86
Joined: 9. Oct 2007, 10:17
Location: Moscow, Russia
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: WinXP, Vista, openSUSE, Ubuntu

Postby CaptainFlint » 15. Oct 2008, 13:03

Additional information: it seems that VB's internal timer works too slowly and then detects it and tries to catch up the host timer. Here is how it looks.

1. Start watching.
Host time: 14:44:54
Guest time: 14:44:54

The guest times works a bit slower than the host one. It is visible by increased difference between timers. Also I noticed that a GIF image in a web-browser is animated slower than the same image on the host OS.

2. Some time later.
Host time: 14:45:40
Guest time: 14:45:12

We can see that for the 46 seconds passed, in VM only 18 seconds passed. At this moment the "activity period" starts, and VM is running very fast (duplicating keypresses, as was described in the first post, and accelerating the same GIF image animation, too).

3. After the "activity period" finishes.
Host time: 14:45:47
Guest time: 14:45:47

So, for the 7 seconds VM caught up 35 seconds it was behind.
CaptainFlint
 
Posts: 86
Joined: 9. Oct 2007, 10:17
Location: Moscow, Russia
Primary OS: MS Windows XP
VBox Version: PUEL
Guest OSses: WinXP, Vista, openSUSE, Ubuntu

Keyboard regulary starts working too fast - workaround

Postby Alegranon » 7. Nov 2008, 21:02

I have the same problem and may have a workaround. If the host machine has Hyperthreading "enabled" in the BIOS, change it to "disabled". This fixed the typing issue on a Pentium 4 machine with Windows XP SP3 that has VBox 2.0.2 installed with a Linux guest booting from the Knoppix 5.3.1 Live DVD iso image. After this change, the system clock in the Linux guest now increments at the same interval as the Windows host's clock.
Alegranon
 
Posts: 3
Joined: 7. Nov 2008, 20:50

Postby pete_l » 8. Nov 2008, 12:41

I'm not too clear on your description of the keyboard being "too fast", but I've had similar problems with Suse as a guest (both 10.x and 11).
Briefly, when using the arrow keys (typically, although it can happen with any keys), I sometimes find the key "autoreapeating" even if I've only pressed it once. During this time, which can last for minutes, the CPU goes to 100% and the guest is unusable. Sometimes I can switch out, back to the host - other times the whole system seems locked. I can't say if this has the same root-cause as your problems.
I did report this as a bug to Suse and got a rather glib response that "it sounds like the X virtualisation bug" - as if being able to give the problem a name is enough of a solution, rather than actually fixing it. Since this problem does not occur with any other Linux guest, it seems to be purely a Suse issue.
Since this was around the beginning of the year and still hasn't been fixed - with no solution in sight I've dumped Suse (although I've been _buying_ and using their O/S's for many, many years) and migrated to Ubuntu for both guests and host.
pete_l
 
Posts: 61
Joined: 23. May 2008, 15:10

Re: Keyboard regularly starts working too fast in guest

Postby inrange » 26. Nov 2009, 15:13

I am having similar problem running MS/DOS virtual machine with Ghost. It requires lots of pull down selection menus, and you cannot select anything but the first or last item as the up and down arrow keys go to fast (must be sending in multiple presses). By accident I tried the arrow keys on the right hand side numeric keypad, these operated as single key depressions. Environment is VB 3.0.12, Windows XP pro host. This may be a workaround, but really sounds like a bug in Vbox.
inrange
 
Posts: 4
Joined: 7. May 2009, 20:44
Primary OS: MS Windows 2003
VBox Version: PUEL
Guest OSses: linux, windows, solaris


Return to Using VirtualBox

Who is online

Users browsing this forum: Bing [Bot] and 7 guests