A bug in virtualBox file share in Windows Hosts.

Discussions related to using VirtualBox on Windows hosts.

A bug in virtualBox file share in Windows Hosts.

Postby TangCheng » 23. Jan 2009, 04:45

VirtualBox version is 2.0.6, VirtualBox Host is WindowXP, Client is Linux, /src is a virtual share directory:
root [ /src/bdrr ]# make
make -C /lib/modules/2.6.26/build M=/src/bdrr modules
make[1]: Entering directory `/u/linux-2.6.26'
rm: cannot remove `/src/bdrr/.tmp_versions/*': Protocol error
make[1]: *** [crmodverdir] Error 1
make[1]: Leaving directory `/u/linux-2.6.26'
make: *** [default] Error 2


Then I contiue to test:
#rm /sharedir/*
Protocol error
# ls /src/bdrr/.tmp_versions/*
ls: cannot access /src/bdrr/.tmp_versions/*: Protocol error

So I think when a directolry is empty, the operator the directory such as:
rm <directory>/*
ls <directory>/*

This is my temportary solution:
cd /vboxsetup
/mnt/cdrom/VBoxLinuxAdditions.run --tar xvf

change the source files Error Code "EPROTO" to "ENOENT":
sed -i "s/\-EPROTO/\-ENOENT/g" `grep "\-EPROTO" -rl /u/vbox/module/vboxvfs/*.c`


Then reinstall vboxvfs module:
./install.sh vfs-module
TangCheng
 
Posts: 1
Joined: 23. Jan 2009, 04:35

Thanks TangCheng....

Postby whoay64 » 16. Feb 2009, 07:16

Thank you very much.
Your solution is great~~...

I would like to add one more,
after executing your final command "./install.sh vfs-module"
I can't use copy/paste, in XP host, Linux guest env.

So I change your final command as "./install.sh"
It was good for everyting...

Thanks...
whoay64
 
Posts: 1
Joined: 16. Feb 2009, 07:10

Re: A bug in virtualBox file share in Windows Hosts.

Postby lavalamp » 13. Sep 2010, 03:45

I have exactly this problem, but it seems the format of the guest extensions installer has changed. I tried making the same substitution in the "src/vboxsf-3.2.8" directory (from the internal .tar.bz2 file) and running make && make install. The command completes without errors (some warnings) but after I reboot guest additions no longer mount. Does anyone know what else I should do?

Thanks!

(sorry for thread necro, this seems to be the only place on the internet where people mention this problem)
lavalamp
 
Posts: 2
Joined: 13. Sep 2010, 03:37
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: ubuntu

Re: A bug in virtualBox file share in Windows Hosts.

Postby lavalamp » 13. Sep 2010, 11:17

I mostly got it working.

First, run the installer. Then use the --tar xjf command to extract its contents somewhere.

Next, fix your source:

root@ubuntu-vm:~# cd /usr/src/vboxsf*
root@ubuntu-vm:/usr/src/vboxsf-3.2.8# sed -i "s/\-EPROTO/\-ENOENT/g" `grep "\-EPROTO" -rl *.c`

finally, go to the place you extracted the installer's contents and run ./vboxadd setup

I now seem to have some troubles with it automatically mounting on startup, but if need be I can fix it manually everytime I reboot. Anyway, if you have this problem this should get things running for you.
lavalamp
 
Posts: 2
Joined: 13. Sep 2010, 03:37
Primary OS: MS Windows 7
VBox Version: OSE other
Guest OSses: ubuntu


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 35 guests