ksoftirqd Using 20-25% of CPU with only GUI running

Discussions related to using VirtualBox on Linux hosts.

ksoftirqd Using 20-25% of CPU with only GUI running

Postby poet_imp » 10. Aug 2007, 18:18

When I start VirtualBox, before I even think of starting a virtual machine, I look at system utilization and notice ksoftirqd using a very significant portion of my box; usually 20-25%.

Here is what I see in top:

Code: Select all   Expand viewCollapse view
  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
    7 root      15  -5     0    0    0 S   21  0.0   0:11.80 ksoftirqd/1


Is this a known issue? Is there something I can do to make it not do this?

$ uname -a
Linux xxx.xxx.com 2.6.22.1-41.fc7 #1 SMP Fri Jul 27 18:10:34 EDT 2007 i686 i686 i386 GNU/Linux

$ rpm -qa | grep -i virt
VirtualBox-1.4.0_21864_fedora7-1

$ sudo /usr/bin/smoltSendProfile
<snip>
Platform: i686
BogoMIPS: 6403.40
CPU Vendor: GenuineIntel
CPU Model: Intel(R) Pentium(R) 4 CPU 3.20GHz
Number of CPUs: 2
CPU Speed: 3199
System Memory: 2026
System Swap: 1983
Vendor: BUYMPC
System:
Form factor: unknown
Kernel: 2.6.22.1-41.fc7
<snip>
poet_imp
 
Posts: 3
Joined: 7. Aug 2007, 20:10

Am I the only one?

Postby poet_imp » 13. Aug 2007, 23:29

Interesting... I was hoping for at least a "I am noticing the same things... " post. Am I the only one seeing this?
poet_imp
 
Posts: 3
Joined: 7. Aug 2007, 20:10

Postby vor » 20. Aug 2007, 00:07

I was seeing this too using a 2.6.22 kernel and VirtualBox from svn. Just starting the VirtualBox gui was causing the problem even if no VM's were running. Getting the latest bits from svn today made the problem go away so it would seem the problem will be fixed with the new version of VirtualBox.
vor
 
Posts: 2
Joined: 19. Aug 2007, 23:56

Postby vor » 20. Aug 2007, 00:11

Actually, I take that back. It appeared to be fixed but then I realized I didn't have the kernel module loaded. Once the kernel module is loaded, it still uses the 20% CPU while idle even with the latest bits from svn.
vor
 
Posts: 2
Joined: 19. Aug 2007, 23:56

Postby c0nv1ct » 20. Aug 2007, 00:48

Same issue here, seems to have started around the time i upgraded my kernel to 2.6.22. I get 2 processes, ksoftirqd/0 and ksoftirqd/1, both using 10-20% cpu. I'm using vbox 1.4.0 though, havent tried svn version yet.
c0nv1ct
 
Posts: 2
Joined: 19. Aug 2007, 20:07

Postby c0nv1ct » 4. Sep 2007, 01:02

Problem still exists in 1.5.0 OSE :(
c0nv1ct
 
Posts: 2
Joined: 19. Aug 2007, 20:07

Postby frank » 6. Sep 2007, 22:34

Please could you attach your kernel configuration?

Thanks,

Frank
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Postby frank » 10. Sep 2007, 11:32

Please could you try to boot with the
nohz=off

Linux kernel command line parameter?
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Postby nc42 » 10. Sep 2007, 18:58

What does nohz=no do? It seems to work
nc42
 
Posts: 3
Joined: 10. Sep 2007, 04:25

Postby frank » 11. Sep 2007, 09:48

This option prevents the host Linux to enter the tickless mode. In this mode the kernel timer is programmed in one-shot mode, contrary to the periodic mode which is normally used. VirtualBox currently does not play well with host kernels in one-shot mode. We are working on a solution. Until we fixed it, use this option to restore the old behavior.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Kubuntu 7.10 gutsy

Postby thripsi » 9. Nov 2007, 12:03

I had the same problem with ksoftirqd on (k)ubuntu 7.10
(linux 2.6.22-14-generic, VirtualBox 1.5.0 OSE).
The boot option "nohz=off" did solve the problem .
thripsi
 
Posts: 1
Joined: 9. Nov 2007, 11:52

Postby Pépou » 9. Jan 2008, 21:39

Frank Mehnert wrote:Please could you try to boot with the
nohz=off

Linux kernel command line parameter?

Sorry but I've got the CPU problem too. Where can we change the kernel configuration ??

Thank you. My guest is ubuntu gusty.
Pépou
 
Posts: 5
Joined: 9. Jan 2008, 21:36

Postby frank » 10. Jan 2008, 14:59

The guest is not relevant, only the host in that case.
frank
Oracle Corporation
 
Posts: 3362
Joined: 7. Jun 2007, 09:11
Location: Dresden, Germany
Primary OS: Debian Sid
VBox Version: PUEL
Guest OSses: Linux, Windows

Postby Pépou » 11. Jan 2008, 11:30

Sorry I confused myself. My host is ubuntu gusty, and my guest is windows XP.. So I need to do this modification !

Thank you in advance for your help.
Pépou
 
Posts: 5
Joined: 9. Jan 2008, 21:36

Postby Ingo » 11. Jan 2008, 19:47

In / boot/grub/menu.list for bootloader grub or in /etc/lilo.conf for bootloader lilo.
The simplest way to a complex system is to start with a simple system.
Ingo
Volunteer
 
Posts: 731
Joined: 22. Aug 2007, 10:13
Location: Germany

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: No registered users and 23 guests