Windows 2000 setup always crashes during device detection

Discussions about using Windows guests in VirtualBox.
Post Reply
Gentle826
Posts: 7
Joined: 14. Aug 2023, 19:47

Windows 2000 setup always crashes during device detection

Post by Gentle826 »

Every time I try to setup Windows 2000 Professional in a VM, it will crash during device setup.
During formatting and copying, it's fine, it starts detecting drivers but after about half a minute, the window locks up, after another minute, it then tells windows it's not responding.

I have also noticed this happening on Windows XP, but unlike XP, Windows 2000 won't complete setup regardless.
Attachments
VBox.log
(76.71 KiB) Downloaded 1 time
Kurt_Aust
Posts: 39
Joined: 10. Apr 2009, 04:48
Primary OS: MS Windows 2003
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: XP x64, W2K, 98se

Re: Windows 2000 setup always crashes during device detection

Post by Kurt_Aust »

It's been a long time since I checked it but it used to be that Windows 2000 would not work in VirtualBox if Avast anti-virus was installed on the host (disabling it wasn't enough, it had to be uninstalled).

Perhaps try disabling any security software to see if that makes a difference?
ghr
Volunteer
Posts: 379
Joined: 25. May 2007, 22:46
Primary OS: MS Windows 7
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: DOS, Win3x, Win95, WinXP, Ubuntu, OS/2

Re: Windows 2000 setup always crashes during device detection

Post by ghr »

I had to do this:

Code: Select all

VBoxManage setextradata "VM name" "VBoxInternal/Devices/piix3ide/0/Config/IRQDelay" 1
This sets the delay to one millisecond. In case this doesn’t help, increase it to a value between 1 and 5 milliseconds. Please note that this slows down disk performance. After installation, you should be able to remove the key (or set it to 0).
From Microsoft KB955076.
Post Reply