TPM not active, even though TPM v2.0 enabled

Discussions about using Windows guests in VirtualBox.
Post Reply
MarkFoley
Posts: 155
Joined: 19. Aug 2016, 03:20

TPM not active, even though TPM v2.0 enabled

Post by MarkFoley »

I have a Windows 10 guest running on a Linux host with VirtualBox version 7.0.14 r161095. The Windows guest is set to boot UEFI. I have the VBox Settings > System, set to TPM v2.0 and Enable EFI. Secure boot not enabled. However, I cannot upgrade this guest to Windows 11. The utility I ran to check compatibility says, "TPM Not Activated", even though tpm.msc says "Status: TPM is ready for use".

I've successfully upgraded a similar system with exactly the same CPU. The only difference is that this failing system has a mdadm RAID array. Therefore, the Linux guest cannot boot UEFI, and I don't think I have the BIOS set to enable TPM. I understood I could enable UEFI and TPM in the VirtualBox Manager and the actual hardware of the Linux host wouldn't matter (except possibly for the CPU).

Is this setup workable for Windows 11 upgrading or do I have to revert to getting rid of the RAID?
DSB Cloudian
Posts: 7
Joined: 1. Apr 2022, 23:04

Re: TPM not active, even though TPM v2.0 enabled

Post by DSB Cloudian »

If you haven't solved this yet, check the guest VM's "Device Manager" to see if the TPM 2.0 device was installed and is started.

If you have solved this problem, let me know.
I enabled TPM 2.0 in the guest's VM Setup and rebooted, but in the VM's "Device Manager", it shows the device "Trusted Platform Module 2.0" is installed but not started.
The Windows Security still shows "Standard hardware security is not supported"
MarkFoley
Posts: 155
Joined: 19. Aug 2016, 03:20

Re: TPM not active, even though TPM v2.0 enabled

Post by MarkFoley »

Solved. A couple of issues. Even though I can't set the BIOS (and hence VM host) to boot UEFI because the system is a mdadm RAID, I can set VirtualBox to boot UEFI in Settings. But, I still need to set the BIOS to enable TPM. The 2nd issue was the my ASUS BIOS had two "flavors" of TMP settings. I don't recall what they were, but one worked and the other did not. So the solution was, don't set BIOS UEFI (for mdadm RAIDs), do set BIOS TPM.
Post Reply