Discuss the VirtualBox 7.0.18 release here

This is for discussing general topics about how to use VirtualBox.
NAILS
Posts: 11
Joined: 5. Sep 2022, 13:36

Re: Discuss the VirtualBox 7.0.18 release here

Post by NAILS »

bmaehr wrote: 17. May 2024, 01:15 I prefer to stay with version 7.0.14 if that is not changed. I'm not going to change a lot of permission or directory structure just because some i... wants to have that for his software. :evil: :evil:
...
Although I wouldn't put it that harsh, I would indeed have appreciated this would have been a choice rather than a forced-on obligation. Not to mention it's a bit daft to make this an all-or-nothing requirement - if it clashes with the local concept of security, it's impossible to use Virtualbox any longer. Our IT department certainly won't change its habits because oracle says so.
hugoxy
Posts: 3
Joined: 19. May 2024, 17:15
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the VirtualBox 7.0.18 release here

Post by hugoxy »

1. I have used Virtual Box from many years without problems, in Windows 10 x64.
2. in May 24, when vr. 7.0.18 had appears, I installed it without problems (in the installation process); I opened the virtual machine and I ins-talled the Guest Additions adequately.
3. When I tried to close the virtual machine, it stayed eternally in "stopping", it never "powered off"!
4. I had return to vr. 7.0.14, without problems. All functions were OK.
5. I tried to install vr. 7.0.19 (beta). When I tried to close the virtual machine, it also remained eternally in "stopping" process, never reached the "powered off".
6. I had reinstalled vr. 7.0.14 and now all is OK.
7. Is there a bug in vr. 7.0.18 while closing Virtual Box in some machines?
okcrum
Posts: 28
Joined: 16. Sep 2022, 21:00
Primary OS: Ubuntu other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Windows, Solaris, Debian

Re: Discuss the VirtualBox 7.0.18 release here

Post by okcrum »

multiOS wrote: 10. May 2024, 00:00 Please avoid 'Image' links on the Forum - they don't work if the file isn't accessible and most Forum users are unlikely to 'visit' unknown links if they value their own security. Use the upload attachment Tab on the message screen instead
Well, since they don't work if the file IS accessible, I do think I'll avoid them. ;) I'd scan the .png first before opening, if I were me. Trust, but verify. Thanks, though.
RonSMeyer1
Posts: 35
Joined: 26. May 2012, 16:20
Primary OS: Ubuntu other
VBox Version: VirtualBox+Oracle ExtPack
Guest OSses: Host: Linux Mint / Guests: Windows 10 - Win XP - OS/2 Warp 4 - MS-DOS

Re: Discuss the VirtualBox 7.0.18 release here

Post by RonSMeyer1 »

hugoxy wrote: 19. May 2024, 20:06 1. I have used Virtual Box from many years without problems, in Windows 10 x64.
2. in May 24, when vr. 7.0.18 had appears, I installed it without problems (in the installation process); I opened the virtual machine and I ins-talled the Guest Additions adequately.
3. When I tried to close the virtual machine, it stayed eternally in "stopping", it never "powered off"!
4. I had return to vr. 7.0.14, without problems. All functions were OK.
5. I tried to install vr. 7.0.19 (beta). When I tried to close the virtual machine, it also remained eternally in "stopping" process, never reached the "powered off".
6. I had reinstalled vr. 7.0.14 and now all is OK.
7. Is there a bug in vr. 7.0.18 while closing Virtual Box in some machines?
Yes. There are several posts about saving VMs not working. The problem has not been addressed. The problem was in 7.0.16 as well, apparently. It is concerning if the problem is still in the 7.0.19 beta, and is still not being addressed.
JedMasterson
Posts: 1
Joined: 22. May 2024, 12:29

Re: Discuss the VirtualBox 7.0.18 release here

Post by JedMasterson »

hugoxy wrote: 19. May 2024, 20:06 1. I have used Virtual Box from many years without problems, in Windows 10 x64.
2. in May 24, when vr. 7.0.18 had appears, I installed it without problems (in the installation process); I opened the virtual machine and I ins-talled the Guest Additions adequately.
3. When I tried to close the virtual machine, it stayed eternally in "stopping", it never "powered off"!
4. I had return to vr. 7.0.14, without problems. All functions were OK.
5. I tried to install vr. 7.0.19 (beta). When I tried to close the virtual machine, it also remained eternally in "stopping" process, never reached the "powered off".
6. I had reinstalled vr. 7.0.14 and now all is OK.
7. Is there a bug in vr. 7.0.18 while closing Virtual Box in some machines?
Does your VM's OS is Linux? If yes i have a similar problem with Linux Mint and latest VBox GA. Tuns out it's Xorg and latest Guest Additions conflicting with each other. I haven't figured out how to solve this problem yet.
hugoxy
Posts: 3
Joined: 19. May 2024, 17:15
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the VirtualBox 7.0.18 release here

Post by hugoxy »

Thanks, RonSMeyer1!
klaus
Oracle Corporation
Posts: 1196
Joined: 10. May 2007, 14:57

Re: Discuss the VirtualBox 7.0.18 release here

Post by klaus »

Confirmed. It seems the hang happens with VMs having USB 1.1 (OHCI) enabled. Switching to USB3 (xHCI) would avoid this (and is part of VirtualBox 7.0 base package).

Test build with the fix not needing the reconfig should be available shortly.
hugoxy
Posts: 3
Joined: 19. May 2024, 17:15
Primary OS: MS Windows other
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the VirtualBox 7.0.18 release here

Post by hugoxy »

No JedMasterson, my VM’s OS is not Linux; it is Win10x64. I thing klaus has solved my problem.
Tks.
Jmars
Posts: 3
Joined: 24. May 2024, 22:02

Re: Discuss the VirtualBox 7.0.18 release here

Post by Jmars »

Capture.JPG
Capture.JPG (39.31 KiB) Viewed 1683 times
getting this error after upgrading from 7.0.16 to 7.0.18. cannot figure out why, please help!
klaus
Oracle Corporation
Posts: 1196
Joined: 10. May 2007, 14:57

Re: Discuss the VirtualBox 7.0.18 release here

Post by klaus »

The previous post sounds like you somehow managed to get a mix of 7.0.16 and 7.0.18 installed. Not a known general issue. Try uninstalling VirtualBox and re-install 7.0.18.
papi_yvel
Posts: 1
Joined: 28. May 2024, 17:50

Re: Discuss the VirtualBox 7.0.18 release here

Post by papi_yvel »

Hi everybody,

VB 7.0.18 installed on Win11 computer, and having sound issues on Ubuntu versions 22.04 and 24.04.
The sound is choppy and running faster than normal with VLC. It seems that the buffer is playing faster on host than normal speed and this is why the sound is choppy because waiting for new data packets to continue.

I uninstalled VB 7.0.18 to re-install my previous 7.0.6 version, and with the same VDI files, sound is playing correctly, with exactly the same sound settings.

Sound problems is a reccurent issue on VB. I have it regularly on new versions.
Jmars
Posts: 3
Joined: 24. May 2024, 22:02

Re: Discuss the VirtualBox 7.0.18 release here

Post by Jmars »

Jmars wrote: 24. May 2024, 22:06 Capture.JPG
getting this error after upgrading from 7.0.16 to 7.0.18. cannot figure out why, please help!

now i get this error with a fresh install of 7.0.18
Attachments
Vbox Error1.JPG
Vbox Error1.JPG (113.98 KiB) Viewed 1128 times
vobx error.JPG
vobx error.JPG (18.81 KiB) Viewed 1128 times
klaus
Oracle Corporation
Posts: 1196
Joined: 10. May 2007, 14:57

Re: Discuss the VirtualBox 7.0.18 release here

Post by klaus »

You still have somehow the old driver from a previous VirtualBox version installed. The certificate serial number for 7.0.18 is 060e2f8f9e1b8be518d5fe2b69cfccb1. The message you're getting is from the driver when it checks the signature of the executable trying to talk with it.
Jmars
Posts: 3
Joined: 24. May 2024, 22:02

Re: Discuss the VirtualBox 7.0.18 release here

Post by Jmars »

What is the quick fix for this, Ive aready done a full uninstall and reinstall.
klaus
Oracle Corporation
Posts: 1196
Joined: 10. May 2007, 14:57

Re: Discuss the VirtualBox 7.0.18 release here

Post by klaus »

For the record (thanks to Jmars for hunting it down): this was caused by having an older Extension Pack installed (which used the old certificate/key). Looks like we need to improve diagnostics in this case. This will happen roughly yearly now due to the shorter certificate validity, maybe we'll find a way to also accept the previous one.
Post Reply