Win XP VM Goes Black After Installing GuestAddons

Discussions about using Windows guests in VirtualBox.
javispedro
Posts: 59
Joined: 29. Jan 2022, 15:31
Primary OS: openSUSE
VBox Version: OSE other
Guest OSses: Old & New Windows, Linux

Re: Win XP VM Goes Black After Installing GuestAddons

Post by javispedro »

I have reproduced that after installing 7.0.14 additions on XP 64 I got a black screen on the next boot (and the guest window didn't resize).
The 7.0.14 additions work fine for me on XP 32.
(Also, 7.0.14 works on Vista32, Vista64, Win7, etc. Pity about XP64; they were close to being one of the best releases of the 7.0.x additions series so far :) ) .

I may try to dig a bit more if I find time.
Apparently we have had this issue on XP64 ever since 7.0.8, the same release that introduced the same issue on XP32.
I had never upgraded the additions on my XP64 boxes so I didn't realize this. :(
Unfortunately, unlike XP32, the 7.0.10 additions did NOT fix the issue.

to recap
7.0.0 additions -> OK
7.0.6 -> OK
7.0.8 -> black screen
7.0.10 -> black screen
7.0.12 -> black screen
7.0.14 -> black screen

I am not sure what ended up being the fix for the 7.0.10 additions.
Interestingly, It turns out that the fix for XP32 in 7.0.10 was simply to install the Win2k driver even on XP guests.
If you try to install the "XP" driver contained in the additions ISO it still has the black screen bug, even on XP32 and even on 7.0.14 :)
The installer transparently installs the w2k one even if your guest is detected as XP(32).
No idea what the issue really is , as the only changes between the XP and w2k driver seem to be in the .inf file .

Fortunately, the same inf changes can be done to the 64-bit XP driver. See attached .inf file.
Replacing the VBoxVideo.inf file (in your XP64's C:\Program Files\Oracle\VirtualBox Guest Additions) with the attached one, and then reinstalling the VBoxVideo driver from it makes it work, even on XP64.
I'm providing the patched .inf just in case you really need to use the 7.0.14 additions, or to debug the issue.

For everyone else, just install the 7.0.6 additions as a workaround.
ISO here: https://download.virtualbox.org/virtual ... _7.0.6.iso

Turns out there is a ticket open about this: https://www.virtualbox.org/ticket/21982
Attachments
VBoxVideo.inf.zip
(1.7 KiB) Downloaded 21 times
fth0
Volunteer
Posts: 5677
Joined: 14. Feb 2019, 03:06
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Linux, Windows 10, ...
Location: Germany

Re: Win XP VM Goes Black After Installing GuestAddons

Post by fth0 »

Thanks for the thorough investigation and for updating #21982! :)
kenkamm
Posts: 2
Joined: 31. Mar 2024, 12:50

Re: Win XP VM Goes Black After Installing GuestAddons

Post by kenkamm »

Would someone be so kind as to outline the exact steps I need to install the 7.0.6 Guest Additions iso? I had the black screen and I reinstalled, got back to a working Windows 11 with the small screen. I'm stuck at that step. I understand how to install the Guest Additions that it came with, but I don't understand how to install an older version.

Thanks for any help.
Ken
kenkamm
Posts: 2
Joined: 31. Mar 2024, 12:50

Re: Win XP VM Goes Black After Installing GuestAddons

Post by kenkamm »

Well, I figured it out. But I still get the black screen.

I'm running this on an Intel Mac with MacOS Sonoma 14.2.1. Something is definitely not working.

I managed to uninstall GA and now I'm back to the tiny Windows 11 screen. Does anyone know how to get this working? I'm running VB version 7.0.14 r161095 (Qt5.15.2).

Thanks for any help.
Ken
Last edited by kenkamm on 31. Mar 2024, 14:46, edited 1 time in total.
Post Reply