X Server 10.6 doesn't complete boot process

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.
Post Reply
Mk558
Posts: 3
Joined: 18. Feb 2024, 20:17

X Server 10.6 doesn't complete boot process

Post by Mk558 »

I'm trying to install 10.6 Snow Leopard Server to check it out. I've tried changing the CPU identifier ($ VBoxManage modifyvm "Mac OS X 10.6 Server v2" --cpu-profile "Intel Core2 T7600 2.33GHz" ), messing around with memory allocation, audio settings (off), different disk images (in case mine was bad) -- none of it completes.

Host: Late 2012 Mac mini 6,2 A1347. 16GB RAM, Mac OS X 10.15 Catalina. VirtualBox 7.0.14 with extension pack.

Log is below. It hangs at the line shown in the image and progresses no further.
Attachments
10.6Screen1.JPEG
10.6Screen1.JPEG (252.39 KiB) Viewed 3052 times
Mac OS X 10.6 Server v2-2024-02-18-10-06-58.log.zip
(18.94 KiB) Downloaded 9 times
granada29
Volunteer
Posts: 702
Joined: 3. Mar 2015, 07:27
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux, macOS, Windows

Re: X Server 10.6 doesn't complete boot process

Post by granada29 »

Try setting the cpu profile to: "Intel Xeon X5482 3.20GHz". This is what I am using in a working configuration.

The thread: viewtopic.php?p=508957 covers a few nuances of installing Snow Leopard, including removing the AppleIntelCPUPowerManagement kext.

Hope that helps.
granada29
Volunteer
Posts: 702
Joined: 3. Mar 2015, 07:27
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux, macOS, Windows

Re: X Server 10.6 doesn't complete boot process

Post by granada29 »

Furthermore: I strongly recommend running VirtualBox 6.1.50 on your MacMini 6,2.

I have the same machine and found VirtualBox 7.0.x worked very badly with a lot of overhead from Apple's hypervisor, which is now unsupported on Catalina and will never be fixed
Mk558
Posts: 3
Joined: 18. Feb 2024, 20:17

Re: X Server 10.6 doesn't complete boot process

Post by Mk558 »

10.6snowleopardserver2.jpg
10.6snowleopardserver2.jpg (124.62 KiB) Viewed 2981 times
I'll have to update the CPU ID later, but for now, we got past that boot startup. Didn't change much of anything. Tip: Don't do this on a thumbdrive install :mrgreen: it's a little slow right now. Doesn't matter since I'm only doing it to poke around. Today I checked out 10.2 Server, 10.3 Server and 10.4 Server. 10.0, 10.1 and 10.5 Server are later. Don't know how VBox will handle 10.5 Server but I'll try it later just in case it works so I won't have to buy a pack of dual layer DVDs.
scottgus1
Site Moderator
Posts: 20945
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: X Server 10.6 doesn't complete boot process

Post by scottgus1 »

Mk558 wrote: 19. Feb 2024, 05:21 Tip: Don't do this on a thumbdrive install
Amen to that! Thumbdrives cannot handle modern OS write counts and speeds. They'll burn up.
granada29
Volunteer
Posts: 702
Joined: 3. Mar 2015, 07:27
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux, macOS, Windows

Re: X Server 10.6 doesn't complete boot process

Post by granada29 »

Mk558 wrote: 19. Feb 2024, 05:21 Today I checked out 10.2 Server, 10.3 Server and 10.4 Server. 10.0, 10.1 and 10.5 Server are later. Don't know how VBox will handle 10.5 Server ...
I'm pretty sure you will be unable to get OSX 10.0 - 10.4 running in VirtualBox. These OS's are PPC architecture and won't run on intel hardware.

Tiger (MacOS X 10.5) should work. This was covered recently in: viewtopic.php?t=111007
Mk558
Posts: 3
Joined: 18. Feb 2024, 20:17

Re: X Server 10.6 doesn't complete boot process

Post by Mk558 »

granada29 wrote: 19. Feb 2024, 21:36 Tiger (MacOS X 10.5) should work.
Leopard?

I'll look into it. When I was speaking of 10.2 et al I have 6 operating systems on my mac mini G4, with room for a 7th or 8th. To quote GLaDOS, "Testing, testing testing!!"

I have a hackintosh 10.4 install that does work in VirtualBox. No 3D acceleration though. Meh. I like Tiger on my mac mini G4 though. Tiger is my #1 operating system of all time.
granada29
Volunteer
Posts: 702
Joined: 3. Mar 2015, 07:27
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: Linux, macOS, Windows

Re: X Server 10.6 doesn't complete boot process

Post by granada29 »

Sorry - my bad in getting the versions confused.

Yes - Leopard will work OK as well - again search this forum for previous hints.
Post Reply