An old innotek VirtualBox installation has been found ...

Discussions related to using VirtualBox on Windows hosts.

An old innotek VirtualBox installation has been found ...

Postby arakel » 21. Dec 2008, 00:27

I have an installed version 2.0.6 and try to install the new 2.1 on win xp sp2.
If I try to install the new version I get following error message:
“An old innotek VirtualBox installation has been found on this machine. Please uninstall this package first and then install Sun xVM VirtualBox!”
The same error-message I get if I want to uninstall the current version, there is no chance to get rid off it.
Does anybody have an idea how I can solve this problem?

Thanks
Arakel
arakel
 
Posts: 2
Joined: 21. Dec 2008, 00:20

Postby Sasquatch » 21. Dec 2008, 20:59

Did you try to run the installer of the version that is already installed? From the installer, you can repair and remove the installation. You might want to repair first, then remove. Do a reboot after the removal so that any system file that needs an update is done.
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby arakel » 21. Dec 2008, 22:47

Thanks Sasquatch for the reply.
Unfortunately the error message also appears if I try to change / repair the installation.

After searching the registry I found the problem. For making clones of the images I use the handy tool clonevdi. This tool needs an entry in registry which tells that the version 1.6.2. is installed.

[HKEY_LOCAL_MACHINE\SOFTWARE\Innotek\VirtualBox]
"Version"="1.6.2"

After deleting this entry and a reboot the update to version 2.1 worked without problems.
Well, I have to say it was my fault. Sorry.
Hopefully this post can help people which are also as unmindful like me.
:roll:
arakel
 
Posts: 2
Joined: 21. Dec 2008, 00:20


Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: Bing [Bot], massula, Todd N and 31 guests