Oracle Virtualbox Not replying to Internet Ping

Discussions about using Windows guests in VirtualBox.

Oracle Virtualbox Not replying to Internet Ping

Postby Bazza from Taupo NZ » 22. Jul 2021, 05:50

I have a VW Service and Workshop manual which came as an Oracle database file. It installs a Virtualbox on Win10 using Windows XP. After install it does not let me ping the internet from the XP shell.

Ipconfig from the XP shell shows:
IP address 192.168.1.67 (pingable OK)
Mask 255.255.255.0
Gateway 192.168.1.1 (Unpingable)
DNS 202.180.64.10 (Unpingable)
DHCP enabled = NO

In this state the VW database is unable to access the internet and cannot progress further.

On the Win10 Host
I can access the internet as normal.

Main Cable Connected Adapter
Virtualbox NDIS6 Bridged Networking Driver installed and ticked.

Virtualbox Host Only Network Adapter
IP Address 192.168.25.1 (Unpingable)
Mask 255.255.255.0
No Gateway
No DNS

I would really appreciate help form anyone on this forum who have a working model similar to mine as I must be missing something in the setup.

Regards
Bazza from Taupo NZ.
Bazza from Taupo NZ
 
Posts: 3
Joined: 22. Jul 2021, 05:23
Primary OS: MS Windows 10
VBox Version: OSE other
Guest OSses: Windows XP

Re: Oracle Virtualbox Not replying to Internet Ping

Postby mpack » 22. Jul 2021, 11:02

Why is DHCP disabled?

And are you sure you are using bridged networking in the VM, and not "host only"? As the latter name indicates, this allows you to communicate with the host (only), there is no Internet access.

The fact that the NDIS host virtual adapter is ticked tells me that bridged networking is available, not that you are using it.

And speaking of the network being available, I'm not entirely certain that XP can talk IPv6, so I would hope that the NDIS4 adapter is available too (or instead of). The IP addresses you've quoted so far are all IPv4, so I assume you still use this locally.
mpack
Site Moderator
 
Posts: 34757
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Oracle Virtualbox Not replying to Internet Ping

Postby Bazza from Taupo NZ » 22. Jul 2021, 13:18

My host adapter settings now are:
IP 192.168.1.67
Mask 255.255.255.0
Gateway 192.168.1.1
DNS 202.180.64.10

After loading the VM running XP I now have an adapter entry on the host. Called "Virtualbox Host Only Network Adapter"
No settings are available.

If I now go to the XP VM the adapter is as follows:
IP 192.168.1.67 (pingable)
Mask 255.255.255.0
Gateway 192.168.1.1 (NOT pingable)
DNS 202.180.64.10 (NOT pingable)

We are not there yet but the bridging shows for the 2 adapters on Win10 host. All I am missing are the 2 pings on the XP and it will probably work.
Bazza from Taupo NZ
 
Posts: 3
Joined: 22. Jul 2021, 05:23
Primary OS: MS Windows 10
VBox Version: OSE other
Guest OSses: Windows XP

Re: Oracle Virtualbox Not replying to Internet Ping

Postby scottgus1 » 22. Jul 2021, 13:53

Bazza from Taupo NZ wrote:My host adapter settings now are:
IP 192.168.1.67

Bazza from Taupo NZ wrote:the XP VM the adapter is as follows:
IP 192.168.1.67 (pingable)

Two houses on the same street cannot have the same house number. Otherwise the mail carrier won't know where to deliver the mail.

Sounds like your choice of static IP address is bunged up. Set back to DHCP, let the VM OS get its own IP address.

Mpack's mention of Host-Only is only to show a network choice you would not want to use to get internet in the VM. See Virtualbox Networks: In Pictures.

For internet access in one VM use Bridged or NAT. NAT is the easiest if you only need internet in the VM. If you have to also access the VM OS's network services from other computers on your physical network, Bridged is required.
scottgus1
Site Moderator
 
Posts: 13389
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Oracle Virtualbox Not replying to Internet Ping

Postby Bazza from Taupo NZ » 4. Aug 2021, 09:03

I have since worked with my son who lives just north of seattle. He did the same install but was able to ping from the XP shell. I reinstalled and now can achieve this as well. BUT we both cannot access the internet using XP Internet Explorer. There must be some missing link that we have both overlooked. Maybe you can comment.

Thank you so far. It could have something about port forwarding but not sure. We are using the latest versions of Virtual Box and Win10.
Bazza from Taupo NZ
 
Posts: 3
Joined: 22. Jul 2021, 05:23
Primary OS: MS Windows 10
VBox Version: OSE other
Guest OSses: Windows XP

Re: Oracle Virtualbox Not replying to Internet Ping

Postby mpack » 4. Aug 2021, 09:56

Bazza from Taupo NZ wrote:we both cannot access the internet using XP Internet Explorer

Internet Explorer as it shipped in XP (IE6) is far too old to understand the modern Internet. Basically, any website that still uses "http:" will (almost) work, anything that uses "https:" (i.e. almost everything) will fail.

This has nothing to do with ping, which uses a much lower level protocol. If ping works then your network connection is ok. It's the XP browser that's crap. Even worse news: all of the mainstream browsers abandoned XP support around 10 years ago, and even the less mainstream browsers mostly followed suit in the last 5 years or so.

However, I was reading this morning about MyPal, a modern browser that someone is maintaining for the express purpose of supporting XP. Download the 32bit installer to the host, copy it into the XP guest via a shared folder, and install. MyPal is based on "Pale Moon", which I used until I recently switched to Edge. "Pale Moon" was based on source code from FireFox.
mpack
Site Moderator
 
Posts: 34757
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 23 guests