Unable to insert virtual optical disk

Discussions about using Linux guests in VirtualBox.

Unable to insert virtual optical disk

Postby KashootMyself » 9. May 2021, 21:47

The exact error I got was
"Could not mount the media/drive 'C:\Program Files\Oracle\VirtualBox/VBoxGuestAdditions.iso' (VERR_PDM_MEDIA_LOCKED)."

What I want to do is make my virtualbox window bigger.

I am running Ubuntu 20.04 under version 6.1.22 of the virtual machine.
I have a laptop with 8Gb of ram.
I am a complete beginner in Linux, VMs and virtualbox

I have encountered many problems when installing my VM, which may be important to my question.

When I first set up my virtual machine I gave it 10Gb of space and 1Gb of ram, and tried to put it on my C drive which was a big mistake because my C drive didn't have nearly enough space and my laptop started doing weird things. I was genuinely worried I might not be able to fix it. In the end, even though my laptop was barely working, I deleted the virtual box folder and made just enough space for my computer to be working again. I tried to open the installation file again and clicked remove all previous files, while the other option was to restore them. After that I spent some time cleaning my computer, and when I went to install it again, I got an error. The fix for the error was to move the virtualbox folder somewhere else in my computer and I put it on my desktop. It worked out, so I went to install it once again. I partitioned the space myself with 2Gb of ram, 10Gb for ext4 "/", 2Gb for swap, and 4Gb and a bit for "'/home". The machine works incredibly slow. My friend has a lot less space than me and it works fine for him(10Gb space and 1Gb ram).

Then, I wanted to make my virtual machine window bigger, and asked my friend. I went to devices tab and clicked "Insert Guest Additions CD image". Now I have this error and I cannot fix it

What can I do? Does this issue relate to any of my previous ones? Was moving the VirtualBox onto another folder a bad Idea?

Thank you for reading.
Posts: 1
Joined: 9. May 2021, 21:22

Re: Unable to insert virtual optical disk

Postby scottgus1 » 9. May 2021, 22:46

This error means the VM has an ISO already loaded, and Linux has locked it and wont let go. It could mean you already have the Guest Additions ISO loaded.

If the GAs ISO is already loaded then you can run it. If it isn't loaded, try shutting down the VM, then emptying the VM's CD drive.
Site Moderator
Posts: 12419
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Unable to insert virtual optical disk

Postby mpack » 10. May 2021, 10:03

When you see an unambiguous error code such as "VERR_PDM_MEDIA_LOCKED", search for it in the forums. You would have found plenty of previous explanations of what this code means.
Site Moderator
Posts: 34214
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 5 guests