Failure to mount vboxsf

Discussions related to using VirtualBox on Mac OS X hosts.

Failure to mount vboxsf

Postby aenlic » 16. Apr 2021, 22:49

I'm running MacOS Big Sur (11.2.3), VirtualBox 6.1.18, and Vagrant 2.2.15. I've installed the VirtualBox Extensions, with a message that claimed to be successful. I'm trying to share files with a box created from ubuntu/xtenial64. My host is a MacBook Pro, 2019 vintage, with 16 GB of RAM and a 2.6 GHz Intel Core i7. My favorite color is green, and my favorite captain is, of course, Jean Luc. This Is The Way.

Vagrant tells me that I have a valid Vagrantfile, but VirtualBox tells me (with no helpful details) that I have 'invalid settings.' When I run 'vagrant up,' I get this error text:

Vagrant was unable to mount VirtualBox shared folders. This is usually
because the filesystem "vboxsf" is not available. This filesystem is
made available via the VirtualBox Guest Additions and kernel module.
Please verify that these guest additions are properly installed in the
guest. This is not a bug in Vagrant and is usually caused by a faulty
Vagrant box. For context, the command attempted was:

mount -t vboxsf -o uid=1000,gid=1000,_netdev vagrant /vagrant

The error output from the command was:

/sbin/mount.vboxsf: mounting failed with the error: No such device

I'm surprised that I'm not finding a raft of problems such as mine reported on this forum of elsewhere. Can anyone shed some light on this situation?
aenlic
 
Posts: 2
Joined: 16. Apr 2021, 22:33

Re: Failure to mount vboxsf

Postby scottgus1 » 16. Apr 2021, 23:26

Read through the manual, section 4.3, on Virtualbox Shared Folders, https://www.virtualbox.org/manual/ch04.html#shared folders. If you can get the VM running under Virtualbox alone sans Vagrant and mount a VSF, then Vagrant should be able to work.

FWIW, we don't grok Vagrant here. Generally, when Vagrant is involved we need to see the same problem happen using Virtualbox alone before we'd have an idea what to do.
scottgus1
Site Moderator
 
Posts: 13765
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux

Re: Failure to mount vboxsf

Postby aenlic » 17. Apr 2021, 00:04

Thank you. I used VirtualBox quite a bit some years back, without vagrant; I thought that since I was using a vagrant box as my 'starter,' the Vagrantfile would be the authority on configuraton. I was expecting to be prompted for the security permissions, and wondered why that didn't happen.

The result of granting the permissions is that I have a running machine... though VB STILL says that I have invalid settings. I'll pursue that wrinkle even though it's not in my way currently, but you've gotten me past the blocked that was plaguing me, thanks again.

aenlic
aenlic
 
Posts: 2
Joined: 16. Apr 2021, 22:33

Re: Failure to mount vboxsf

Postby scottgus1 » 17. Apr 2021, 15:12

Great! Glad you're up and running.
scottgus1
Site Moderator
 
Posts: 13765
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Linux


Return to VirtualBox on Mac OS X Hosts

Who is online

Users browsing this forum: Google [Bot] and 20 guests