VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED)

Discussions related to using VirtualBox on Linux hosts.

VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED)

Postby 2u14 » 20. May 2007, 18:25

Hi,
I installed VBox using Automatix2 on a Kubuntu 7.04. When I try to power on a machine I get this error:

Code: Select all   Expand viewCollapse view
VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Result Code:
0x80004005
Component:
Console
Interface:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}


... so I tryed ... but:

Code: Select all   Expand viewCollapse view
root@m6811ne:~# /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module ...done.
Recompiling VirtualBox kernel module ...done.
Starting VirtualBox kernel moduleFATAL: Error inserting vboxdrv (/lib/modules/2.6.20-15-generic/misc/vboxdrv.ko): Invalid argument
 ...fail!
(modprobe vboxdrv failed)
root@m6811ne:~# /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module ...done.
Recompiling VirtualBox kernel module ...done.
Starting VirtualBox kernel moduleFATAL: Error inserting vboxdrv (/lib/modules/2.6.20-15-generic/misc/vboxdrv.ko): Invalid argument
 ...fail!
(modprobe vboxdrv failed)
root@m6811ne:~# lsmod | grep vbox
root@m6811ne:~# dmesg | grep vbox
[12415.388000] vboxdrv: Trying to deactivate NMI watchdog permanently...
[12415.388000] vboxdrv: NMI watchdog either active or at least initialized. Please disable the NMI
[12415.388000] vboxdrv: watchdog by specifying 'nmi_watchdog=0' at kernel command line.
root@m6811ne:~#


Has someone a solution for this? Please help. I found noting useful on the web.

2u14
2u14
 
Posts: 2
Joined: 20. May 2007, 18:02

Postby 2u14 » 20. May 2007, 18:42

RTFM

The NMI watchdog is either active. Add nmi_watchdog=0 to the kernel command line and reboot.
Then execute sudo dpkg-reconfigure virtualbox again.


Edit the /boot/grub/menu.lst
Code: Select all   Expand viewCollapse view
title           Ubuntu, kernel 2.6.20-15-generic
root            (hd0,1)
kernel          /boot/vmlinuz-2.6.20-15-generic root=UUID=XXXXXXX ro quiet splash nmi_watchdog=0
initrd          /boot/initrd.img-2.6.20-15-generic
quiet
savedefault


and it works
2u14
 
Posts: 2
Joined: 20. May 2007, 18:02

disabling nmi doesn't work

Postby perdidonanet » 17. Apr 2008, 17:36

Tried disabling NMI and it still didn't work, any ideas?
perdidonanet
 
Posts: 1
Joined: 17. Apr 2008, 17:35

Postby dvh » 2. Sep 2008, 20:16

I had the same problem, here is what helps me:

1. find your kernel version, use "uname -r" in the terminal:

$ uname -r
2.6.24-19-generic

2. In ubuntu, in addition to virtualbox and virtualbox-ose, you need to install modules. For my version of kernel, I installed this:

$ sudo apt-get install virtualbox-ose-modules-2.6.24-19-generic

3. Then restart virtualbox backend:

$ sudo /etc/init.d/vboxdrv restart
$ sudo /etc/init.d/virtualbox-ose restart
(i am not sure about the order)

4. In Ubuntu main menu in user and groups settings, add yourself to group virtualbox. After this, you need to relogin to X windows. Then start virtualbox, it should work.
dvh
 
Posts: 1
Joined: 2. Sep 2008, 20:09

Postby itguru » 18. Oct 2008, 16:04

dvh said:
I had the same problem, here is what helps me:

1. find your kernel version, use "uname -r" in the terminal:

$ uname -r
2.6.24-19-generic

2. In ubuntu, in addition to virtualbox and virtualbox-ose, you need to install modules. For my version of kernel, I installed this:

$ sudo apt-get install virtualbox-ose-modules-2.6.24-19-generic

3. Then restart virtualbox backend:

$ sudo /etc/init.d/vboxdrv restart
$ sudo /etc/init.d/virtualbox-ose restart
(i am not sure about the order)

4. In Ubuntu main menu in user and groups settings, add yourself to group virtualbox. After this, you need to relogin to X windows. Then start virtualbox, it should work.


When I did a fresh install I recieved this error and the above fix corrected it. But, when I did an update, I received the same error. I replaced the "2.6.24-19-generic " with "2.6.24-21-generic" and it corrected the problem once again.

It seems like some files are not getting installed when you download from the add/remove programs.

Thanks for the help dvh!
itguru
 
Posts: 1
Joined: 18. Oct 2008, 15:52

Shorter fix

Postby Ozdemon » 20. Oct 2008, 01:54

I had the same problem after updating to the 2.6.24-21 kernel. This link http://tinyurl.com/6qo2fc offers a quick fix.
Ozdemon
 
Posts: 35
Joined: 23. Jun 2008, 02:44
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Win XP


Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: chankim and 23 guests