Upgrade to Big Sur now no network connectivity

For discussions related to using VirtualBox on Mac OS X pre-releases

Upgrade to Big Sur now no network connectivity

Postby Starion » 17. Nov 2020, 19:33

Upgraded to Big Sur this week. Launched VirtualBox 6.1.16 and now I have an IP conflict in Windows that I cannot fix. IP address in Windows always shows self-assigned. Interface is set for DHCP.

No changes were made to the VirtualBox networking configuration from Catalina.

On another annoying note, VirtualBox is back to not remembering the startup window location. It always reverts back to my primary monitor. Arrrrgh. I thought this was fixed and had been working fine through the last couple of versions of VirtualBox.

{Not sure why this post was moved to "VirtualBox on Mac OS X pre-releases". Big Sur is no longer a pre-release.}
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby Starion » 3. Dec 2020, 00:47

A month since I posted this, still no network connectivity and apparently no fix from VirtualBox.
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby Starion » 3. Dec 2020, 01:34

More information. Networking works set to NAT. Bridged adapter is what is not working anymore.
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby NuuKeM » 12. Feb 2021, 20:46

See post # 100751 labeled "Big Sur: VB works but no internet connection Win10" (I'm not able to post links yet)

In Windows guest, open a command prompt and run the following command:

Code: Select all   Expand viewCollapse view
netsh interface ipv4 show inter

A similar list will be displayed:
Code: Select all   Expand viewCollapse view
Idx  Met        MTU          State          Name
---  ---------- ----------   ------------   ---------------------------
1    50         4294967295   connected      Loopback Pseudo-Interface 1
11   10         1500         connected      Local Area Connection

Copy index number (Idx #11 in my case) of the adapter and use it in the following code:
Code: Select all   Expand viewCollapse view
netsh interface ipv4 set interface 11 dadtransmits=0 store=persistent

Reboot and problem solved.

Apparently, per web-searching "netsh dadtransmits=0", this solution is part of disabling Windows' IP autoconfiguration, which among other possible things sets the IP address to an APIPA address if there is no DHCP server on the network.
NuuKeM
 
Posts: 1
Joined: 19. May 2014, 20:00

Re: Upgrade to Big Sur now no network connectivity

Postby Starion » 10. Mar 2021, 21:02

This appears to be the same solution (via another method) that someone else mentioned. Setting the MAC address of the virtual box interface to that of your host's wifi or LAN adapter.
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby mpack » 14. Mar 2021, 21:14

Starion wrote:Setting the MAC address of the virtual box interface to that of your host's wifi or LAN adapter.

That would be illegal. You can't have two PCs on a switch (bridged is just a software switch) with the same MAC address. At best only one of the conflicting nodes will have comms. At worst it will mess up the network.
mpack
Site Moderator
 
Posts: 34554
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Re: Upgrade to Big Sur now no network connectivity

Postby Starion » 15. Mar 2021, 03:39

That would be illegal. You can't have two PCs on a switch (bridged is just a software switch) with the same MAC address. At best only one of the conflicting nodes will have comms. At worst it will mess up the network.


It is the only solution that has worked so far. And it has not "messed up the network".
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby Starion » 5. Apr 2021, 20:33

Still no official solution to this. Posted solution does not work. MAC address change does.
Starion
 
Posts: 22
Joined: 14. Oct 2012, 07:50

Re: Upgrade to Big Sur now no network connectivity

Postby MarcinR » 11. Apr 2021, 06:41

I'll add another datapoint to this issue.

I've been successfully using Bridged networking on OS X Catalina on with a number of 6.0 and 6.1 versions, up to 6.1.18. It worked great on a Windows 10 guest. I upgraded my laptop to Big Sur, and bridged networking no longer works, in precisely the same way that many others have described. The `dadtransmits=0` trick didn't work for me. Sadly, I need bridged mode since I'm connecting to a device which requires promiscuous mode for some UDP shenanigans.

I have one other computer still on Catalina. I copied my VM over to that one, and bridged networking works fine, so the guest OS isn't the issue.
MarcinR
 
Posts: 1
Joined: 11. Apr 2021, 06:33


Return to VirtualBox on Mac OS X pre-releases

Who is online

Users browsing this forum: No registered users and 4 guests