Mouse dragging fails with 10.15 guest

Discussions about using Mac OS X guests (on Apple hardware) in VirtualBox.

Re: Mouse dragging fails with 10.15 guest

Postby Poulpix » 21. Aug 2019, 21:55

Short update: I found a workaround by connecting to the VM using the built-in Screen Sharing macOS app from the host. It doesn't solve the problem but at least when drag-and-dropping is mandatory to achieve something, it works.
Poulpix
 
Posts: 3
Joined: 21. Aug 2019, 21:22
Location: Lyon, France
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: macOS Beta

Re: Mouse dragging fails with 10.15 guest

Postby socratis » 21. Aug 2019, 21:58

Poulpix,
As you might have noticed, I merged your posts with the prominent thread on the subject. Speaking of "subject", I changed the thread's subject from "USB trackpad problems with macOS guest." to something more appropriate.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mouse dragging fails with 10.15 guest

Postby Poulpix » 21. Aug 2019, 22:02

Yes, no problem. It was my first post here although I've been using VirtualBox for several years. And I wasn't really aware of the "only speak of 10.15 Beta" stuff, but I'll be more cautious next time.
Glad to see that this problem is seen by other VBox users anyway.
Thanks socratis
Poulpix
 
Posts: 3
Joined: 21. Aug 2019, 21:22
Location: Lyon, France
Primary OS: Mac OS X other
VBox Version: OSE other
Guest OSses: macOS Beta

Re: Mouse dragging fails with 10.15 guest

Postby socratis » 21. Aug 2019, 22:06

Poulpix wrote:And I wasn't really aware of the "only speak of 10.15 Beta" stuff, but I'll be more cautious next time.

Now that 10.15 is in public beta, we can definitely talk about it. The "caution" was when the first testers had signed an NDA to not discuss it in public, no harm here, only from Apple. ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mouse dragging fails with 10.15 guest

Postby culler » 6. Oct 2019, 21:24

I have just installed the Catalina "Gold master" beta on a VirtualBox 6.0.12 VM and can happily report that it is now possible to drag windows and use scrollbars using the usual USB Tablet input device.
culler
 
Posts: 10
Joined: 5. Jun 2019, 18:44

Re: Mouse dragging fails with 10.15 guest

Postby socratis » 7. Oct 2019, 06:36

So I take it that this means it was an OSX 10.15 issue then. I guess Parallels can remove that Knowledge Base of theirs as well... ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27690
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Mouse dragging fails with 10.15 guest

Postby mp101 » 10. Jan 2020, 21:40

Is there any solution for this?

Just installed 10.15 guest and no mouse dragging.
mp101
 
Posts: 10
Joined: 29. Oct 2018, 09:55

Re: Mouse dragging fails with 10.15 guest

Postby BenZr » 6. May 2020, 10:56

mp101 wrote:Is there any solution for this?

Just installed 10.15 guest and no mouse dragging.


I got the same problem moving from 10.13 to 10.15
The USB on the VM should be set to USB 3.0 xHCI
I found a workaround but not a solution. If you connect a second mouse, it will be directly handled as an USB device by the VM.
If you click the "Devices" menu on top of the VM display, then click "USB" , the second mouse should appear, just select it.
The second mouse will only work inside the VM window. I agree it is not a long term solution ...
BenZr
 
Posts: 1
Joined: 6. May 2020, 10:46

Previous

Return to Mac OS X Guests

Who is online

Users browsing this forum: No registered users and 21 guests