SVN + VMMR0.r0

Discussions related to using the OSE version of VirtualBox.

SVN + VMMR0.r0

Postby Coeus » 12. Nov 2008, 14:54

A week or so ago, after updating my Ubuntu test box from 8.04 to 8.10, I accidently installed (well, on purpose, but I forgot my 2.0.51 SVN images would not work on the repository version 2.0.somethinglower) VirtualBox OSE out of the Ubuntu repositories. This caused my SVN version to stop working. I uninstalled the repository version, rebuilt the SVN version from the latest SVN, and rebuilt the kernel module. But, now, whenever I try to start a VM, I get the error:
Code: Select all   Expand viewCollapse view
Failed to load VMMR0.r0 (VERR_SYMBOL_NOT_FOUND).
Unknown error creating VM (VERR_SYMBOL_NOT_FOUND).


A tail of the log produces:
Code: Select all   Expand viewCollapse view
84: RTLogRelDefaultInstance
85: RTLogSetDefaultInstanceThread
86: RTLogLogger
87: RTLogLoggerEx
88: RTLogLoggerExV
89: RTLogPrintf
90: RTLogPrintfV
91: AssertMsg1
92: AssertMsg2
VMMR0.r0 is importing __memset_chk which we couldn't find


Many searches over the past week or so have yielded nothing. For what it's worth, when I'm running VirtualBox, I run it from the vbox/out/linux.x86/release/bin/ directory with the command: LD_LIBRARY_PATH=. ./VirtualBox

I'm 99% sure I had built VirtualBox OSE and had it working on an Ibex system, but I can't remember for sure. Ibex is the first release where I've had to use --with-gcc-compat=4.2 when running ./configure

If anyone has any thoughts, I'd really appreciate it.
Coeus
 
Posts: 2
Joined: 12. Nov 2008, 14:41

Postby tgc » 14. Nov 2008, 13:15

Hi,

I had the same problem with vb-ose 2.0.4 on Ubuntu 8.10. The solution for me was to get latest SVN (r14092), which made the VMMR0 error go away.
I 'talked' with one of the developers on IRC, and it seems to be a compiler bug or something like that, but a workaround sould be in SVN now.
tgc
 
Posts: 1
Joined: 14. Nov 2008, 13:07

Postby Coeus » 14. Nov 2008, 16:43

r14092 does seem to have fixed the issue for me. Thanks!
Coeus
 
Posts: 2
Joined: 12. Nov 2008, 14:41

Postby toad » 19. Nov 2008, 15:21

I'm running Kubuntu 8.10 out of the repos and I'm getting that error as well. It requires a reboot to go away.

Could there be another solution such as restarting a demon or particular service?
toad
 
Posts: 2
Joined: 3. Mar 2008, 13:15


Return to VirtualBox OSE

Who is online

Users browsing this forum: No registered users and 0 guests