100% CPU Usage on Ubuntu 8.10

Discussions related to using VirtualBox on Linux hosts.

100% CPU Usage on Ubuntu 8.10

Postby ramaboo » 1. Nov 2008, 01:37

I just installed the final version of Ubuntu 8.10 amd64 and then installed VirtualBox 2.0.4 however whenever I install a guest OS (either Ubuntu 8.04 amd64 or Windows XP SP3 32bit) my CPU goes to 100% (only one core) and stays there though the install and operations of the virtual machine. This make the virtual machine really unusable for example after I completed the XP install as a guest the mouse would be really jerky and it would freeze up for a few seconds ever 20-30 seconds. When I installed Ubuntu 8.04 as a guest it my host CPU would be at 100% and stay there before the initial chose your language screen appeared (less than 15 seconds).

I am running a MacBook Core 2 Duo 2.2Ghz with 4GB or RAM (2GB for host and 2GB for guest).

I have tried every combination of APCI settings and with and without VT-x and PAE/NX.

This is a very strange problem since I have run VB 2.0.2 under Ubuntu 8.04 without any issues.

Anyone else having these problems or know a work around. I have googled with no luck. I love 8.10 but without virtual box i will have to go back to 8.04 :(
ramaboo
 
Posts: 6
Joined: 1. Nov 2008, 01:30

Postby Vadi » 1. Nov 2008, 15:35

I don't have such an issue.

I installed virtualbox-ose from synaptic (because virtualbox.org doesn't have a .deb for 8.10 atm)
Vadi
 
Posts: 39
Joined: 28. Aug 2007, 15:11
Location: Toronto, Canada

Postby Sasquatch » 1. Nov 2008, 19:31

Vadi wrote:I don't have such an issue.

I installed virtualbox-ose from synaptic (because virtualbox.org doesn't have a .deb for 8.10 atm)

You can install the Hardy file until there is an Intrepid build without any problem.


Ramaboo,
That is strange. Did you check the forums about the CPU usage? It might have something to do with I/O APIC being enabled. If you have it enabled, try to disable it, but you might need to reinstall the Guest for that (Windows is a jerk about that, it will crash when turned off after install).
Read the Forum Posting Guide before opening a topic.
VirtualBox FAQ: Check this before asking questions.
Online User Manual: A must read if you want to know what we're talking about.
Howto: Install Linux Guest Additions
Howto: Use Shared Folders on Linux Guest
See the Tutorials and FAQ section at the top of the Forum for more guides.
Try searching the forums first with Google and add the site filter for this forum.
E.g. install guest additions site:forums.virtualbox.org

Retired from this Forum since OSSO introduction.
Sasquatch
Volunteer
 
Posts: 17800
Joined: 17. Mar 2008, 13:41
Location: /dev/random
Primary OS: Debian other
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Linux

Postby ramaboo » 1. Nov 2008, 19:50

Tried with and without i/o apci.

I have searched the forums with no luck.

I tried the hardy version and installing from apt-get same problem with both versions.
ramaboo
 
Posts: 6
Joined: 1. Nov 2008, 01:30

Postby ramaboo » 1. Nov 2008, 19:50

Vadi wrote:I don't have such an issue.

I installed virtualbox-ose from synaptic (because virtualbox.org doesn't have a .deb for 8.10 atm)


Are you using a Santa Rosa 3.1 MacBook or another computer?
ramaboo
 
Posts: 6
Joined: 1. Nov 2008, 01:30

same issue on thinkpad x61 | ubuntu 8.10 intrepid

Postby elementz » 2. Nov 2008, 22:01

I do have the exact same problem.
This is on a thinkpad x61.
I just updated to ubuntu 8.10, downloaded the PUEL (non-free) deb for intrepid from the virtualbox servers.
When trying to install windows xp as a guest, i get a very high cpu load, actually freezing my system .
First I thought, the reason might be that I checked the SATA support box under hd-settings. So I switched that off during my next installation attempt.
But even then, the cpu load remains high, rendering the system unusable. The only way i can start using my system again is hitting the powerswitch - which is the worst thing to do anyways!
I have no clue if this has something to do with ubuntu 8.10 or virtualbox 2.04.
If anybody experiences the same problem, or found a solution to this problem, please post.
I will upload the logs from virtualbox later.
elementz
 
Posts: 2
Joined: 2. Nov 2008, 21:54

logfile

Postby elementz » 3. Nov 2008, 02:25

Here's parts of my logfile from virtualbox. My guess is, that it is some sort of issue with the virtual machine accessing the file system.
But maybe somebody else has an idea? No matter, what I try, sata support switched on or off - as soon as the installation process kicks off, the hd is working like mad, but I can't use the machine any more...

Code: Select all   Expand viewCollapse view
00:02:12.245 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=720 h=400 bpp=0 cbLine=0x0
00:02:12.261 Guest Log: BIOS: Booting from CD-ROM...
00:02:14.245 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=aedb4000 w=640 h=480 bpp=0 cbLine=0x140
00:02:14.337 Guest Log: BIOS: int13_harddisk: function 15, unmapped device for ELDL=81
00:02:42.721 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=720 h=400 bpp=0 cbLine=0x0
00:02:42.726 PIT: mode=2 count=0x2ead (11949) - 99.85 Hz (ch=0)
00:02:46.841 PIIX3 ATA: LUN#0: IDLE IMMEDIATE, CmdIf=0xc4 (-1 usec ago)
00:02:46.841 PIIX3 ATA: LUN#0: aborting current command
00:02:49.918 PATM: Disable block at 89834dd4 - write 89834ee7-89834eeb
00:02:51.285 Display::handleDisplayResize(): uScreenId = 0, pvVRAM=00000000 w=720 h=396 bpp=0 cbLine=0x0
00:04:24.482 PIIX3 ATA: execution time for ATA command 0xc8 was 8 seconds
00:04:28.344 TM: Giving up catch-up attempt at a 61033005556 ns lag; new total: 61033005556 ns
00:05:30.972 TM: Giving up catch-up attempt at a 60230934258 ns lag; new total: 121263939814 ns
00:06:54.202 TM: Giving up catch-up attempt at a 83171076520 ns lag; new total: 204435016334 ns
00:08:42.298 TM: Giving up catch-up attempt at a 107925687717 ns lag; new total: 312360704051 ns
00:09:44.147 TM: Giving up catch-up attempt at a 61616989460 ns lag; new total: 373977693511 ns
00:11:49.117 TM: Giving up catch-up attempt at a 120322904307 ns lag; new total: 494300597818 ns
00:12:51.344 TM: Giving up catch-up attempt at a 66022037395 ns lag; new total: 560322635213 ns
00:13:53.263 TM: Giving up catch-up attempt at a 61922257915 ns lag; new total: 622244893128 ns
00:14:54.984 TM: Giving up catch-up attempt at a 61038238168 ns lag; new total: 683283131296 ns
00:15:21.876 PIIX3 ATA: execution time for ATA command 0xca was 53 seconds
00:16:01.388 TM: Giving up catch-up attempt at a 63684963722 ns lag; new total: 746968095018 ns
00:16:53.833 PIIX3 ATA: execution time for ATA command 0xc8 was 8 seconds
00:16:58.576 TM: Giving up catch-up attempt at a 60094035336 ns lag; new total: 807062130354 ns
00:17:59.842 TM: Giving up catch-up attempt at a 60340380630 ns lag; new total: 867402510984 ns
00:18:14.140 PIIX3 ATA: execution time for ATA command 0xc8 was 9 seconds
00:18:50.533 PIIX3 ATA: execution time for ATA command 0xc8 was 9 seconds
elementz
 
Posts: 2
Joined: 2. Nov 2008, 21:54

Postby relpats_eht » 9. Nov 2008, 01:53

I have the same problem running an XP64 guest on my laptop (Gentoo, 2GHz Core2Duo, 2 GB ram). I allocate 512 MB ram for the guest with 8 MB vram.

No matter what configuration I try, Virtualbox 2.0.4 constantly uses 100% of one cpu. I've searched the forums to no avail.
relpats_eht
 
Posts: 4
Joined: 9. Nov 2008, 01:46

Postby relpats_eht » 9. Nov 2008, 12:11

Also, the problem occurs regardless of Virtualbox version (be that 2.0.2 or 2.0.4). At least for the binary version; I've yet to successfully build and run the open source addition.

Since the OP said there was no problem in Ubuntu 8.04, I'm lead to believe it is likely a kernel issue. I'm looking into kernel changes between the two Ubuntu versions now.
relpats_eht
 
Posts: 4
Joined: 9. Nov 2008, 01:46

Postby ramaboo » 10. Nov 2008, 14:23

8.10 uses 2.6.27 where 8.04 is 2.6.24 so my guess is there are tons of kernel level changes.

I don't think its a coincidence that the only people reporting problems are running on a Core 2 Due laptop.
ramaboo
 
Posts: 6
Joined: 1. Nov 2008, 01:30

Postby stephanecharette » 10. Nov 2008, 20:18

ramaboo wrote:I don't think its a coincidence that the only people reporting problems are running on a Core 2 Due laptop.


I'm running VB 2.0.4 on an Intel Core2 Duo laptop: not a Macbook, but a DELL Latitude D630. No problem here. Host was Ubuntu 8.04, is now Ubuntu 8.10. Guests are Debian Etch and Windows Vista.

Because my Debian guest is 64-bit, I run with ACPI, IOAPIC, VTx/AMDV and PAE/NX all enabled. Don't know if that makes any difference.

Code: Select all   Expand viewCollapse view
00:15:21.876 PIIX3 ATA: execution time for ATA command 0xca was 53 seconds
00:16:53.833 PIIX3 ATA: execution time for ATA command 0xc8 was 8 seconds
00:18:14.140 PIIX3 ATA: execution time for ATA command 0xc8 was 9 seconds
00:18:50.533 PIIX3 ATA: execution time for ATA command 0xc8 was 9 seconds

That seems wrong! ATA commands that are taking 53 seconds to run?!

If anyone cares to know:
- ATA 0xCA is: "write data using DMA"
- ATA 0xC8 is: "read data using DMA"

Are your host systems going into swap space? That could explain this:
elementz wrote:as soon as the installation process kicks off, the hd is working like mad, but I can't use the machine any more...


Stéphane Charette
stephanecharette
Volunteer
 
Posts: 262
Joined: 10. Nov 2007, 22:03
Location: Kelowna, British Columbia, Canada
Primary OS: Ubuntu other
VBox Version: PUEL
Guest OSses: Ubuntu-64bit, Windows

Postby shockwave » 11. Nov 2008, 06:31

Hi,

I have the same problem with a 64bit linux host running a 32bit XP guest. It does not use any CPU until you try to do something "intensive" (in my case I tried windows update and as soon as it got to the "preparing download" stage one of my cores spiked and would not return unless the VM was rebooted.


Travis
shockwave
 
Posts: 2
Joined: 11. Nov 2008, 06:28

Postby relpats_eht » 11. Nov 2008, 10:11

The virtual machines have not been using swap space for me (but I am using a Core2Duo).

The problem seems to come about for every piece of virtual machine software.
relpats_eht
 
Posts: 4
Joined: 9. Nov 2008, 01:46

Postby weertske » 13. Nov 2008, 01:28

I am using a quad core Q6600. Running 32 bit XP on 64 bit Ubuntu 8.10 host. When I first start the guest, cpu load is minimal. As soon as I start an application the load on one core goes up to 40-60% and stays there until I shut down the application. At that point the load comes down a little (floats around 30-50%) but it never comes back to less than 10% even though the Windows CPU monitor says its idle. Certain events (unknown) have caused my cpu load to climb to 90% and stick there until I reboot the guest.

My swap file is not being used at all probably since the cpu has such a large cache.

While I have been writing this I have been trying different settings in VirtualBox. It seems the enable VT setting causes more cpu load.
weertske
 
Posts: 1
Joined: 13. Nov 2008, 00:26

SOLUTION!

Postby shockwave » 13. Nov 2008, 05:09

Download the "HAL Updater"

Change your ACPI PC to "ACPI Uniprocessor PC".

The HAL Updater can be found here (www.hardware.info):
http://www.hardware.info/en-US/news/ym2cmZqYwp2a/Problems_updating_to_a_dualcore_CPU_Not_anymore/

The problem seems to be that windows finds a quad/dual core, installs the multicore HAL, but virtualbox only allows it to "see" one core, causing an issue.

After reboot I am not seeing the problem anymore.
shockwave
 
Posts: 2
Joined: 11. Nov 2008, 06:28

Next

Return to VirtualBox on Linux Hosts

Who is online

Users browsing this forum: Google [Bot] and 22 guests