[Solved] Office windows are not rendered correctly

Discussions about using Windows guests in VirtualBox.

[Solved] Office windows are not rendered correctly

Postby BerlinUser » 16. Jun 2019, 23:09

Hi,

I am running a Win 10 guest on a 18.04 Ubuntu host. When I open programs like calculator, Chrome, and others everything looks fine. But if I open an Office app like Excel most of the application window is not rendered correctly, but there are plain areas where I do not see buttons, menus, and so on. Do you have any idea how to find the problem behind that?

Best regards
Last edited by BerlinUser on 17. Jun 2019, 13:00, edited 1 time in total.
BerlinUser
 
Posts: 12
Joined: 12. Nov 2018, 16:47

Re: Office windows are not rendered correctly

Postby scottgus1 » 16. Jun 2019, 23:24

You could try enabling 2D and/or 3D acceleration. Otherwise, please post a zipped guest log and a png screenshot, 128kB or less, attached via the forum's Upload Attachment tab.
Human government is like that crazy uncle who hides a quarter in his fist behind his back, then asks you to guess which fist the quarter is in...
No matter which side you choose, Left or Right, both Sides are empty.
scottgus1
Volunteer
 
Posts: 4632
Joined: 30. Dec 2009, 20:14
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Win7

Re: Office windows are not rendered correctly

Postby BerlinUser » 17. Jun 2019, 07:58

Dear scottgus1

Here comes the log file.
w10-32-2019-06-17-07-54-16.zip
(31.23 KiB) Downloaded 11 times
BerlinUser
 
Posts: 12
Joined: 12. Nov 2018, 16:47

Re: Office windows are not rendered correctly

Postby BerlinUser » 17. Jun 2019, 07:59

And here comes the screenshot.
Screenshot from 2019-06-17 07-52-52.png
Screenshot from 2019-06-17 07-52-52.png (96.93 KiB) Viewed 383 times


Best regards
BerlinUser
 
Posts: 12
Joined: 12. Nov 2018, 16:47

Re: Office windows are not rendered correctly

Postby andyp73 » 17. Jun 2019, 10:14

VBox.log wrote:
00:00:04.245744 CPUM: Physical host cores: 2
00:00:01.062636 NumCPUs <integer> = 0x0000000000000001 (1)

As your CPU only has two physical cores, you have done the right thing allocating one to the guest and leaving one for the host. Running Windows 10 on a single core is never a great experience but it is the best you can hope for.

VBox.log wrote:
00:00:01.063130   VMSVGA3dEnabled  <integer> = 0x0000000000000001 (1)
00:00:01.063131 VMSVGAEnabled <integer> = 0x0000000000000001 (1)
00:00:01.063132 VRamSize <integer> = 0x0000000010000000 (268 435 456, 256 MB)

It looks like you have the vGPU set to VMSVGA which is targeted at Linux guests. Can you change it to VBoxVGA and see if that improves the situation?

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: Office windows are not rendered correctly

Postby BerlinUser » 17. Jun 2019, 12:48

Dear Andy

I will try that, but how is it to be done? I ask because I found that Graphics controller dropdown menu, but it was actually set to VBoxSVGA and not VMSVGA. But anyway I changed it now to VBoxVGA (without the S in the middle). I have tried to boot the machine, but now I only get a black screen. I don't know if this is due to the controller switch.

Best regards
BerlinUser
 
Posts: 12
Joined: 12. Nov 2018, 16:47

Re: Office windows are not rendered correctly

Postby BerlinUser » 17. Jun 2019, 13:00

PS: I shut down the machine again and then I could boot again and got to the greeter. Now it seems to work, also the Office apps.

Thank you very much!
BerlinUser
 
Posts: 12
Joined: 12. Nov 2018, 16:47


Return to Windows Guests

Who is online

Users browsing this forum: g3poandls and 15 guests