[WorksForMe] Unable to install UEFI Windows guests in Windows host

Discussions about using Windows guests in VirtualBox.

[WorksForMe] Unable to install UEFI Windows guests in Windows host

Postby Ransom » 19. May 2019, 20:09

Hello guys,

I have already installed many Windows guests (WinXP, Vista, Win7x64, Win8.1x32, Win8.1x64 and Win10Prox64) in my Windows Host of VirtualBox – all in BIOS/MBR mode so far. Now I wanted to do a UEFI installation for the first time.

With Win7SP1x64 it seemed to work at first, then the screen froze with a red bar above the screen.

At Win10Pro_x64_1903 comes “Press ESC in x seconds to skip startup.nsh or any other key to continue.” appears after a short time. Then comes “Shell>”

I have already searched so many pages, but nowhere found my problem described. Only once, with the red bar, I was told to switch off the Secure Boot, but I can’t see where I could switch off the Secure Boot under VirtualBox, this is actually in the BIOS resp. my BIOS doesn’t have this function at all (only “Launch CSM” enable/disable resp. “Fast Boot” enable/disable).

Who knows advice?

Greetings
ransom
Last edited by socratis on 20. May 2019, 17:05, edited 1 time in total.
Reason: Marked as [WorksForMe].
Ransom
 
Posts: 29
Joined: 3. Mar 2017, 13:38
Location: Germany
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: WinXP-SP3, Vista_x32, Win7_Pro_x64, Win8.1_x32_Home, Win8.1_x64_Pro, Win10_Pro(1607)

Re: Unable to install UEFI Windows guests in Windows host

Postby socratis » 19. May 2019, 20:56

Ransom wrote:With Win7SP1x64 it seemed to work at first, then the screen froze with a red bar above the screen.
I highly doubt that it would work, because you see according to the User Manual (great tool BTW), ch. 3.14. Alternative Firmware (EFI):
Windows 7 guests are unable to boot with the Oracle VM VirtualBox EFI implementation.


Ransom wrote:At Win10Pro_x64_1903
That's not an official Microsoft ISO, since 1903 has not been released yet. But, if you download the official Win10_1809Oct ISO, it works just great.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Unable to install UEFI Windows guests in Windows host

Postby Ransom » 19. May 2019, 22:23

Hello socratis,

Thank you for your fast answer.

@ Win7SP1x64: It really worked at first. I made a sreenshot (Host + E), it’s not the same like it was on my screen, but maybe you can see of it, that there was really a beginning.

@ Win10x64_1809: I have downloaded the current ISO from the link offered by you, but the error described above still happens.

Greetings,
Ransom
Attachments
VirtualBox_Win7x64_Pro_UEFI_19_05_2019_21_30_55.png
VirtualBox_Win7x64_Pro_UEFI_19_05_2019_21_30_55.png (4.1 KiB) Viewed 535 times
Ransom
 
Posts: 29
Joined: 3. Mar 2017, 13:38
Location: Germany
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: WinXP-SP3, Vista_x32, Win7_Pro_x64, Win8.1_x32_Home, Win8.1_x64_Pro, Win10_Pro(1607)

Re: Unable to install UEFI Windows guests in Windows host

Postby Ransom » 19. May 2019, 23:09

Hello socratis,

I’m rowing back. It works with the ISO you suggested. I made it a habit to implement my serial number as pid.txt in the ISO. This changed ISO was probably not accepted by VirtualBox. Now I had tried it again with the untouched, original ISO for safety’s sake – and lo and behold, it worked.

I can’t say whether it really became a real UEFI installation yet, because I have to proceed in a very specific way to keep an activated VirtualBox activated in the future, but if everything went smoothly, I’ll get back to you.

Best regards,
Ransom
Ransom
 
Posts: 29
Joined: 3. Mar 2017, 13:38
Location: Germany
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: WinXP-SP3, Vista_x32, Win7_Pro_x64, Win8.1_x32_Home, Win8.1_x64_Pro, Win10_Pro(1607)

Re: Unable to install UEFI Windows guests in Windows host

Postby socratis » 20. May 2019, 00:33

I know it was working because I tested it right before I replied... ;)
But, what do you mean by:
Ransom wrote:I made it a habit to implement my serial number as pid.txt in the ISO


As far as what you see in the Win7 attempt, that's exactly what's called a "failure to boot Win7 with EFI". ;)
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Unable to install UEFI Windows guests in Windows host

Postby Ransom » 20. May 2019, 10:20

Hello socratis,

The thing with the pid.txt:

Because I often do CleanInstalls (or installations in VirtualBox), I don’t want to enter the serial number manually every time. Somewhere in the web it was said that you should create a text file with Notepad (or similar) according to the following pattern and use the serial number instead of the letters. This file should be called “pid.txt” and copied into the folder “sources”.

[PID]
Value=AAAAA-BBBBB-CCCCC-DDDDD-EEEEE

So when I download an ISO from Microsoft, I unpack it, copy my pid.txt to sources and create another ISO using ImgBurn. Obviously VirtualBox doesn’t like such modified ISOs.

@Win7: Here the thing with pid.txt doesn’t work yet, but my Win7-Pro-SP1x64-ISO comes from Microsoft. The installation process starts (at least in my case) and doesn’t stop with the error message “failure to boot Win7 with EFI”, but a red bar appears above the screen, and then the whole process freezes.

Best regards,
Ransom
Ransom
 
Posts: 29
Joined: 3. Mar 2017, 13:38
Location: Germany
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: WinXP-SP3, Vista_x32, Win7_Pro_x64, Win8.1_x32_Home, Win8.1_x64_Pro, Win10_Pro(1607)

Re: Unable to install UEFI Windows guests in Windows host

Postby socratis » 20. May 2019, 17:05

Thanks for the info on the "pid.txt", wasn't aware of that. I guess something breaks in there that makes it incompatible. As for the red bar in Win7, yes, I told you, that's what everybody sees, that's what makes it "not working". ;)

Marking this as [WorksForMe].
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: [WorksForMe] Unable to install UEFI Windows guests in Windows host

Postby Martin » 20. May 2019, 18:26

I don't think the problem is the additional txt file. More probably the process of "create another ISO using ImgBurn" is not creating a correct UEFI enabled ISO.
Martin
Volunteer
 
Posts: 2253
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Re: [WorksForMe] Unable to install UEFI Windows guests in Windows host

Postby Ransom » 31. May 2019, 14:47

Hello Martin,

I thought you are right with your conjecture and tried it therefore with UltraISO to insert the pid.txt.

The result was not exactly the same like with ImgBurn (“screen froze with a red bar above the screen”) but in the end it also did not work. Only with an untouched original ISO-file, generated with the MediaCreationTool of Microsoft, it works.

Best regards,
Ransom
Ransom
 
Posts: 29
Joined: 3. Mar 2017, 13:38
Location: Germany
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: WinXP-SP3, Vista_x32, Win7_Pro_x64, Win8.1_x32_Home, Win8.1_x64_Pro, Win10_Pro(1607)


Return to Windows Guests

Who is online

Users browsing this forum: No registered users and 18 guests