Discuss the 6.0.6 release

This is for discussing general topics about how to use VirtualBox.

Discuss the 6.0.6 release

Postby michael » 16. Apr 2019, 22:55

Discuss the 6.0.6 release here.
You can download the release here.
VirtualBox 6.0.6 is a new maintenance release.

VirtualBox 6.0.14 has been released. Please try that before continuing the discussion in this thread.

Known new issues/regressions
These are new and confirmed tickets about issues with 6.0.6:
See also:
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 6.0.6 release

Postby Etepetete » 17. Apr 2019, 06:38

A huge thanks to the developers!

VBox 6.0.6 installed flawlessly, and works like a charm.
GuestAdditions compiled as expected.
No issues with shared folder
No issues with audio or video playback.
No complaints whatsoever.
Great job!
Etepetete
 
Posts: 393
Joined: 7. Oct 2009, 10:19
Location: Berlin
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Slackware 14.2

Re: Discuss the 6.0.6 release

Postby michael » 17. Apr 2019, 09:23

Thank you!
michael
Oracle Corporation
 
Posts: 683
Joined: 10. May 2007, 09:46

Re: Discuss the 6.0.6 release

Postby mpack » 17. Apr 2019, 10:21

Found a bug within 30 seconds, perhaps a new record for me... :) I'm not sure if this is a new one or not.

Win7 64bit guest, v6.0.6 GAs installed in safe mode so that OpenGL will work, VBoxVGA graphics.

I ran an OpenGL 3D viewer in the guest, worked fine. Closed it.
Win7 guest.png
Win7 guest.png (70.23 KiB) Viewed 3640 times


I then tested whether the VM fullscreen window size restore bug had been fixed (it had), but while in fullscreen mode I ran the 3D viewer app again. The entire screen went black except for the contents of the viewer window - which had no window frame or caption bar. I had to guess where the close (X) button was to restore my guest desktop.

I tried to capture a screenshot to show you what I meant, but the screenshot captured the opposite: a visible desktop and an empty (black) OpenGL viewer window frame. While trying to get the screenshot the screen suddenly fixed itself, but broke again when I moved the viewer window.

I can't test other graphics chipsets since AFAIK none yet support OpenGL in a Windows guest.
mpack
Site Moderator
 
Posts: 30055
Joined: 4. Sep 2008, 17:09
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Mostly XP

Windows 10 Guest Performance.

Postby isgdre » 17. Apr 2019, 18:56

I recommend trying 6.0.6 for any user that was having performance problems on their Windows 10 Guest.

Just updated from 6.0.4 to 6.0.6 and there is a huge difference. Close to native speeds now.
isgdre
 
Posts: 18
Joined: 15. Nov 2012, 21:45

Re: Discuss the 6.0.6 release

Postby socratis » 17. Apr 2019, 21:20

@isgdre
Merged your post with the "Discuss the 6.0.6 release".
I'm sure the devs will be glad to hear your assessment! ;)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27378
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.6 release

Postby misvin » 18. Apr 2019, 08:50

VirtualBox 6.0.6 Bugs (Windows 10 1809 64-bit Host):
1. Deleting a snapshot doesn't show estimated time and operation progress bar always starts from 99%.
This is a maintenance release. The following items were fixed and/or added:
[...]
User interface: fixed operation progress when deleting snapshots

2. The Search function of the .chm help does not work.
Last edited by misvin on 18. Apr 2019, 09:29, edited 2 times in total.
misvin
 
Posts: 13
Joined: 4. Oct 2017, 17:46
Primary OS: MS Windows 10
VBox Version: OSE other
Guest OSses: Windows 10

Re: Discuss the 6.0.6 release

Postby mcp » 19. Apr 2019, 01:24

I lose the mouse when I switch to seamless mode. And yes I did install the extensions.
How can I solve this problem?

MCP

UPDATE: I found the setting that needed to be changed. All is good now.
Last edited by mcp on 19. Apr 2019, 06:36, edited 1 time in total.
mcp
Volunteer
 
Posts: 132
Joined: 12. May 2007, 23:55
Primary OS: PCLinuxOS
VBox Version: PUEL
Guest OSses: Windows XP Pro

Re: Discuss the 6.0.6 release

Postby socratis » 19. Apr 2019, 02:04

@mcp, you should know what the "Minimum information needed for assistance" is. And we need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27378
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.6 release

Postby arQon » 19. Apr 2019, 12:00

I'm seeing kernel panics 100% of the time on shutdown. W7x64 host, ubuntu 16.04 guest with 4.4.0-145-generic.
An 18.04 guest with kernel 4.15.0-47 that's still on the 6.04 GAs doesn't have this problem.

On startup i'm sometimes seeing this as an xmessage:
VBoxClient: VBoxClient (seamless): failed to start. Stage: Setting guest IRQ filter mask Error: VERR_INTERNAL_ERROR
and shared folders aren't present. (mounted in rc.local rather than as vbox auto-mounts).

Have reinstalled the GAs a couple of times, no change.

The 4.4.0-142 kernel (the last one with working GAs in 6.04 following a signature change) exhibits the same problem with the 6.06 GAs.

add> The same VM works fine if updated to 4.15, so the problem is specific to 6.06 and 4.4 kernels. (well, probably several other old kernel versions as well, but meh)
Attachments
606guestpanic.zip
(29.61 KiB) Downloaded 17 times
Last edited by arQon on 22. Apr 2019, 03:35, edited 1 time in total.
arQon
 
Posts: 58
Joined: 1. Jan 2017, 09:16
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Ubuntu 16.04 x64, W7

Re: Discuss the 6.0.6 release

Postby markos2680 » 19. Apr 2019, 19:13

Left mouse button works like right mouse button on desktop while "Input/Mouse Integration" is checked
Uncheck the "Input/Mouse Integration" solves the problem

Host : Ubuntu 18.04.2 x64, Kernel 4.18.0-16-generic
Guests tested : Windows 2003 Server, Windows 7 Pro x64
Environment : VBox 6.0.6 r130049 ( Qt 5.6.1 )
Last edited by markos2680 on 20. Apr 2019, 14:44, edited 1 time in total.
markos2680
 
Posts: 7
Joined: 1. Aug 2018, 23:33

Re: Discuss the 6.0.6 release

Postby socratis » 19. Apr 2019, 22:01

mcp wrote:UPDATE: I found the setting that needed to be changed. All is good now.
@mcp,
Please don't leave the solutions hidden. Please make yourself clear and post the solution. What setting did you find?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27378
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.6 release

Postby ciamaulex » 23. Apr 2019, 10:26

Thanks for the awesome release!
This is not only more stable, but also blazing fast.

One note though: the "restore frozen at 97%" seemed completely gone.
Only once I got it again on my WinXP guest. Then I discarded the saved state and did a fresh boot, and the machine paused because it could not lock the required amount of memory.

May there be a remaining case when the "saved state restore" crashes instead of gracefully pausing the machine in low-memory conditions?

I will try to test again, in case I will send you the logs.

Best regards
ciamaulex
 
Posts: 5
Joined: 22. Nov 2017, 13:57
Primary OS: MS Windows 7
VBox Version: PUEL
Guest OSses: Windows XP, Windows 7, Windows 2016, Debian

Re: Discuss the 6.0.6 release

Postby socratis » 23. Apr 2019, 10:41

@ciamaulex
Take a look at the corresponding ticket "Win7 in VB 6.0.0 fails on resume on 97%". See comment #9 from "bird" (emphasis mine):
Seems some device is raising interrupts while restoring saved state, which it is absolutely not supposed to do, thus the release assertion later in the restore process. However, to move on with this I've degraded the release assertion to a scary log entry (in VBox.log) and we'll try hunt down the real culprit internally.

The fix will appear in 6.0.8, 5.2.30 and any test build with revision 130145 or higher. (No, we did not knowingly fix this in 6.0.6.)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 27378
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Discuss the 6.0.6 release

Postby vesa » 24. Apr 2019, 09:11

I had some problems with 6.0.6 so I could not upgrade.
* could not move around windows
* could not click on menu item in Idea
I have Windows 10 host and Ubuntu 18 guest.
vesa
 
Posts: 2
Joined: 23. Apr 2019, 20:41

Next

Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 16 guests