[Invalid] Debian 10 (buster) Copy paste not working (#18511)

Discussions about using Linux guests in VirtualBox.

[Invalid] Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 27. Mar 2019, 10:35


ModEdit; related ticket: #18511: [buster] [virtualbox] Copy paste not working

Dear all,

I come from the bugtracker and I was asked to post my issue here as well.
Please, have a look at the ticket to find out more about my problem: ticket/18511
(sorry, the forum forbids me to post URLs)

Let me know if you have an idea how to fix the problem.

Best regards,

Federico M.

ModEdit; Related logs from the ticket:
Last edited by socratis on 2. Apr 2019, 17:43, edited 3 times in total.
Reason: Marked as [Invalid].
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 00:38

We need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 09:52

I did the complete VBox log. I started the VM, reproduced the copy-paste bug a few times then shut it down.
Are you sure you will find something useful on those logs?

I think I will provide a vdi disk on some file transfer site so that you can reproduce in 30 seconds and investigate it then. What do you think?
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby andyp73 » 1. Apr 2019, 10:00

Federico M. wrote:I think I will provide a vdi disk on some file transfer site so that you can reproduce in 30 seconds and investigate it then. What do you think?

I think we should start with the easy parts to make sure that there is nothing obviously incorrect with your VirtualBox and guest configurations. If we had wanted the .vdi file someone would have said "please post the .vdi file to a third party file sharing site". If you don't (or won't) provide the information that is requested then folks will just give their time to answering other questions.

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 10:02

No problem: I will attach a new log... :o
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 10:04

But why my old MachineLogs.rar are not good?
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 10:12

New logs
Attachments
Debian-10Alpha4_amd64.log.zip
VBox.log
(24.95 KiB) Downloaded 10 times
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby andyp73 » 1. Apr 2019, 10:31

00:00:13.290882 VMMDev: Guest Log: vboxguest: host-version: 6.0.4r128413 0x80000007
00:00:13.290915 VMMDev: Guest Additions information report: Version 5.2.0 r68940 '5.2.0'

You look to have updated your VirtualBox installation to v6.0.4 but your guest still has v5.2.0 of the guest additions. These were released about 15 months apart and there have been significant changes in between. Can you install the matching v6.0.4 guest additions and see if the problem persists?

-Andy.
My crystal ball is currently broken. If you want assistance you are going to have to give me all of the necessary information.
Please don't ask me to do your homework for you, I have more than enough of my own things to do.
andyp73
Volunteer
 
Posts: 1642
Joined: 25. May 2010, 23:48
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Assorted Linux, Windows Server 2012, DOS, Windows 10, BIOS/UEFI emulation

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 10:56

As I said in the bug report, the problem does not seem related to host type, VB version, or VB addons.
Maybe the issue is on Debian side as well...

New logs attached, problem reproduced.

Thanks for your help.
Attachments
Debian-10Alpha4_amd64.zip
(30.06 KiB) Downloaded 10 times
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 11:02

Federico M. wrote:As I said in the bug report, the problem does not seem related to host type, VB version, or VB addons.
I couldn't agree more. Because in my case it works in all cases! So, 1) it's not a "bug", 2) it must be you!!! :)

What are you trying to copy/paste exactly? Terminal to Notepad and Notepad to gedit should work just fine. Just don't try to copy rich/HTML text, images, files or anything other than that. Shared Clipboard is for text-only, and simple text-only actually...

Finally, do you have a copy of the installation process of the GAs in the guest?
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:17

The quickest way to reproduce is to open a terminal and try to copy paste text.
I am able to copy, sometimes, if I am really fast (less than half a second). After that time, it is impossible to copy (it seems that the clipboard is cleared).

I would like to try installing Debian 10 on a PC (with no virtualbox), and see if I can reproduce there. I cannot do it now... I will try during the week.

Finally, do you have a copy of the installation process of the GAs in the guest?

Sorry, what do you mean?
Last edited by Federico M. on 1. Apr 2019, 11:35, edited 1 time in total.
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:18

And, of course, I was not able to copy into or outo gedit/leafpad...
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:32

Little video :D

https://www.virtualbox.org/attachment/ticket/18511/No_copy.mp4

[ModEdit: replaced ZIPPED video attachment, with the same video in the ticket, no need for duplication]
Last edited by socratis on 1. Apr 2019, 12:16, edited 1 time in total.
Reason: Removed unnecessary attachment, be more "green".
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby socratis » 1. Apr 2019, 11:35

Federico M. wrote:
Finally, do you have a copy of the installation process of the GAs in the guest?

Sorry, what do you mean?

When you installed the GAs in the guest... that part, the terminal output. You can reinstall the GAs if you want and grab that output.

In the meantime, which version did you get from https://www.debian.org/devel/debian-installer/? I'm going to try and replicate it on another setup/host... I see the log's name is Alpha4, but Alpha5 is out...

 Edit: I'll go with the debian-buster-DI-alpha5-amd64-xfce-CD-1.iso one... 
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26901
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Debian 10 (buster) Copy paste not working (#18511)

Postby Federico M. » 1. Apr 2019, 11:37

I used this one (Debian 10 current testing)
http://cdimage.debian.org/cdimage/unoff ... ch/iso-cd/

Please note that I installed lxde.
Federico M.
 
Posts: 16
Joined: 27. Mar 2019, 10:32

Next

Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 18 guests