VM fails to start from saved state. Works from fresh boot.

This is for discussing general topics about how to use VirtualBox.

VM fails to start from saved state. Works from fresh boot.

Postby DessaDog » 28. Dec 2018, 19:42

When starting my VMs from a saved state, I get the following error. This happens on both my Windows 7 and my CentOS VM.

Code: Select all   Expand viewCollapse view
Failed to open a session for the virtual machine Windows -<name>.

Failed to load unit 'lsilogicsas' (VERR_SSM_LOADED_TOO_LITTLE).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}


If i discard the saved state, then start the VM the VM starts without error.
These two VMs were originally copied over from Fusion and used with VirtualBox 5.x. The problem only started when I upgraded to VirtualBox 6.
Currently running VirtualBox Version 6.0.0 r127566 (Qt5.6.3)
Host: OSX 10.14.2

Log is attached. This was made doing a clean start of the Windows VM, then saving the state, then trying to start it from the saved state.
Attachments
VBox.log.zip
(32.2 KiB) Downloaded 20 times
DessaDog
 
Posts: 3
Joined: 28. Dec 2018, 19:27

Re: VM fails to start from saved state. Works from fresh boot.

Postby Martin » 28. Dec 2018, 19:58

Keeping saved states through version upgrades of Virtualbox was never supported.
Martin
Volunteer
 
Posts: 2253
Joined: 30. May 2007, 18:05
Primary OS: Fedora other
VBox Version: PUEL
Guest OSses: XP, Win7, Linux, OS/2

Re: VM fails to start from saved state. Works from fresh boot.

Postby DessaDog » 28. Dec 2018, 20:22

Martin,
I understand saved states isn't supported across upgrades. That's not my problem.
To Summarize:
- I'm currently running VirtualBox 6.0
- I startup my VM
- I save my VM state
- I can't startup my VM from the saved state.

This is all with 6.0
DessaDog
 
Posts: 3
Joined: 28. Dec 2018, 19:27

Re: VM fails to start from saved state. Works from fresh boot.

Postby socratis » 29. Dec 2018, 16:44

I think I've seen a report or two regarding saved states and not-default HD controllers, but I can't find them at the moment... :?
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VM fails to start from saved state. Works from fresh boot.

Postby DessaDog » 29. Dec 2018, 17:24

Is my HD controller a non-default type?
What is the default type?
DessaDog
 
Posts: 3
Joined: 28. Dec 2018, 19:27

Re: VM fails to start from saved state. Works from fresh boot.

Postby socratis » 29. Dec 2018, 23:52

The LsiLogic SCSI controller is usually the one that's assigned for imported VMs, OVA or OVF. The easiest way to see which is the default controller is to create a new VM (and then delete it). For both Win7 and CentOS that would be SATA (for the HDD).
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VM fails to start from saved state. Works from fresh boot.

Postby gapost » 23. Jan 2019, 10:45

I have exactly the same problem on my CentOS 7 host with a Windows 7 VM after upgrade to VirtualBox 6.0 (from 5.2).

If I save the VM state and then try to start it I get the same error message as the OP.
gapost
 
Posts: 1
Joined: 23. Jan 2019, 10:37

Re: VM fails to start from saved state. Works from fresh boot.

Postby socratis » 24. Jan 2019, 08:11

socratis wrote:I think I've seen a report or two regarding saved states and not-default HD controllers, but I can't find them at the moment... :?

Found them:
  • #18263 Restoring 32bit Windows7 VM Saved State Fails
  • #18265 Win7 in VB 6.0.0 fails on resume on 97%
Moving to "Using VirtualBox" from "OSX Hosts".
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26741
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Using VirtualBox

Who is online

Users browsing this forum: No registered users and 11 guests