Failed to attach the usb device to the virtual machine (busy with previous request)

Discussions about using Linux guests in VirtualBox.

Failed to attach the usb device to the virtual machine (busy with previous request)

Postby dis0wned » 20. Jan 2019, 14:54

Host OS - Windows 10
Guest OS - Kali Linux
VirtualBox - 6.0.2
Extension pack - 6.0.2

I also downgraded both VirtualBox and extension pack to 6.0.0 which did not resolve this issue


Steps taken so far:
Read usb troubleshooting
Read forums
Removed drivers in host OS and reinstalled
Uninstalled and reinstalled VirtualBox (rebooted between)
Added usb filters per device
Added generic usb filters
Removed all usb filters
Tried to add devices ad-hoc
Removed VirtualBox usb device in device manager of host OS
Removed all usb devices on host OS
Unplugged usb devices and rebooted
Cloned machine
Tried installing new machine from scratch


After roughly 5-6 hours of banging my head off the wall, I feel I have run out of troubleshooting steps and could use some insightful direction (please don’t say read blog post .... because chances are I already did and it didn’t help.).
dis0wned
 
Posts: 2
Joined: 20. Jan 2019, 14:33

Re: Failed to attach the usb device to the virtual machine (busy with previous request)

Postby socratis » 20. Jan 2019, 14:57

Please read the following thread: USB basics and troubleshooting, all of the posts.

If you still have a problem after reading through the whole thing, please follow the advice of the last post, #8: Asking for help and post the information requested.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 22095
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Failed to attach the usb device to the virtual machine (busy with previous request)

Postby dis0wned » 20. Jan 2019, 15:59

logs and output of commands
Attachments
vbox.7z
logs and output of commands
(21.29 KiB) Downloaded 2 times
dis0wned
 
Posts: 2
Joined: 20. Jan 2019, 14:33

Re: Failed to attach the usb device to the virtual machine (busy with previous request)

Postby socratis » 20. Jan 2019, 19:22

You did NOT follow the directions on how to grab the log:
  • You did NOT plug the USB device after the VM started and you logged in. And obviously you didn't unplug it either.
  • You did NOT shut down the VM completely before grabbing the log.
Please try again:
socratis wrote:Finally, a log from a cold_start / login / plug_USB / unplug_USB / complete_shutdown cycle:
  1. Start the VM from cold-boot (not from a paused or saved state).
  2. After you've logged in, plug the USB device. Wait (idling) for a minute or two. Unplug the USB device.
  3. Shutdown the VM (not paused or saved).
  4. Right-click on the VM in the VirtualBox Manager and select "Show Log".
  5. Save only the first "VBox.log", ZIP it and attach it to your response (see the "Upload attachment" tab below the reply form).
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 22095
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 11 guests