VirtualBox 6.0 and Hyper-V

Discussions related to using VirtualBox on Windows hosts.

Re: VirtualBox 6.0 and Hyper-V

Postby jmar83_the2nd » 6. Jan 2019, 05:17

ok thx
regards, jan
jmar83_the2nd
 
Posts: 157
Joined: 9. Mar 2012, 00:14

Re: VirtualBox 6.0 and Hyper-V

Postby irak » 8. Jan 2019, 01:01

HyperV is now forced on nd...
WHvCreatePartition failed with E_ACCESSDENIED (Last=0xc0000022/5) (VERR_NEM_VM_CREATE_FAILED).
VT-x is not available (VERR_VMX_NO_VMX).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Still Dead Build
18309
Last edited by socratis on 8. Jan 2019, 01:35, edited 1 time in total.
Reason: Enclosed the information in [quote] tag for better readability
irak
 
Posts: 10
Joined: 26. Dec 2018, 03:41

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 8. Jan 2019, 01:37

@irak
This is not Twitter, you're not limited to 140 characters. You've got to explain the situation in way more detail, we're not charging people by the character!

Start with what's "nd" for example...
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby RichardT » 8. Jan 2019, 15:49

I get the same VT-X error "VT-x is not available". I am running on Windows 1809 and my two VirtualBox machines are fine when I boot without Hyper-V using "hypervisorlaunchtype off" in a boot option. If Hyper-V is running then neither machine work. One machine is Windows 98.

Richard
RichardT
 
Posts: 3
Joined: 8. Jan 2019, 15:43

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 8. Jan 2019, 17:36

@RichardT
A "me too" won't help, unless we have details (mainly about the CPU). So, we need to see a complete VBox.log, from a complete VM run, where the problem occurs:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby nathaniel515 » 8. Jan 2019, 20:50

To those who are getting the "native API not available" or some other error with hyper v enabled, make sure you're on Windows 10 1809 and have the Windows Hypervisor Platform optional feature enabled (not just hyper-v)
nathaniel515
 
Posts: 5
Joined: 8. Jan 2019, 20:46

Re: VirtualBox 6.0 and Hyper-V

Postby socratis » 8. Jan 2019, 21:26

That's a very, very good point "nathaniel515", I'll add the info on the first post! 8)
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26934
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: VirtualBox 6.0 and Hyper-V

Postby irak » 9. Jan 2019, 19:40

Sorry socratis and about the nd instead of and .I'm partially Blind
irak
 
Posts: 10
Joined: 26. Dec 2018, 03:41

Re: VirtualBox 6.0 and Hyper-V

Postby irak » 9. Jan 2019, 19:52

Thank you for your responses

I have made sure that the Hypervisor was enabled and I am submitting my log
Attachments
CENT os fail log.zip
(7.04 KiB) Downloaded 42 times
irak
 
Posts: 10
Joined: 26. Dec 2018, 03:41

Re: VirtualBox 6.0 and Hyper-V

Postby RichardT » 10. Jan 2019, 03:31

mpack wrote:Could the last two posters please provide evidence that Hyper-v is installed, enabled and working on your host PCs. I don't use Hyper-v myself, perhaps others can suggest where to look.

I wasn't one of the previous two posters but I have the same problem. The evidence that Hyper-V is installed and running is that I can run my Windows 10 VM which I use quite a bit as it a virtualized version of my previous computer.
RichardT
 
Posts: 3
Joined: 8. Jan 2019, 15:43

Re: VirtualBox 6.0 and Hyper-V

Postby RichardT » 10. Jan 2019, 04:06

I have attached the log as suggested. Since I can reboot without Hyper-V and get to my VMs this isn't critical just inconvenient and disappointing.

Richard
Attachments
VirtualBox 6.0.0 -2019-01-09-20-58-49.zip
(7.22 KiB) Downloaded 35 times
RichardT
 
Posts: 3
Joined: 8. Jan 2019, 15:43

Re: VirtualBox 6.0 and Hyper-V

Postby irak » 16. Jan 2019, 17:42

Any update on this issue please?
irak
 
Posts: 10
Joined: 26. Dec 2018, 03:41

Re: VirtualBox 6.0 and Hyper-V

Postby DanzanRyu » 17. Jan 2019, 04:00

I think I may have the same problem as described in this thread. Just wanted to offer another data point, in case it helps. I am also running on an AMD Ryzen system. Might not be related at all, but I thought I'd mention it just in case.

Also, I verified that Hyper-V was definitely enabled and working by installing and running an Ubuntu 18.04 VM through the Hyper-V console.

After removing Hyper-V from Windows features, VirtualBox returns to normal operation and I can run my VirtualBox VMs without issue.

I am running Windows 10 1809.
Attachments
Debian-2019-01-16-18-02-38.zip
(9.83 KiB) Downloaded 22 times
DanzanRyu
 
Posts: 1
Joined: 17. Jan 2019, 03:49

Re: VirtualBox 6.0 and Hyper-V

Postby BillG » 17. Jan 2019, 05:50

You don't really need to uninstall Hyper-V. All you need to do is prevent the hypervisor from loading. You can do in from bcdedit.

https://derekgusoff.wordpress.com/2012/ ... e-machine/
Bill
BillG
Volunteer
 
Posts: 4194
Joined: 19. Sep 2009, 04:44
Location: Sydney, Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows 7,8,Server

Re: VirtualBox 6.0 and Hyper-V

Postby nathaniel515 » 17. Jan 2019, 06:21

Has anyone actually managed to get any guest to boot up on VirtualBox 6 (with Hyper-V and Windows Hypervisor Framework)? I can get to the Grub menu on an Ubuntu guest but it just goes to a black screen after that and freezes. Windows guests do the same (except no grub menu of course)
nathaniel515
 
Posts: 5
Joined: 8. Jan 2019, 20:46

PreviousNext

Return to VirtualBox on Windows Hosts

Who is online

Users browsing this forum: No registered users and 78 guests