Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Discussions about using Linux guests in VirtualBox.

Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby PeterH17 » 16. Jan 2019, 12:57

I recently updated my copy of VirtualBox to v6 on my Windows 10 PC and started my Ubuntu 16.04 LTS VM which has a text only console.
I then upgraded the Guest Additions to v6.
As son as I did that and rebooted, the display would not update when entering text and the only way to refresh the screen was to click on Manager window and then click back on the VM window to refresh the screen contents.
I uninstalled the Guest Additions and the display now refreshes okay again.

Please fix this for the next release.
PeterH17
 
Posts: 6
Joined: 16. Jan 2019, 12:53
Location: England
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Windows Server, Ubuntu, Linux Mint

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby socratis » 16. Jan 2019, 14:55

We need to see a complete VBox.log, from a complete VM run:
  • Start the VM from cold-boot (not from a paused or saved state) / Observe problem / Shutdown the VM (force close it if you have to).
  • With the VM completely shut down (not paused or saved), right-click on the VM in the VirtualBox Manager and select "Show Log".
  • Save only the first "VBox.log", ZIP it and attach it to your response. See the "Upload attachment" tab below the reply form.
Image


PS. I removed the "Bug:" characterization from the title of your thread. I hate jumping into quick conclusions without enough evidence.
Do NOT send me Personal Messages (PMs) for troubleshooting, they are simply deleted.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
socratis
Site Moderator
 
Posts: 26935
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby PeterH17 » 24. Jan 2019, 12:35

Log of problem with v6 Guest tools on Ubuntu 16.04
Attachments
Ubuntu 16.04 LTS-2019-01-16-10-58-38.log.zip
Virtualbox VBox.log.1 file
(28.96 KiB) Downloaded 11 times
PeterH17
 
Posts: 6
Joined: 16. Jan 2019, 12:53
Location: England
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Windows Server, Ubuntu, Linux Mint

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby PeterH17 » 25. Jan 2019, 17:47

I have tried changing the Graphics Controller from VboxVGA to VMSVGA and that has improved the display refresh.
PeterH17
 
Posts: 6
Joined: 16. Jan 2019, 12:53
Location: England
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Windows, Windows Server, Ubuntu, Linux Mint

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby goodvibes » 28. Jan 2019, 12:43

I have the same problem I think. I had to replace my old PC with ATI HD6970 video card. My new one has a NVIDIA gtx1080 and I'm have trouble getting the display manager (I think) to run under VirtualBox so I'm using ctrl-alt-F2 to get to a console to debug. After I updated guest additions in the console, I have to move the pointer out and back in to the window to get it to refresh.
Host: win10, guest:Ubuntu 16.04.
NVIDIA proprietary drivers were installed while booted native, and the same partition is used in VirtualBox as a raw partition.
goodvibes
 
Posts: 3
Joined: 28. Jan 2019, 12:07
Location: Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Linux

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby goodvibes » 30. Jan 2019, 23:25

Actually, I only have to move the pointer out of the console window for it to refresh.
goodvibes
 
Posts: 3
Joined: 28. Jan 2019, 12:07
Location: Australia
Primary OS: MS Windows 10
VBox Version: PUEL
Guest OSses: Linux

Re: Virtual Box 6 and Ubuntu 16.04 LTS display not refreshing

Postby krthie » 16. Mar 2019, 20:32

I have upgraded to VBox 6.0.4 (from 5.x been running many versions over the years). My Ubuntu 16.04 guest now has this problem. I did upgrade the VGA. (I'm running Windows 10 Home as Host OS).

At start-up the console windows just remains black. After a while, my X server starts and all works fine. Pressing Ctrl-F1 gets me to the console which has the log-in prompt. However, it appears to be frozen, i.e. typing to log in doesn't seem to do anything. However, weirdly I just noticed that the "preview" window on the VBox client does show correctly what is happening, i.e. I can log in, type commands, and shut it down. It's just that the window in the VM doesn't refresh. This turns out to be also be true during startup (i.e. the "preview" windows shows the boot sequence correctly).

I can get my console window to refresh by clicking outside of the VM as mentioned in the previous post.

I also note that I don't see my mouse pointer when it's in console mode and I cannot paste anything inside the console. Everything works fine in the X GUI though (e.g. Ctrl-F7 brings me back to the normal view, switching back to window size I used). Possibly a VGA problem in console mode only?
Attachments
vboxlogs.zip
(52.74 KiB) Downloaded 11 times
krthie
 
Posts: 12
Joined: 22. Aug 2011, 13:37
Primary OS: MS Windows XP
VBox Version: OSE other
Guest OSses: ubuntu


Return to Linux Guests

Who is online

Users browsing this forum: No registered users and 13 guests