Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postings relating to old VirtualBox pre-releases

Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby jthimer » 16. Nov 2018, 07:28

Installed Vbox 6.0.0Beta2 on a Solaris (11.3.35.6.0) host.
I get no audio with the OL7.5 (4.1.12-112.16.4.el7uek) guest.

Host Driver: OSS Audio Driver
Controller: ICH AC97

VirtualBoxGuestAdditions installed
Oracle VM VirtualBox Extensions installed

I get no audio from several Linux guest applications. Testing speakers individually

Applications -> System Tools -> Settings -> Sound

also is negative. No sound on speakers or on head phones.

Collected some diagnostics in attached zip file.

I'll add, that I also do not have audio with 5.2.20 nor 5.2.22 either.

All Vbox versions 5.2.18 and earlier work just fine -- no issues at all with audio
on the guest.
Attachments
s11.3-vbox6.00B2.zip
(32.79 KiB) Downloaded 20 times
jthimer
 
Posts: 1
Joined: 16. Nov 2018, 06:47

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby stes » 20. Dec 2018, 23:06

I can reproduce the problem but have no idea what causes this.

Host : Solaris 11.4 with "audiohd" Solaris driver
Code: Select all   Expand viewCollapse view
# scanpci | grep Audio
 Intel Corporation 82801I (ICH9 Family) HD Audio Controller
# pkg list vbox
NAME (PUBLISHER)                                  VERSION                    IFO
virtualbox/host/vbox (local)                      5.2.18-124319              i--
# pkg list audiohd
NAME (PUBLISHER)                                  VERSION                    IFO
driver/audio/audiohd                              11.4-11.4.0.0.1.15.0       i--

When I test OL 7.5 with vbox 5.2.18 I have audio: I defined a guest with Audio Host Driver set (in Vbox) to 'OSS Driver' and controller set (in Vbox) to 'Intel HD Audio'
Code: Select all   Expand viewCollapse view
$ pactl list short cards
0   alsa_card.pci-0000_00_05.0   module-alsa-card.c
[$ lspci | grep Audio
00:05.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 01)
]$ rpm -q pulseaudio
pulseaudio-10.0-5.el7.x86_64
$ ls /dev/snd
by-path    hwC0D0    pcmC0D0p  pcmC0D1p  seq
controlC0  pcmC0D0c  pcmC0D1c  pcmC0D2c  timer
$ cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.5 (Maipo)
$ paplay /usr/share/sounds/gnome/default/alerts/sonar.ogg

The paplay plays a sound which seems to work when the host is running vbox 5.2.18 ...

With the same guest and same settings using vbox 6.0.0 rc1 on the same host it fails or better said there is no sound but not immediately an error ...
stes
 
Posts: 142
Joined: 28. Apr 2018, 11:07

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby stes » 20. Dec 2018, 23:31

Note that there is a difference : in the case when the host runs,
Code: Select all   Expand viewCollapse view
$ pkg list vbox
NAME (PUBLISHER)                                  VERSION                    IFO
virtualbox/host/vbox (local)                      6.0.0-127378               i--

In that case of Vbox 6.0.0 rc1 on Solaris 11.4 (the case where paplay plays no sound) I note that the "pactl list short cards" gives no results.
Code: Select all   Expand viewCollapse view
[stes@saturn ~]$ uname -a
Linux saturn 3.10.0-862.el7.x86_64 #1 SMP Wed Apr 11 11:40:58 PDT 2018 x86_64 x86_64 x86_64 GNU/Linux
[stes@saturn ~]$ lspci | grep Audio
00:05.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 01)
[stes@saturn ~]$ pactl list short sinks
0   auto_null   module-null-sink.c   s16le 2ch 44100Hz   SUSPENDED
[stes@saturn ~]$ pactl list short cards
[stes@saturn ~]$ paplay /usr/share/sounds/gnome/default/alerts/sonar.ogg
[stes@saturn ~]$ echo -e "\a"

The alert beep works but the paplay gives no sound but note that in the working case of vbox 5.2.18 the guest reported a card while none in the vbox 6.0.0rc1 case.
stes
 
Posts: 142
Joined: 28. Apr 2018, 11:07

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby socratis » 21. Dec 2018, 08:38

I don't know why this isn't in the "Beta/RC" section, moving it there from the "Solaris Hosts", since most of the posts talk about Beta/RC.

You could either reference this thread in a new post under "Solaris Hosts" if you're having an issue with the released 6.0.0. Or if it's fixed, you can add a comment like "Fixed with the released version" so that we can mark the thread as such...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26840
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby stes » 21. Dec 2018, 10:11

I'm not the person who originally alerted about this issue.
Also I tested on a host with Solaris 11.4 not with 11.3. The guest is OL7.5 in both cases but I use the 3.10 kernel and not the UEK kernel.
Anyway I can reproduce the fact that audio in the guest worked with 5.2.18 and not any longer with 6.0.0rc1. I'll try with the 6.0.0 release.
stes
 
Posts: 142
Joined: 28. Apr 2018, 11:07

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby socratis » 21. Dec 2018, 11:25

Sure, it's OK. The post should have been moved originally by one of the mods, that's our "job". It fell through the cracks. Nothing to worry about. I just posted that it was actually moved to another section, we always do that...
If you obfuscate any information requested, I will obfuscate my response. These are virtual UUIDs, not real ones.
Do NOT reply with the "QUOTE" button, please use the "POST REPLY", at the bottom of the form.
socratis
Site Moderator
 
Posts: 26840
Joined: 22. Oct 2010, 11:03
Location: Greece
Primary OS: Mac OS X other
VBox Version: PUEL
Guest OSses: Win(*>98), Linux*, OSX>10.5

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby stes » 21. Dec 2018, 11:29

I upgraded on the Solaris 11.4 host to :
Code: Select all   Expand viewCollapse view
# pkg info vbox
             Name: virtualbox/host/vbox
          Summary: Oracle VM VirtualBox
      Description: A powerful PC virtualization solution
            State: Installed
        Publisher: local
          Version: 6.0.0
           Branch: 127566
   Packaging Date: December 21, 2018 at  9:00:27 AM
Last Install Time: December 21, 2018 at  9:02:37 AM
             Size: 297.17 MB
             FMRI: pkg://local/virtualbox/host/vbox@6.0.0-127566:20181221T090027Z

But on the same guest where audio works with vbox 5.2.18 I have no audio but an error "Failed to drain stream: Timeout" when I run the same guest under VirtualBox 6.0.0

Also the pactl list short cards is now showing a card in this case (despite the fact that there is no audio).

On the guest:
Code: Select all   Expand viewCollapse view
$ pactl info
Server String: unix:/run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 8
Tile Size: 65472
User Name: stes
Host Name: saturn
Server Name: pulseaudio
Server Version: 10.0
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.pci-0000_00_05.0.analog-stereo
Default Source: alsa_input.pci-0000_00_05.0.analog-stereo
Cookie: c6a9:8940
$ pactl list short sinks
0       alsa_output.pci-0000_00_05.0.analog-stereo      module-alsa-card.c     
s16le 2ch 44100Hz       SUSPENDED
$ pactl list short cards
0       alsa_card.pci-0000_00_05.0      module-alsa-card.c
$ paplay /usr/share/sounds/gnome/default/alerts/sonar.ogg
Failed to drain stream: Timeout
$ lspci | grep Audio
00:05.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 01)
stes
 
Posts: 142
Joined: 28. Apr 2018, 11:07

Re: Vbox6.0.0Beta2: No audio with OL7.5 guest on Solaris 11.3 host

Postby stes » 21. Dec 2018, 18:03

A related issue, maybe I should open a new thread, but on the other hand I think it is related to the "No audio on OL7.5" report.

On a Solaris 11.4 host with Intel HD audio I can play audio on the host.

When defining a Solaris 11.3 guest with audio set to "Intel HD Audio" (OSS Audio Driver) on this Solaris 11.4 host,
there is also a difference between vbox 6.0.0 and 5.2.18 on the host.

When the host runs vbox 6.0.0 on the guest "pulseaudio" seems stuck or hanging because it does not reply to "pactl info".

When the host runs vbox 5.2.18 the guest responds (pactl info works) but there is no audio. So in neither case there is audio.

The audio card seems to be detected by the guest:
Code: Select all   Expand viewCollapse view
root@venus:~# scanpci | grep Audio
 Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Con
troller
root@venus:~# ls /dev/sndstat
/dev/sndstat
root@venus:~# ls /dev/dsp
/dev/dsp
root@venus:~# ls -l /dev/dsp*
lrwxrwxrwx   1 root     root           4 Dec 21 15:51 /dev/dsp -> dsp0
lrwxrwxrwx   1 root     root          18 Dec 21 15:51 /dev/dsp0 -> sound/audiohd
:0dsp
root@venus:~# modinfo | grep audiohd
279 fffffffff882b000   9680 306   1  audiohd (AudioHD)
root@venus:~# dmesg | grep audio
Dec 21 16:14:50 venus pseudo: [ID 129642 kern.info] pseudo-device: audio0
Dec 21 16:14:50 venus genunix: [ID 936769 kern.info] audio0 is /pseudo/audio@0
Dec 21 16:15:52 venus pci: [ID 370704 kern.info] PCI-device: pci8384,7680@5, aud
iohd0
Dec 21 16:15:52 venus genunix: [ID 936769 kern.info] audiohd0 is /pci@0,0/pci838
4,7680@5

but using vbox 6.0.0 I get:
Code: Select all   Expand viewCollapse view
stes@venus:~$ pactl info
Connection failure: Timeout

while using vbox 5.2.18
Code: Select all   Expand viewCollapse view
stes@venus:~$ pactl info
Server String: unix:/export/home/stes/.pulse/venus-runtime/native
Library Protocol Version: 23
Server Protocol Version: 23
Is Local: yes
Client Index: 6
Tile Size: 65496
User Name: stes
Host Name: venus
Server Name: pulseaudio
Server Version: 1.1
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: output
Default Source: input
Cookie: 46e7:b26f
stes@venus:~$ pactl list short sinks
0       output  module-oss.c    s16le 2ch 44100Hz       SUSPENDED
1       solaris_output.audio    module-solaris.c        s16le 2ch 44100Hz       
SUSPENDED
stes@venus:~$ pactl list short cards
stes@venus:~$ paplay /usr/share/sounds/gnome/default/alerts/glass.ogg

The paplay doesn't actually play audio even on 5.2.18 but on 6.0.0 the pactl info command is completely nonresponsive.
stes
 
Posts: 142
Joined: 28. Apr 2018, 11:07


Return to Old Beta Postings

Who is online

Users browsing this forum: No registered users and 3 guests